QuiteRSS crashes intermittently

Bug #1833536 reported by William on 2019-06-20
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
qtbase-opensource-src (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

[Impact]
This bug affects QuiteRSS and other Qt applications, like plasma-discover (see https://bugs.kde.org/show_bug.cgi?id=402848) and qbittorrent (see bug 1814375). All they crash with similar stack traces.

[Test Case]
1. Open QuiteRSS.
2. Leave it running for several hours.
3. It should not crash.

[Proposed Fix]
The proposed fix is a backport of the following commit from upstream 5.12 branch: https://code.qt.io/cgit/qt/qtbase.git/commit/?id=e431a3ac027915db

[Regression Potential]
This patch adds an additional check before re-sending the request. Regressions chance is minimal, but the potential regressions may be that the request is not re-sent where it was re-sent with the previous code.

[Original Description]
After opening QuiteRSS it will run until crash happens. This happens intermittently within the hour usually.

(gdb) bt
#0 QHttpNetworkConnectionChannel::sendRequest (this=<optimized out>)
    at access/qhttpnetworkconnectionchannel.cpp:238
#1 0x00007ffff30deca2 in QHttpNetworkConnectionPrivate::_q_startNextRequest (
    this=0x7fff480d4a20) at access/qhttpnetworkconnection.cpp:1015
#2 0x00007ffff2736122 in QObject::event (this=0x7fff48da89b0,
    e=<optimized out>) at kernel/qobject.cpp:1247
#3 0x00007ffff6f2482c in QApplicationPrivate::notify_helper(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#4 0x00007ffff6f2c0f4 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#5 0x00007ffff27069a8 in QCoreApplication::notifyInternal2 (
    receiver=0x7fff48da89b0, event=event@entry=0x7fff494233b0)
    at kernel/qcoreapplication.cpp:1024
#6 0x00007ffff270911d in QCoreApplication::sendEvent (event=0x7fff494233b0,
    receiver=<optimized out>)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:233
#7 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0,
    event_type=event_type@entry=0, data=0x7fff60008e90)
    at kernel/qcoreapplication.cpp:1699
#8 0x00007ffff27096a8 in QCoreApplication::sendPostedEvents (
    receiver=receiver@entry=0x0, event_type=event_type@entry=0)
    at kernel/qcoreapplication.cpp:1553
#9 0x00007ffff27602c3 in postEventSourceDispatch (s=0x7fff48003f10)
    at kernel/qeventdispatcher_glib.cpp:276
#10 0x00007fffece96317 in g_main_context_dispatch ()
   from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007fffece96550 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007fffece965dc in g_main_context_iteration ()
   from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007ffff275f8ef in QEventDispatcherGlib::processEvents (
    this=0x7fff48000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#14 0x00007ffff27049ea in QEventLoop::exec (this=this@entry=0x7fff4fffec60,
    flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#15 0x00007ffff252322a in QThread::exec (this=<optimized out>)
    at thread/qthread.cpp:515
#16 0x00007ffff252816d in QThreadPrivate::start (arg=0x7fff60008a20)
    at thread/qthread_unix.cpp:368
#17 0x00007ffff22646db in start_thread (arg=0x7fff4ffff700)
    at pthread_create.c:463
#18 0x00007ffff19ec88f in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtbase-opensource-src (Ubuntu Bionic):
status: New → Confirmed
Changed in qtbase-opensource-src (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtbase-opensource-src - 5.12.2+dfsg-4ubuntu2

---------------
qtbase-opensource-src (5.12.2+dfsg-4ubuntu2) eoan; urgency=medium

  * Backport upstream patch to fix nullptr dereference in HTTP handler
    (LP: #1833536).

 -- Dmitry Shachnev <email address hidden> Fri, 21 Jun 2019 19:43:18 +0300

Changed in qtbase-opensource-src (Ubuntu):
status: Confirmed → Fix Released
Changed in qtbase-opensource-src (Ubuntu Bionic):
status: Confirmed → In Progress
Changed in qtbase-opensource-src (Ubuntu Disco):
status: New → In Progress

Hello William, or anyone else affected,

Accepted qtbase-opensource-src into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/qtbase-opensource-src/5.12.2+dfsg-4ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in qtbase-opensource-src (Ubuntu Disco):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-disco
Łukasz Zemczak (sil2100) wrote :

Hello William, or anyone else affected,

Accepted qtbase-opensource-src into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/qtbase-opensource-src/5.9.5+dfsg-0ubuntu2.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in qtbase-opensource-src (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic

All autopkgtests for the newly accepted qtbase-opensource-src (5.12.2+dfsg-4ubuntu1.1) for disco have finished running.
There have been regressions in tests triggered by the package. Please visit the sru report page and investigate the failures.

https://people.canonical.com/~ubuntu-archive/pending-sru.html#disco

All autopkgtests for the newly accepted qtbase-opensource-src (5.9.5+dfsg-0ubuntu2.3) for bionic have finished running.
There have been regressions in tests triggered by the package. Please visit the sru report page and investigate the failures.

https://people.canonical.com/~ubuntu-archive/pending-sru.html#bionic

Dmitry Shachnev (mitya57) wrote :

Hi Łukasz,

For disco, all autopkgtests are passing now.

For bionic, the only failing package is kdeconnect. These failures are caused by OpenSSL update to 1.1.1, not by Qt update. Also, it is a bug in tests, not in real code. It was fixed upstream yesterday in https://invent.kde.org/kde/kdeconnect-kde/merge_requests/42. As it is a bug in tests, I would ignore it.

Dmitry Shachnev (mitya57) wrote :

Dear William and Brian,

Please test the updated Qt packages in -proposed and let us know your results and the version you tested with. Without this the update will not be released.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers