Drag and drop not working from Qt to some applications

Bug #1577313 reported by Timo Jyrinki on 2016-05-02
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
qtbase-opensource-src (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

[Impact]

Drag and drop broken from Qt application to some applications like Chromium and Emacs.

[Test Case]

See above.

[Regression Potential]

Drag and drop in general should be tested. The fixes have been merged to upstream Qt LTS release.

--

https://codereview.qt-project.org/#/c/150641/
https://codereview.qt-project.org/#/c/157683/

As requested on Kubuntu mailing list https://lists.ubuntu.com/archives/kubuntu-devel/2016-May/010420.html

description: updated
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtbase-opensource-src - 5.5.1+dfsg-16ubuntu10

---------------
qtbase-opensource-src (5.5.1+dfsg-16ubuntu10) yakkety; urgency=medium

  * debian/patches/Blacklist-Mali-T760-Mali-T720-from-supporting-BGRA.patch
    - Backport from upstream 5.6 (LP: #1557915) (LP: #1559906)
  * Add two patches from stable Qt 5.6 branch to fix another case of
    QXcbWindow crashes (LP: #1571158).
    - debian/patches/Fix-crash-because-of-NULL-screen-in-QXcbWindow.patch
    - debian/patches/QtGui-Don-t-set-a-screen-to-a-child-window.patch
  * Fix drag and drop issues with patches from upstream. (LP: #1577313)
    - debian/patches/xcb-Fix-drag-and-drop-to-Emacs.patch
    - debian/patches/xcb-Fix-drag-and-drop-to-applications-like-Emacs-and.patch

 -- Timo Jyrinki <email address hidden> Mon, 02 May 2016 07:46:50 +0000

Changed in qtbase-opensource-src (Ubuntu):
status: New → Fix Released
Vitaliy Gorbunov (vit-gorbunov) wrote :

I can confirm that bug is fixed for chromium and emacs. Also I tested drag and drop in general with other applications and didn't find any issue.
Thanks again to Timo and all involved for such quick response to my request.

FYI: Bug seems to be not completely fixed on qt side, because it still doesn't work for skype. But I will report it to Qt tracker.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtbase-opensource-src (Ubuntu Xenial):
status: New → Confirmed

Hello Timo, or anyone else affected,

Accepted qtbase-opensource-src into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/qtbase-opensource-src/5.5.1+dfsg-16ubuntu7.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in qtbase-opensource-src (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

Tested in comment #2 with the same binaries. (more testing always welcome of course)

tags: added: verification-done
removed: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

Sorry, obviously not same binaries, just identical patches in yakkety. I have now also tested the drag and drop between various mentioned applications and eg kate text editor in xenial + ubuntu7.1 packages.

Vitaliy Gorbunov (vit-gorbunov) wrote :

Tested with libqt5gui5/xenial-proposed as well. Works perfectly.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtbase-opensource-src - 5.5.1+dfsg-16ubuntu7.1

---------------
qtbase-opensource-src (5.5.1+dfsg-16ubuntu7.1) xenial; urgency=medium

  * debian/patches/Blacklist-Mali-T760-Mali-T720-from-supporting-BGRA.patch
    - Backport from upstream 5.6 (LP: #1557915) (LP: #1559906)
  * Add two patches from stable Qt 5.6 branch to fix another case of
    QXcbWindow crashes (LP: #1571158).
    - debian/patches/Fix-crash-because-of-NULL-screen-in-QXcbWindow.patch
    - debian/patches/QtGui-Don-t-set-a-screen-to-a-child-window.patch
  * Fix drag and drop issues with patches from upstream. (LP: #1577313)
    - debian/patches/xcb-Fix-drag-and-drop-to-Emacs.patch
    - debian/patches/xcb-Fix-drag-and-drop-to-applications-like-Emacs-and.patch

 -- Timo Jyrinki <email address hidden> Mon, 02 May 2016 12:24:35 +0000

Changed in qtbase-opensource-src (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for qtbase-opensource-src has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers