bgra support broken on Mali T720

Bug #1559906 reported by Timo Jyrinki on 2016-03-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Zoltan Balogh
qtbase-opensource-src (Ubuntu)
Undecided
Timo Jyrinki
Xenial
Undecided
Unassigned
qtbase-opensource-src (Ubuntu RTM)
Critical
Timo Jyrinki

Bug Description

[Impact]

Black screenshots on certain mobile chipsets.

[Test Case]

Take a screenshot on affected mobile product.

[Regression Potential]

Low, only affects the specified chipsets. Already in use on Ubuntu phone and tablet products.

--

It seems the screenshots get black on Mali T720 too (frieza) and thus the bgra should blacklist should be further extended (from bug #1557915 / turbo).

GL_VENDOR = ARM
GL_RENDERER = Mali-T720
GL_VERSION = OpenGL ES 3.1

Upstream merged commit: https://codereview.qt-project.org/#/c/153756/

description: updated
Changed in canonical-devices-system-image:
importance: Undecided → Critical
assignee: nobody → Zoltan Balogh (bzoltan)
milestone: none → ww08-2016
Changed in qtbase-opensource-src (Ubuntu RTM):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Changed in qtbase-opensource-src (Ubuntu):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Changed in qtbase-opensource-src (Ubuntu RTM):
status: New → In Progress
importance: Undecided → Critical
Changed in canonical-devices-system-image:
status: New → In Progress
description: updated
Timo Jyrinki (timo-jyrinki) wrote :

This is now available for testing from silo 057.

Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package qtbase-opensource-src 5.4.1+dfsg-2ubuntu11~vivid7 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

qtbase-opensource-src (5.4.1+dfsg-2ubuntu11~vivid7) vivid; urgency=medium

  * debian/patches/Skip-Mali-T720-OpenGL-ES-3.1-for-m10.patch:
    - Skip bgra support on Mali T720. (LP: #1559906)

 -- Timo Jyrinki <email address hidden> Mon, 21 Mar 2016 08:07:54 +0000

Changed in qtbase-opensource-src (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

I've also submitted this to upstream and it's in 5.6 (https://codereview.qt-project.org/#/c/153756/), and it is both in my 5.5 and 5.6 branches but just not published to Ubuntu archives.

Changed in qtbase-opensource-src (Ubuntu):
status: New → Fix Committed
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtbase-opensource-src - 5.5.1+dfsg-16ubuntu10

---------------
qtbase-opensource-src (5.5.1+dfsg-16ubuntu10) yakkety; urgency=medium

  * debian/patches/Blacklist-Mali-T760-Mali-T720-from-supporting-BGRA.patch
    - Backport from upstream 5.6 (LP: #1557915) (LP: #1559906)
  * Add two patches from stable Qt 5.6 branch to fix another case of
    QXcbWindow crashes (LP: #1571158).
    - debian/patches/Fix-crash-because-of-NULL-screen-in-QXcbWindow.patch
    - debian/patches/QtGui-Don-t-set-a-screen-to-a-child-window.patch
  * Fix drag and drop issues with patches from upstream. (LP: #1577313)
    - debian/patches/xcb-Fix-drag-and-drop-to-Emacs.patch
    - debian/patches/xcb-Fix-drag-and-drop-to-applications-like-Emacs-and.patch

 -- Timo Jyrinki <email address hidden> Mon, 02 May 2016 07:46:50 +0000

Changed in qtbase-opensource-src (Ubuntu):
status: Fix Committed → Fix Released

Hello Timo, or anyone else affected,

Accepted qtbase-opensource-src into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/qtbase-opensource-src/5.5.1+dfsg-16ubuntu7.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in qtbase-opensource-src (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

I tried this on my M10 and it seems to work as intended.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtbase-opensource-src - 5.5.1+dfsg-16ubuntu7.1

---------------
qtbase-opensource-src (5.5.1+dfsg-16ubuntu7.1) xenial; urgency=medium

  * debian/patches/Blacklist-Mali-T760-Mali-T720-from-supporting-BGRA.patch
    - Backport from upstream 5.6 (LP: #1557915) (LP: #1559906)
  * Add two patches from stable Qt 5.6 branch to fix another case of
    QXcbWindow crashes (LP: #1571158).
    - debian/patches/Fix-crash-because-of-NULL-screen-in-QXcbWindow.patch
    - debian/patches/QtGui-Don-t-set-a-screen-to-a-child-window.patch
  * Fix drag and drop issues with patches from upstream. (LP: #1577313)
    - debian/patches/xcb-Fix-drag-and-drop-to-Emacs.patch
    - debian/patches/xcb-Fix-drag-and-drop-to-applications-like-Emacs-and.patch

 -- Timo Jyrinki <email address hidden> Mon, 02 May 2016 12:24:35 +0000

Changed in qtbase-opensource-src (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for qtbase-opensource-src has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers