Duplicate menu (both unity and in-app) for Qt5 apps

Bug #1436405 reported by Egmont Koblinger on 2015-03-25
64
This bug affects 11 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
appmenu-qt5 (Ubuntu)
Medium
Unassigned
qtbase-opensource-src (Ubuntu)
Medium
Unassigned

Bug Description

At least konsole and khelpcenter suffers from this bug:

Start the app inside the default Unity environment (not under KDE). Notice that the app's menubar appears twice. Once in the upper row of the whole desktop, as expected and as it is for every Gnome app. And also inside the application's window, wasting precious screen real estate.

In Utopic, at least for konsole, I'm quite sure that the menu wasn't duplicated inside the app, it only appeared on the desktop's top Unity bar.

(I'm not sure I guessed the component right; please reassign as appropriate.)

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: libdbusmenu-qt5 0.9.3+14.10.20140619-0ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-10.10-generic 3.19.2
Uname: Linux 3.19.0-10-generic x86_64
ApportVersion: 2.16.2-0ubuntu4
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Mar 25 16:33:14 2015
InstallationDate: Installed on 2012-05-30 (1028 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
SourcePackage: libdbusmenu-qt
UpgradeStatus: Upgraded to vivid on 2015-03-17 (7 days ago)

Egmont Koblinger (egmont-gmail) wrote :
Changed in libdbusmenu-qt (Ubuntu):
status: New → Confirmed
Changed in hundredpapercuts:
status: New → Confirmed
Changed in hundredpapercuts:
importance: Undecided → Medium
Changed in libdbusmenu-qt (Ubuntu):
importance: Undecided → Medium
Albert Astals Cid (aacid) wrote :

do you have appmenu-qt5 installed? it creates some issues when used outside of unity, but if you're using only unity i think it fixes this issue.

Egmont Koblinger (egmont-gmail) wrote :

I do have appmenu-qt5 installed. If I remove the package, the menu inside konsole's window remains, and the one in Unity's top bar vanishes. Clearly not the direction in which I'd expect the duplicate menu issue to be resolved.

Adolfo Jayme (fitojb) on 2015-07-30
summary: - Duplicate menu (both unity and in-app) for kde apps
+ Duplicate menu (both unity and in-app) for Qt apps
sanket (sanketjn210) on 2015-10-06
Changed in libdbusmenu-qt (Ubuntu):
assignee: nobody → sanket (sanketjn210)

I have the same issue on Ubuntu Wily, with quasselclient, a Qt5 application.

The menu shows both in the global app menu and at the top of the window.

When I start using "UBUNTU_MENUPROXY=0 quasselclient", the menu will only show in the window but not the global menu area.

However I'd prefer the opposite, only the global menu showing.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in appmenu-qt5 (Ubuntu):
status: New → Confirmed
Changed in appmenu-qt5 (Ubuntu):
importance: Undecided → Medium
sanket (sanketjn210) wrote :

The attachment "smime.p7s" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Turbid (turbidit) wrote :

I confirm this bug at Ubuntu 16.04 and kdenlive app.

Gabriel Ionescu (justoneslave) wrote :

So far I found this bug in the following applications:

Kdenlive
Krita3
Smplayer (qt5 version) after coming back from fullscreen
Digikam (luckily Digikam has an option to hide the menubar)

summary: - Duplicate menu (both unity and in-app) for Qt apps
+ Duplicate menu (both unity and in-app) for Qt5 apps

VirtualBox is affected by this. When I comment out calls to menuBar()->setVisible() in the VirtualBox source the duplicate menu bar goes away.

Nick Dedekind (nick-dedekind) wrote :

I believe the issue may lie with Qt. QMenuBar only supports "native" menu bars in OSX & windows CE as stated in http://doc.qt.io/qt-5/qmenubar.html#nativeMenuBar-prop

This causes calls to QMenuBar::setVisible to fall through to QWidget::setVisible which then sets the menu bar visual component of the app window to visible.

Nick Dedekind (nick-dedekind) wrote :
Dmitry Shachnev (mitya57) wrote :
affects: libdbusmenu-qt (Ubuntu) → qtbase-opensource-src (Ubuntu)
Changed in qtbase-opensource-src (Ubuntu):
assignee: sanket (sanketjn210) → nobody
Dmitry Shachnev (mitya57) wrote :

The patch from that linked codereview was applied in qtbase 5.6.1+dfsg-3ubuntu5~1 (thanks Timo for taking care of it).

Changed in qtbase-opensource-src (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers