Kubuntu Vivid - unable to display Gujarati Text

Bug #1426942 reported by JantarMantar on 2015-03-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qtbase-opensource-src (Ubuntu)
Undecided
Timo Jyrinki

Bug Description

Applications built with qt5/KDE Framework 5 on Kubuntu Vivid Beta 1 can no longer render Gujarati script. This is probably due to

https://bugreports.qt.io/browse/QTBUG-44568

My Platform:
Kubuntu Vivid Beta 1

Packages affected: Any package built with Qt5 5.4 (e.g. konsole, Muon Package Manager etc)

Expected:
Render Gujarati script correctly (as was the case in Kubuntu versions prior to 15.04)

Actual Results:
Gujarati glyphs are displayed as squares

The above Qt bug is scheduled to be fixed in Qt 5.5. If Kubuntu Vivid is going to ship with Qt 5.4, will it be possible to include a patched Qt5.4 to resolve this specific bug?

Ross Gammon (rosco2) on 2015-03-01
Changed in qtbase-opensource-src (Ubuntu):
status: New → Confirmed
Timo Jyrinki (timo-jyrinki) wrote :

There's Qt 5.4.1 brewing, but since it's currently blocked by a bug I'll include this in another 5.4.0 qtbase upload if it seems the blocker bug isn't seeing a fix soon.

Changed in qtbase-opensource-src (Ubuntu):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
status: Confirmed → Triaged
Changed in qtbase-opensource-src (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtbase-opensource-src - 5.4.1+dfsg-2ubuntu3

---------------
qtbase-opensource-src (5.4.1+dfsg-2ubuntu3) vivid; urgency=medium

  * New upstream release. (LP: #1427560)
  * Remove patches that are included in upstream:
    - debian/patches/Add-C++11-if-available-for-QVariant-autotest.patch
    - debian/patches/Break-after-handling-the-read-write.patch
    - debian/patches/Qt-should-not-print-warning-unless-we-have-an-API-mi.patch
    - debian/patches/QtBearer-networkmanager-make-sure-to-set-flag-Active.patch
    - debian/patches/Refactor-networkmanager-QtBearer-backend-to-use-QDBu.patch
    - debian/patches/Resolve-GLES3-functions-from-the-shared-lib.patch
    - debian/patches/qimage_conversions.cpp-Fix-build-on-big-endian-syste.patch
    - debian/patches/upstream_Handle-SelectionClientClose-in-QXcbClipboard.patch
  * Refresh patches:
    - load_testability_from_env_var.patch
    - enable_tests.patch
  * Merge with Debian 5.4.1+dfsg-2
  * Update symbols and mark private ones private using the improved script.
  * debian/patches/Correct-typo-in-the-Gujarati-openType-identififer.patch:
    - Fix Gujarati text (LP: #1426942)
 -- Timo Jyrinki <email address hidden> Tue, 10 Mar 2015 05:51:18 +0000

Changed in qtbase-opensource-src (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers