Fix crash in QNetworkAccessCacheBackend::closeDownstreamChannel

Bug #1371472 reported by Albert Astals Cid on 2014-09-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qtbase-opensource-src (Ubuntu)
Undecided
Timo Jyrinki

Bug Description

Patch is not yet accepted upstream but i have confirmed it fixes crashes we are seeing at https://bugs.launchpad.net/ubuntu/+source/unity8/+bug/1370385

Patch can be found at https://codereview.qt-project.org/#/c/95245/

Changed in qtbase-opensource-src (Ubuntu):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Albert Astals Cid (aacid) wrote :

Btw it's been approved upstream but not yet merged since their CI seems broken.

Changed in qtbase-opensource-src (Ubuntu):
status: New → In Progress
Albert Astals Cid (aacid) wrote :

FWIW This has now been merged upstream

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtbase-opensource-src - 5.3.0+dfsg-2ubuntu8

---------------
qtbase-opensource-src (5.3.0+dfsg-2ubuntu8) utopic; urgency=medium

  * Update arm64, powerpc and ppc64el symbols

qtbase-opensource-src (5.3.0+dfsg-2ubuntu7) utopic; urgency=medium

  * Fix-crash-in-QNetworkAccessCacheBackend-closeDownstr.patch:
    - Cherry-pick a fix from upstream (LP: #1371472)
  * enable-tests.patch: skip an additional test that has started failing
    even on no-change rebuild
  * Update symbols (gcc 4.9)
 -- Timo Jyrinki <email address hidden> Mon, 29 Sep 2014 04:07:58 +0000

Changed in qtbase-opensource-src (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers