[FFe] Qt 5.1.1

Bug #1219695 reported by Timo Jyrinki on 2013-09-02
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
qtbase-opensource-src (Ubuntu)
Undecided
Unassigned
qtdeclarative-opensource-src (Ubuntu)
Undecided
Unassigned
qtgraphicaleffects-opensource-src (Ubuntu)
Undecided
Unassigned
qtimageformats-opensource-src (Ubuntu)
Undecided
Unassigned
qtjsbackend-opensource-src (Ubuntu)
Undecided
Unassigned
qtmultimedia-opensource-src (Ubuntu)
Undecided
Unassigned
qtquick1-opensource-src (Ubuntu)
Undecided
Unassigned
qtscript-opensource-src (Ubuntu)
Undecided
Unassigned
qtsensors-opensource-src (Ubuntu)
Undecided
Unassigned
qtsvg-opensource-src (Ubuntu)
Undecided
Unassigned
qttools-opensource-src (Ubuntu)
Undecided
Unassigned
qttranslations-opensource-src (Ubuntu)
Undecided
Unassigned
qtwebkit-opensource-src (Ubuntu)
Undecided
Unassigned
qtxmlpatterns-opensource-src (Ubuntu)
Undecided
Unassigned

Bug Description

Dear Release Team,

I'd like to request FFe for Qt 5.1.1 and its release modules. It was discussed during vUDS (https://blueprints.launchpad.net/ubuntu/+spec/client-1308-qt51) and the consensus was that we would be better off with 5.1.1 than staying with 5.0.2.

Qt 5.1.1 fixes numerous bugs like non-English inputting on desktop QML apps (like Friends app), long-standing bugs in the low-level rendering loop resulting in improved stability identified by our developers, and new functionality that makes it possible for example to drop current QtWebKit Device Pixel Ratio patch.

Before any uploads would happen, the QA team will validate the release by running tests on both desktop and touch device, so that no unacceptable regressions remain. Testing will involve automated autopilot runs and manual testing. Already a lot of developers are running 5.1.1 on desktop and Touch. The currently known problems are listed at https://bugs.launchpad.net/bugs/+bugs?field.tag=qt5.1 - as of this writing all of them besides one obsolete package have assigned people who now have them as priority fixes.

The PPA with testable 5.1.1 packages for desktop/touch is ppa:canonical-qt5-edgers/qt5-beta-proper (https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta-proper). The packages are snapshots from the release branch from 20130820, with the only change not in those upstream tarballs being a Mac OS related commit to qtbase.

The Work-In-Progress PPA with final tarballs, more syncing/polishing and more modules will land to ppa:canonical-qt5-edgers/qt5-beta2 at the moment - these will be copied on top of qt5-beta-proper when they are finalized. Also qt5-daily PPA has been used before the latest sync round with Debian.

The list of packages (and the upload order) to be upgraded to 5.1.1 are:

U) lp:~kubuntu-packagers/kubuntu-packaging/qtbase-opensource-src
T) lp:~kubuntu-packagers/kubuntu-packaging/qttools-opensource-src
*) lp:~kubuntu-packagers/kubuntu-packaging/qtjsbackend-opensource-src
*) lp:~kubuntu-packagers/kubuntu-packaging/qtxmlpatterns-opensource-src
*) lp:~kubuntu-packagers/kubuntu-packaging/qtscript-opensource-src
*) lp:~kubuntu-packagers/kubuntu-packaging/qtsvg-opensource-src
U) lp:~kubuntu-packagers/kubuntu-packaging/qtdeclarative-opensource-src
T) lp:~kubuntu-packagers/kubuntu-packaging/qtgraphicaleffects-opensource-src
T) lp:~kubuntu-packagers/kubuntu-packaging/qtmultimedia-opensource-src
*) lp:~kubuntu-packagers/kubuntu-packaging/qtsensors-opensource-src
U) lp:~kubuntu-packagers/kubuntu-packaging/qtwebkit-opensource-src
T) lp:~kubuntu-packagers/kubuntu-packaging/qtquick1-opensource-src
*) lp:~kubuntu-packagers/kubuntu-packaging/qtquickcontrols-opensource-src (NEW)
*) lp:~kubuntu-packagers/kubuntu-packaging/qtimageformats-opensource-src
*) lp:~kubuntu-packagers/kubuntu-packaging/qtwebkit-examples-opensource-src (NEW)
*) lp:~kubuntu-packagers/kubuntu-packaging/qttranslations-opensource-src
U) lp:~kubuntu-packagers/kubuntu-packaging/qtdoc-opensource-src (NEW)
*) lp:~kubuntu-packagers/kubuntu-packaging/qtx11extras-opensource-src (NEW)

Additionally pkg-kde-tools 0.15.8 (a single commit) should be merged to Ubuntu's pkg-kde-tools as part of this, to allow unchanged qtscript sync.

The branches marked with "*" are non-modified packages from Debian that will be synced from Debian if 5.1.1 releases are available in unstable when the time comes.

The rest of the branches differ from Debian for one of the two reasons:
T) Package name transitions from raring, otherwise similar to Debian
U) Ubuntu / Touch specific changes. Much smaller delta than during 5.0.x.

Summaries of "U" branch changes (current status):
- qtbase: aarch64 support, some intentional Qt4 era differences on databases supported, our raring solution to Qt4 supporting that does not require rebuilds, additional multi-arch packages, documentation packages that have been temporarily disabled in Debian (the bootstrapping methods non-optimal but works for us), four additional patches (two backported from 5.2, one submitted for upstreaming, one small (6 lines) Ubuntu specific patch related to disabling overlay bars).
- qtdeclarative: One patch backported from upstream.
- qtwebkit: Additional snapshot module dependencies for extra features, keeping of private headers needed by webbrowser-app, two backported patches.
- qtdoc: Building also qtbase and qtwebkit-examples docs.

All branches either already are or will be rebased on Debian 5.1.x packaging.

If the new Qt would be uploaded, Touch will continue to function after four package rebuilds on top of the new Qt - this is currently done at qt5-beta-proper with Launchpad recipes. Other rebuilds and bug fixes are expected. On the desktop side Qt Creator and the few existing Qt5 applications will continue to work.

More details on the migration are in the google doc at https://docs.google.com/a/canonical.com/spreadsheet/ccc?key=0AjuCdq68GSyVdFI4QzNQdWpfME5aMEV2VXo0cUpOMkE#gid=15

Build logs are available at https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta-proper/+packages?field.name_filter=&field.status_filter=published&field.series_filter=saucy + the newest currently at https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta2/+packages?field.name_filter=&field.status_filter=published&field.series_filter=saucy

Summary changelogs for the 5.1.0 and 5.1.1 upstream releases attached as a tarball (Qt_5.1.1_changelogs.tar.xz). The detailed changelogs for all commits may be a bit large to be meaningfully gone through, but can be provided. Notes: qtjsbackend, qtwebkit, qttranslations do not provide a (usable) changelog summary. qtsensors is essentially 5.1.0 already in the archives because of a previous snapshot. Many of the smaller modules just state 'only minor changes' in their changelogs.

Dist-upgrade log with Ubuntu saucy having ubuntu-sdk installed attached (using the ~20130820 qt5-beta-proper packages).

Timo Jyrinki (timo-jyrinki) wrote :
Timo Jyrinki (timo-jyrinki) wrote :
description: updated
description: updated

Are there any downsides to updating pkg-kde-tools in conjunction with this FFe and keeping the diff minimized?

description: updated

All of the packages listed as being in Debian New are out and accepted into
Debian.

Timo Jyrinki (timo-jyrinki) wrote :

No, I don't see downsides to updating pkg-kde-tools. The delta is essentially this commit http://anonscm.debian.org/gitweb/?p=pkg-kde/pkg-kde-tools.git;a=commitdiff;h=bd3ddd5ae38ee392f10ac7f255676372f14d63b7 since Ubuntu already has 0.15.7ubuntu4. 0.15.8ubuntu1 would thus be needed:

The NEW packages in the list now reflect packages that are new to Ubuntu.

Scott Kitterman (kitterman) wrote :

OK. I think we should include updating pkg-kde-tools in this FFe and keep the overall diff down. From a release perspective, I think this update makes sense. Are the product managers for ubuntu-desktop and touch on board with this? This will affect both their efforts so I think they should weigh in.

description: updated
Bill Filler (bfiller) wrote :

I'm good with the switch as long as we perform proper testing and can validate that both manual image testing and autopilot testing don't turn up any significant issues.

Jonathan Riddell (jr) wrote :

Useful for Unity and Kubuntu, issue well researched with an eye to problems, thanks for a good FFe request, approved.

Changed in qtbase-opensource-src (Ubuntu):
status: New → Confirmed
Changed in qtdeclarative-opensource-src (Ubuntu):
status: New → Confirmed
Changed in qtgraphicaleffects-opensource-src (Ubuntu):
status: New → Confirmed
Changed in qtimageformats-opensource-src (Ubuntu):
status: New → Confirmed
Changed in qtjsbackend-opensource-src (Ubuntu):
status: New → Confirmed
Changed in qtmultimedia-opensource-src (Ubuntu):
status: New → Confirmed
Changed in qtquick1-opensource-src (Ubuntu):
status: New → Confirmed
Changed in qtscript-opensource-src (Ubuntu):
status: New → Confirmed
Changed in qtsensors-opensource-src (Ubuntu):
status: New → Confirmed
Changed in qtsvg-opensource-src (Ubuntu):
status: New → Confirmed
Changed in qttools-opensource-src (Ubuntu):
status: New → Confirmed
Changed in qttranslations-opensource-src (Ubuntu):
status: New → Confirmed
Changed in qtwebkit-opensource-src (Ubuntu):
status: New → Confirmed
Changed in qtxmlpatterns-opensource-src (Ubuntu):
status: New → Confirmed
Timo Jyrinki (timo-jyrinki) wrote :

The NEW packages qtquickcontrols, qtwebkit-examples and qtx11extras are newly released modules by upstream, and would be useful to have in universe. qtdoc existed before but was not uploaded to Ubuntu before - it's useful to have complete offline documentation.

Scott Kitterman (kitterman) wrote :

Syncing the new packages from Debian is fine.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtdoc-opensource-src (Ubuntu):
status: New → Confirmed
Changed in qtquickcontrols-opensource-src (Ubuntu):
status: New → Confirmed
Changed in qtx11extras-opensource-src (Ubuntu):
status: New → Confirmed
Scott Kitterman (kitterman) wrote :

We start final beta freeze on Friday. This needs to happen before then or not at all (frankly, I think it's probably too late already).

Timo Jyrinki (timo-jyrinki) wrote :

Yes, sorry for not yet updating this earlier, too many things in flight.

The amount of unfixed regressions and so many other things to land has lead us to (unfortunately) postpone Qt 5.1 until t-series opens. We're trying to get QtWebkit 5.1.1 alone in, compiled against 5.0.2, which has been now tested and shows very good results.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtwebkit-opensource-src - 5.1.1-1ubuntu2

---------------
qtwebkit-opensource-src (5.1.1-1ubuntu2) saucy; urgency=low

  * Drop libwebp-dev dependency and disable it, not in main.
 -- Timo Jyrinki <email address hidden> Thu, 19 Sep 2013 16:18:00 +0300

Changed in qtwebkit-opensource-src (Ubuntu):
status: Confirmed → Fix Released
Scott Kitterman (kitterman) wrote :

That's it, right?

Changed in qtbase-opensource-src (Ubuntu):
status: Confirmed → Won't Fix
Changed in qtdeclarative-opensource-src (Ubuntu):
status: Confirmed → Won't Fix
Timo Jyrinki (timo-jyrinki) wrote :

It surfaced there is also possibility for qtmultimedia, tested separately by the multimedia team. Let's see if we get it in still today.

Scott Kitterman (kitterman) wrote :

qtmultimedia or qtmultimedia-fork?

Timo Jyrinki (timo-jyrinki) wrote :

After some tinkering, it looks like what would be wanted would be https://code.launchpad.net/~phablet-team/phablet-extras/qtmultimedia-touch - it seems it's indeed a fork with different package names as well. I originally thought it'd be just some simple patches.

Timo Jyrinki (timo-jyrinki) wrote :

Ok, so no qtmultimedia under this FFe. The 5.0.2 stays in the archive. If there'll be a GStreamer 1.0 supporting renamed qtmultimedia-touch, it'll be under different FFe.

Changed in qtxmlpatterns-opensource-src (Ubuntu):
status: Confirmed → Won't Fix
Changed in qttranslations-opensource-src (Ubuntu):
status: Confirmed → Won't Fix
Changed in qttools-opensource-src (Ubuntu):
status: Confirmed → Won't Fix
Changed in qtsvg-opensource-src (Ubuntu):
status: Confirmed → Won't Fix
Changed in qtsensors-opensource-src (Ubuntu):
status: Confirmed → Won't Fix
Changed in qtscript-opensource-src (Ubuntu):
status: Confirmed → Won't Fix
Changed in qtquick1-opensource-src (Ubuntu):
status: Confirmed → Won't Fix
Changed in qtmultimedia-opensource-src (Ubuntu):
status: Confirmed → Won't Fix
Changed in qtjsbackend-opensource-src (Ubuntu):
status: Confirmed → Won't Fix
Changed in qtimageformats-opensource-src (Ubuntu):
status: Confirmed → Won't Fix
Changed in qtgraphicaleffects-opensource-src (Ubuntu):
status: Confirmed → Won't Fix
no longer affects: qtdoc-opensource-src (Ubuntu)
no longer affects: qtquickcontrols-opensource-src (Ubuntu)
no longer affects: qtx11extras-opensource-src (Ubuntu)
Ricardo Salveti (rsalveti) wrote :

It'd be good actually to also bump qtmultimedia to use the released 5.1.1 version, as the fork one is based on 5.1.1 as well.

That way we know the version used by touch shares the same base from the original package available in the archive.

Loïc Minier (lool) wrote :

It seems safer indeed if qtmultimedia-touch and qtmultimedia share the same source level.

Scott Kitterman (kitterman) wrote :

I disagree. The forked qtmultimedia was allowed on the basis of it's use case being completely disjoint from the desktop package. We only let qtwebkit in on it's own after testing to verify that there were no regressions and that specific bugs seen in Ubuntu were fixed. Nack on updating qtmultimedia-opensource-src.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers