Fails to build on PowerPC

Bug #1125949 reported by Timo Jyrinki on 2013-02-15
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
qtbase-opensource-src (Ubuntu)
High
Matthias Klose
Raring
High
Matthias Klose

Bug Description

See build log at:

https://launchpadlibrarian.net/131243410/buildlog_ubuntu-raring-powerpc.qtbase-opensource-src_5.0.1%2Bdfsg-0ubuntu1_FAILEDTOBUILD.txt.gz

Similar problems have seemingly been there with other packages in the past, but it's not immediately certain what would be the proper cure.

Changed in qtbase-opensource-src (Ubuntu):
status: New → Triaged
Matthias Klose (doko) wrote :

@timo: just having a build log with an error message is not status triaged.

this is caused by a macro B0 defined in the glibc headers, bits/termios.h, included by termios.h. The macro does exist on x86 too, so wondering why the issue isn't seen there.

include order is
. ../../mkspecs/linux-g++/qplatformdefs.h
.. /usr/include/powerpc-linux-gnu/sys/ioctl.h
... /usr/include/powerpc-linux-gnu/bits/ioctl-types.h
.... /usr/include/termios.h
..... /usr/include/powerpc-linux-gnu/bits/termios.h

qprinter.h already has an undef, which is missing in qpagedpaintdevice.h.

No comment about using a two letter capital identifier in an API, and not just one ...

Changed in qtbase-opensource-src (Ubuntu Raring):
assignee: nobody → Matthias Klose (doko)
importance: Undecided → High
milestone: none → ubuntu-13.04-beta-1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtbase-opensource-src - 5.0.1+dfsg-0ubuntu2

---------------
qtbase-opensource-src (5.0.1+dfsg-0ubuntu2) raring; urgency=low

  * Undefined B0 in qpagedpaintdevice.h too (already done in qprinter.h).
    No comment on using two letter capital identifiers as enum values in
    a public API. LP: #1125949.
 -- Matthias Klose <email address hidden> Mon, 18 Feb 2013 21:42:15 +0100

Changed in qtbase-opensource-src (Ubuntu Raring):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers