Ubuntu

Patch Qt to fix annoying KDE bug 275469 (ghost taskbar entries)

Reported by Nikola Snele on 2012-01-04
66
This bug affects 12 people
Affects Status Importance Assigned to Milestone
qt4-x11 (Ubuntu)
High
Fathi Boudra

Bug Description

KDE bug 275469 ( https://bugs.kde.org/show_bug.cgi?id=275469 ) is caused by Qt bug.

Steps to reproduce bug:
1) Close all applications and open Firefox (or any other app).
2) Close Firefox by clicking on the window manager close button (X), but make
sure your mouse doesn't move at all in the process. Firefox should close
cleanly without any ghost entries.
3) Now, start Firefox again.
4) Close Firefox using the same button, but try to move the mouse very quickly
to and from the button while pressing it. On my system, I get a ghost entry
almost every time I do this.

There are 3 patches which are fixing the bug. One can find them here:
http://bugs.kde.org/show_bug.cgi?id=275469 , comment #173. Please patch Qt for precise (and oneiric if it is possible) to workaround this annoying bug.

Thank you.

Related branches

Nikola Snele (n-schnelle) wrote :

Patches which are confirmed in KDE bug report to fix the problem are:

For Qt-4.7.4 : https://bugs.kde.org/show_bug.cgi?id=275469#c133

For Qt-4.8.0: https://bugs.kde.org/attachment.cgi?id=67168

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/911733/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
affects: ubuntu → qt4-x11 (Ubuntu)
Fathi Boudra (fboudra) on 2012-01-06
Changed in qt4-x11 (Ubuntu):
assignee: nobody → Fathi Boudra (fboudra)
Linuxboy (linuxboy) wrote :

no news on this bug? It is very annoying!

Take a look at the Upstream KDE-bug reference, comment# 179

For the time beeing u can always get rid of this ghosty stuff, with the key combination alt+F2 (Krunner)

Linuxboy (linuxboy) wrote :

@Flames_in_Paradise (ellisistfroh)

You mean comment #176 ?

resolved upstream means that the bug will be solved directly into QT library developing, is this right? This means that no temporary patch will be released by ubuntu team, is this right?

Regards.

@Linuxboy:

Right #175, especially #176. To my personal opinion this should be a QA matter for the Kubuntu Release of PP (I've not been searching for this). I also think everybody from KDE understands that this is a nuisance within the KDE-SC.

As you can read in the KDE-bug thread, the fix will firstly be implemented in QT 5.0 and then backported. People with other distros using KDE-SC may not be happy with this neither, since this bug is accompanying us for quite a while. So, then it's the general question how to fix bugs in the preferably best way. The bugfix itself has to take a testing period as well, since they do not want to make new ones occur alongside; like you & I.

But, I do not speak for the Kubuntu-Team... Just keep in mind that it was not trivial to get this solved yet.

I've uploaded patched qt to my PPA, if someone wants to use it:
https://launchpad.net/~hrvojes/+archive/qt
Precise version is built, oneiric currently building

Nikola Snele (n-schnelle) wrote :

šumski, thank you thank you THANK YOU!

Finally I can use my KDE without this nasty bug.

One warning: After upgrading qt, on first reboot python process was using 50% of CPU. And veromix plasmoid was broken. So I removed veromix, then reinstalled it, and after reboot everything works well. I am using oneiric.

Hvala još jednom :)

Great to see this has arrived in in the Pangolin.

[ubuntu/precise] qt4-x11 4:4.8.0-1ubuntu5 (Accepted) Mon Feb 6 21:21:24 UTC 2012

  [ Martin Pitt ]
  * debian/control: Drop qdbus dependency of libqt4-dbus to a Recommends. The
    library does not actually need qdbus, and this is a cyclic dependency
    which breaks upgrades. (LP: #927637)

  [ Jonathan Riddell ]
  * Add kubuntu_29_window_shaping_fix.diff from
    http://qt.gitorious.org/qt/qt/commit/21713e04160ee285c831fedd1f3c7b8
    ce0aba681 take window shape into account in findRealWindow,
    LP: #926129
 -- Jonathan Riddell <email address hidden> Mon, 06 Feb 2012 19:39:15 +0000

There's no mention of this bug

@Nikola
Nema na čemu! :)

Nikola Snele (n-schnelle) wrote :

I just tested daily build and all task manager bugs are still there. So it seems that Qt is not patched yet.

I will write to kubuntu-devel mailing list to raise awareness about this important fixes.

Btw, with Qt from šumski's ppa, I cannot reproduce any of this task manager bugs.

Nikola Snele (n-schnelle) wrote :

Beta 1 is out and this is still not fixed.

There are 3 patches which are fixing the bug. One can find them here:
http://bugs.kde.org/show_bug.cgi?id=275469 , comment #173.

Fabo please backport these patches :)

description: updated
Fathi Boudra (fboudra) on 2012-03-16
Changed in qt4-x11 (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Fathi Boudra (fboudra) on 2012-03-19
Changed in qt4-x11 (Ubuntu):
milestone: none → ubuntu-12.04-beta-2
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt4-x11 - 4:4.8.0-1ubuntu11

---------------
qt4-x11 (4:4.8.0-1ubuntu11) precise; urgency=low

  * Add patches cherry-picked upstream (LP: #911733):
    - Pass_events_to_eventFilter_first.patch
    - Pass_non-MotionNotify_events_to_event_dispatcher_filters.patch
    - Raise_loopLevel_for_deleteLater_in_event_filters.patch
 -- Fathi Boudra <email address hidden> Mon, 19 Mar 2012 09:06:21 +0200

Changed in qt4-x11 (Ubuntu):
status: Fix Committed → Fix Released
Linuxboy (linuxboy) wrote :

I'm sorry for the question, but I don't understand: this fix will be available only for ubuntu 12.04b2 ?

On 19 March 2012 16:44, Linuxboy wrote:
> I'm sorry for the question, but I don't understand: this fix will be
> available only for ubuntu 12.04b2 ?

The bug was targeted to be fixed for beta2. As I've uploaded the fixed
packages today, it should be available right now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.