Ubuntu

libqt4-network (xmlpatterns, declaritive) upgrade fails

Reported by Scott Moser on 2011-11-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qt4-x11 (Ubuntu)
Undecided
Unassigned

Bug Description

$ sudo dpkg -i /var/cache/apt/archives/libqt4-network_4%3a4.7.4-1ubuntu4_amd64.deb
(Reading database ... 210766 files and directories currently installed.)
Preparing to replace libqt4-network 4:4.7.4-0ubuntu8 (using .../libqt4-network_4%3a4.7.4-1ubuntu4_amd64.deb) ...
Unpacking replacement libqt4-network ...
dpkg: error processing /var/cache/apt/archives/libqt4-network_4%3a4.7.4-1ubuntu4_amd64.deb (--install):
 './usr/share/doc/libqt4-network/LGPL_EXCEPTION.txt' is different from the same file on the system
Errors were encountered while processing:
 /var/cache/apt/archives/libqt4-network_4%3a4.7.4-1ubuntu4_amd64.deb

This occurred for me on upgrade of precise system this morning.

I tried this;
 $ sudo dpkg --force-depends --purge remove libqt4-declarative libqt4-xmlpatterns libqt4-network
 $ sudo apt-get -f install

it still dies like:
(Reading database ... 210749 files and directories currently installed.)
Preparing to replace libqt4-xmlpatterns:i386 4:4.7.4-0ubuntu8 (using .../libqt4-xmlpatterns_4%3a4.7.4-1ubuntu4_i386.deb) ...
Unpacking replacement libqt4-xmlpatterns:i386 ...
Selecting previously unselected package libqt4-xmlpatterns.
Unpacking libqt4-xmlpatterns (from .../libqt4-xmlpatterns_4%3a4.7.4-1ubuntu4_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libqt4-xmlpatterns_4%3a4.7.4-1ubuntu4_amd64.deb (--unpack):
 './usr/share/doc/libqt4-xmlpatterns/LGPL_EXCEPTION.txt' is different from the same file on the system
Selecting previously unselected package libqt4-network.
Unpacking libqt4-network (from .../libqt4-network_4%3a4.7.4-1ubuntu4_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libqt4-network_4%3a4.7.4-1ubuntu4_amd64.deb (--unpack):
 './usr/share/doc/libqt4-network/LGPL_EXCEPTION.txt' is different from the same file on the system
Selecting previously unselected package libqt4-declarative.
Unpacking libqt4-declarative (from .../libqt4-declarative_4%3a4.7.4-1ubuntu4_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libqt4-declarative_4%3a4.7.4-1ubuntu4_amd64.deb (--unpack):
 './usr/share/doc/libqt4-declarative/LGPL_EXCEPTION.txt' is different from the same file on the system
Errors were encountered while processing:
 /var/cache/apt/archives/libqt4-xmlpatterns_4%3a4.7.4-1ubuntu4_amd64.deb
 /var/cache/apt/archives/libqt4-network_4%3a4.7.4-1ubuntu4_amd64.deb
 /var/cache/apt/archives/libqt4-declarative_4%3a4.7.4-1ubuntu4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libqt4-network 4:4.7.4-0ubuntu8 [modified: usr/share/doc/libqt4-network/copyright]
ProcVersionSignature: Ubuntu 3.1.0-2.3-generic 3.1.0
Uname: Linux 3.1.0-2-generic x86_64
ApportVersion: 1.26-0ubuntu1
Architecture: amd64
Date: Mon Nov 28 08:39:25 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: qt4-x11
UpgradeStatus: Upgraded to precise on 2011-11-07 (21 days ago)

Scott Moser (smoser) wrote :
summary: - libqt4-networkupgrade fails
+ libqt4-network upgrade fails
summary: - libqt4-network upgrade fails
+ libqt4-network (xmlpatterns, declaritive) upgrade fails
Scott Moser (smoser) wrote :

Ah, I see the problem:
$ dpkg -S /usr/share/doc/libqt4-network/LGPL_EXCEPTION.txt
libqt4-network:i386: /usr/share/doc/libqt4-network/LGPL_EXCEPTION.txt

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers