The qmltooling/tcpserver plugin is missing

Bug #754942 reported by Richard Dale on 2011-04-08
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
qt4-x11 (Ubuntu)
High
Unassigned

Bug Description

In order to use the QML debugger with Qt Creator a plugin called 'qmltool/tcpserver' is needed. This is missing from the libqt4-dev package in Natty. I built the package from the Qt source for qt4-x1, installed the plugin and it worked fine.

If you try to use Qt Creator QML debugging without the plugin you get a 'Remote debugger plugin has not been found' error. It took me some time to track down the cause of this.

Changed in qt4-x11 (Ubuntu):
status: New → Confirmed
Changed in qt4-x11 (Ubuntu):
importance: Undecided → High
Felix Geyer (debfx) wrote :

Fixed in oneiric.
libqt4-declarative contains /usr/lib/qt4/plugins/qmltooling/libtcpserver.so

Changed in qt4-x11 (Ubuntu):
status: Confirmed → Fix Released
Harald Sitter (apachelogger) wrote :

Could we get an SRU for that? I do not feel much like breaking a production system.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints