current qtopengl breaks virtualbox

Bug #724867 reported by Mingming Ren
174
This bug affects 33 people
Affects Status Importance Assigned to Milestone
qt4-x11 (Ubuntu)
Fix Released
Undecided
Felix Geyer
Natty
Fix Released
Undecided
Felix Geyer

Bug Description

Virtualbox doesn't work with latest qt package in natty.

VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: /usr/lib/virtualbox/VirtualBox.so: undefined symbol: _ZN10QGLContext9tryVisualERK9QGLFormati

Virtualbox works only after downgrade libqt4-opengl package.

Tags: kubuntu
Revision history for this message
Ernst Sjöstrand (ernstp) wrote :

mythfrontend is also broken by this.

Revision history for this message
gfunicus (tsuther) wrote :

Seeing the exact same issue with virtualbox after last night's update.

Jonathan Riddell (jr)
Changed in qt4-x11 (Ubuntu):
milestone: none → natty-alpha-3
tags: added: kubuntu
Revision history for this message
Felix Geyer (debfx) wrote :

4:4.7.1-0ubuntu10 is accidentally built with egl support.

Changed in qt4-x11 (Ubuntu):
status: New → Triaged
Felix Geyer (debfx)
Changed in qt4-x11 (Ubuntu):
assignee: nobody → Felix Geyer (debfx)
status: Triaged → In Progress
Revision history for this message
Le Gluon Du Net (legluondunet) wrote :

same problem here for this morning.

Revision history for this message
Ahmed Kamal (kim0) wrote :

virtualbox stopped working here too

Revision history for this message
Angel Guzman Maeso (shakaran) wrote :

I try this, but it dont work:
$ virtualbox
VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: /usr/lib/virtualbox/VirtualBox.so: undefined symbol: _ZN10QGLContext9tryVisualERK9QGLFormati

$ sudo /etc/init.d/vboxdrv setup
[sudo] password for shakaran:
 * Stopping VirtualBox kernel modules [ OK ]
 * Uninstalling old VirtualBox DKMS kernel modules
Error! There are no instances of module: vboxhost
4.0.4 located in the DKMS tree.
                                                                         [ OK ]
 * Removing old VirtualBox netadp kernel module [ OK ]
 * Removing old VirtualBox kernel module [ OK ]
 * Trying to register the VirtualBox kernel modules using DKMS [ OK ]
 * Starting VirtualBox kernel modules [ OK ]

$ virtualbox
VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: /usr/lib/virtualbox/VirtualBox.so: undefined symbol: _ZN10QGLContext9tryVisualERK9QGLFormati

Then I try to downgrade the package:
sudo aptitude install libqt4-core=4:4.7.0-0ubuntu4

But it dont work too, because the package it is on maverick (I don't know how to downgrade then)

Revision history for this message
Mingming Ren (portis25) wrote :

You can download manually the previous version from here:
https://launchpad.net/ubuntu/natty/+source/qt4-x11/4:4.7.1-0ubuntu9

And replace the libQtOpenGL files in /usr/lib/
It's ugly but it works.

Revision history for this message
Francesc Vicent (fransex) wrote :

I downgraded by installing three packages:

dpkg -i \
 libqt4-opengl_4.7.1-0ubuntu9_amd64.deb \
 libqtcore4_4.7.1-0ubuntu9_amd64.deb \
 libqtgui4_4.7.1-0ubuntu9_amd64.deb

that can be found in the pool/main/q/qt4-x11/ subdirectory of the mirrors.

Revision history for this message
Oded Arbel (oded-geek) wrote :

Downgrading works for me - I can now run VirtualBox

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt4-x11 - 4:4.7.1-0ubuntu11

---------------
qt4-x11 (4:4.7.1-0ubuntu11) natty; urgency=low

  [ Felix Geyer ]
  * Explicitly disable EGL support on all architectures except ARM. The last
    version accidentally enabled it as libegl1-mesa-dev was pulled in.
    (LP: #724867)

  [ Jonathan Riddell ]
  * Cast use of double in kubuntu_28_xi2.1.patch to fix FTBFS on armel.

  [ Ricardo Salveti de Araujo ]
  * Changing OpenGL backend from GL to GLES 2 for ARM (LP: #707794)
 -- Felix Geyer <email address hidden> Fri, 25 Feb 2011 14:21:36 +0100

Changed in qt4-x11 (Ubuntu Natty):
status: In Progress → Fix Released
Revision history for this message
Francesc Vicent (fransex) wrote :

#10 Version 4:4.7.1-0ubuntu11 makes my guest OS (windows7 x64) to close unexpectedly before having completely started. I downgraded to 4.7.1-0ubuntu9 and the guest worked fine again.

A new bug report has been opened for this error: https://bugs.launchpad.net/ubuntu/+source/qt4-x11/+bug/725959

Revision history for this message
Le Gluon Du Net (legluondunet) wrote :

I just updated natty, the new QT paquages resolved two of my bugs: I can now launch projectM and virtualbox.

Thank you.

Revision history for this message
Reinis Zumbergs (reinis-zumbergs) wrote :

updated to version 4:4.7.1-0ubuntu11 today and it works now. thank you

Revision history for this message
Jason Reusch (jason-reusch) wrote :

Fixed! Thanks!

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers