Failure when upgrading the system (broken package)

Bug #689113 reported by Wajih Letaief
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qt4-x11 (Ubuntu)
New
Undecided
Unassigned

Bug Description

When upgrading my Natty, i have a failure message and next time a always notified about broken package.
Sorry for the attached message, which is in french, but my system is in french :

Impossible d'installer « /var/cache/apt/archives/qt4-qmake_4%3a4.7.1-0ubuntu5_i386.deb »

La mise à niveau va continuer mais le paquet « /var/cache/apt/archives/qt4-qmake_4%3a4.7.1-0ubuntu5_i386.deb » pourrait ne pas être fonctionnel. Veuillez signaler ceci comme un bogue.

lecture courte (short read) lors d'une copie de buffer pour backend dpkg-deb pendant « ./usr/bin/qmake-qt4 »

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: qt4-qmake 4:4.7.1-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.37-8.21-generic 2.6.37-rc4
Uname: Linux 2.6.37-8-generic i686
Architecture: i386
Date: Sun Dec 12 01:04:09 2010
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.utf8
 SHELL=/bin/bash
SourcePackage: qt4-x11

Revision history for this message
Wajih Letaief (mawale) wrote :
Revision history for this message
Wajih Letaief (mawale) wrote :

When i tried to fix the broken package (sudo apt-get install -f), i've got this message :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-2.6.37-7-generic linux-headers-2.6.37-7
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  qt4-qmake
Les paquets suivants seront mis à jour :
  qt4-qmake
1 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
3 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/1 228 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
debconf: Impossible d'initialiser l'interface : Dialog
debconf: (L'interface dialog a besoin d'un écran d'au moins 13 lignes sur 31 colonnes.)
debconf: Utilisation de l'interface Readline en remplacement
(Lecture de la base de données... 254338 fichiers et répertoires déjà installés.)
Préparation du remplacement de qt4-qmake 4:4.7.1-0ubuntu4 (en utilisant .../qt4-qmake_4%3a4.7.1-0ubuntu5_i386.deb) ...
Dépaquetage de la mise à jour de qt4-qmake ...
xz: (stdin): Les données compressées sont endommagées
dpkg-deb: le sous-processus <decompress> a retourné une erreur de sortie d'état 1
dpkg : erreur de traitement de /var/cache/apt/archives/qt4-qmake_4%3a4.7.1-0ubuntu5_i386.deb (--unpack) :
 lecture courte (short read) lors d'une copie de buffer pour backend dpkg-deb pendant « ./usr/bin/qmake-qt4 »
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/qt4-qmake_4%3a4.7.1-0ubuntu5_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers