Comment 139 for bug 650539

Yes, works for me on triple monitor Nvidia SLI setup, thanks, hope it becomes official.
For those left wondering just run Synaptic Package Manager -> Settings -> Repositories.In the Software Sources dialog box select the Updates tab.Check the Pre-released updates (maverick-proposed) box.Run update-manager, restart and your'e done.
--- On Thu, 23/12/10, mustangtyson <email address hidden> wrote:

From: mustangtyson <email address hidden>
Subject: [Bug 650539] Re: SRU: Launching a Qt app crashes X when using Xinerama
To: <email address hidden>
Received: Thursday, 23 December, 2010, 6:09 AM

I enabled "proposed" updated, rebooted and it solved the problem. Thanks!
http://ubuntuforums.org/showthread.php?p=10268993#post10268993

--
You received this bug notification because you are a direct subscriber
of a duplicate bug (659538).
https://bugs.launchpad.net/bugs/650539

Title:
  SRU: Launching a Qt app crashes X when using Xinerama

Status in X.Org X server:
  Unknown
Status in “nvidia-graphics-drivers” package in Ubuntu:
  Invalid
Status in “qt4-x11” package in Ubuntu:
  Invalid
Status in “xorg-server” package in Ubuntu:
  Fix Released
Status in “nvidia-graphics-drivers” source package in Maverick:
  Invalid
Status in “qt4-x11” source package in Maverick:
  Invalid
Status in “xorg-server” source package in Maverick:
  Fix Committed

Bug description:
  Justification:
=============
Regression from Ubuntu 10.04, causing an Xserver crash when starting a Qt application in an multi-head X configuration using Xinerama.  The X crash risks losing user data from unsaved documents in applications.

Fix:
===
This is caused by a typo in commit 80b5d3a3.  A fix has been pulled to the server-1.9 stable branch in commit 3effb61e (http://cgit.freedesktop.org/xorg/xserver/commit/?id=78f94f19aab66a1e5331df0ce29f36e310b4195d ).  This commit has been cherry-picked onto the Natty xserver tree.

Test case:
========
Start a Qt app such as Skype while using Xinerama multi-head.  Users of the binary nVidia driver who have multiple monitors and select “Separate X screen” rather than “Twinview” in nvidia-settings will be using a Xinerama multi-head configuration.

Regression Potential:
==================
Low.  Patch is a one-line typo fix, and anything which exercises this codepath currently crashes.

Original report:

PROBLEM
=======
Starting a Qt app such as Skype crashes X, leaving
"Caught signal 11 (Segmentation fault). Server aborting"
in Xorg.0.log.old and the dazzled user with the login screen.
This is a bug in X, fixed upstream in http://cgit.freedesktop.org/xorg/xserver/commit/?id=78f94f19aab66a1e5331df0ce29f36e310b4195d .

WORKAROUND
==========
Until the fix is released as an official Ubuntu update, Jared Bunting has it in his PPA at https://launchpad.net/~jared-bunting/+archive/xorg-xserver-650539 (thx!).
You need xserver-xorg-core and xserver-common, so for 32 bit
1) Download
https://launchpad.net/~jared-bunting/+archive/xorg-xserver-650539/+files/xserver-xorg-core_1.9.0-0ubuntu7%2Bbug650539%2B1_i386.deb and
https://launchpad.net/~jared-bunting/+archive/xorg-xserver-650539/+files/xserver-common_1.9.0-0ubuntu7%2Bbug650539%2B1_all.deb
2) Install
sudo dpkg -i xserver-xorg-core_1.9.0-0ubuntu7+bug650539+1_i386.deb xserver-common_1.9.0-0ubuntu7+bug650539+1_all.deb

ORIGINAL DESCRIPTION
====================
I think this may be related to QT apps, as keepassx, skype also crash X when started
This is on maverick will all current updates.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: speedcrunch 0.10.1-2
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Tue Sep 28 12:29:04 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: speedcrunch
---
Architecture: amd64
DistroRelease: Ubuntu 10.10
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
NonfreeKernelModules: nvidia
Package: xorg 1:7.5+6ubuntu3
PackageArchitecture: amd64
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Tags: maverick
Uname: Linux 2.6.35-22-generic x86_64
UnreportableReason: The drivers from nvidia.com are not supported by Ubuntu.  Please uninstall them and test whether your problem still occurs.
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare video
system:
 distro:             Ubuntu
 codename:           maverick
 architecture:       x86_64
 kernel:             2.6.35-22-generic

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/xorg-server/+bug/650539/+subscribe