Kubuntu ubiquity is unthemed

Bug #600646 reported by Ara Pulido on 2010-07-01
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
qt4-x11 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

Testing Kubuntu Maverick Alpha 2 Live i386 (http://cdimage.ubuntu.com/kubuntu/daily-live/20100630.1/maverick-desktop-i386.iso)

The ubiquity windows are unthemed (see screenshot)

Ara Pulido (ara) wrote :
tags: added: iso-testing
Ronald McCollam (fader) wrote :

This is also occurring on the Alpha 2 i386 kubuntu DVD image.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Jussi Schultink (jussi01) wrote :

<Riddell> This seems to be an issue since we uploaded Qt 4.7, apps running as root don't pick up the widget theme

affects: ubiquity (Ubuntu) → qt4-x11 (Ubuntu)
Yuri sss (yukihiro-ayaka) wrote :

Commenting here as well since the bug I commented at has been marked a duplicate of this bug.

Affected are Lucid with Kde 4.5.0b from Kubuntu backport repositories as well as current Maverick Alpha 3 with Kde 4.5.0b.
For *all* Kde applications running as root using kdesudo (systemsettings, Dolphin, whatever else) it's the same: they always have only the Oxygen style, as you cannot set a different style for Kde apps running as root in kdesudo systemsettings - the preview of other styles works fine, but when you press "Apply", *nothing* happens - the style is never applied, it's always stuck at the Oxygen style.

Jonathan Riddell (jr) on 2010-08-25
tags: added: kubuntu
Changed in qt4-x11 (Ubuntu):
milestone: none → ubuntu-10.10-beta
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt4-x11 - 4:4.7.0~beta2-0ubuntu7

---------------
qt4-x11 (4:4.7.0~beta2-0ubuntu7) maverick; urgency=low

  * Add debian/Trolltech.conf installed into /etc/xdg to point at KDE
    plugin directory for oxygen style, closes LP: #600646
 -- Jonathan Riddell <email address hidden> Thu, 26 Aug 2010 00:55:02 +0100

Changed in qt4-x11 (Ubuntu):
status: Confirmed → Fix Released
dw40 (xoobxa) wrote :

I have filed bug report #619519 (https://bugs.launchpad.net/ubuntu/+source/kdebase-workspace/+bug/619519), which has been marked as a duplicate of this bug (Bug #600646). But I think they are two separate issues. What ever is fixed in package qt4-x11, does not address the problem I stated in bug #619519. That is. when I issued command "kdesudo systemsettings", and then changed the widget style to QtCurve from the default Oxygen, I would still get the Oxygen style the next time I issue commands "kdesudo systemsettings" or "kdesudo dolphin". I don't know about other people, but I do run dolphin as sudo from time to time to make changes to my system and I like to have dolphin themed like it does under normal user.

Yuri sss (yukihiro-ayaka) wrote :

I can confirm this. The fix for this bug does *nothing* to fix bug 619519, so it has to be considered a separate bug. I have therefore removed the wrongly marked "Duplicate" status for 619519.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments