No VFS entries in the sidebar of QGtkStyle's GtkFileChooser

Bug #498532 reported by benste on 2009-12-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
qt4-x11 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

I was about to search for all files of type WMA on my NAS, connected via SMB (smb://192.168.2.2/)

the drive is successfully mounted, but if i want to modify the path where to search on I get all entrys including HDDs which are in the sidebar and "custom location" If I enter the path named above I can't close with OK.

I would expect it to have all entrys of the sidebar too.

ProblemType: Bug
Architecture: i386
Date: Sat Dec 19 16:24:53 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: nautilus 1:2.28.1-0ubuntu3
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: nautilus
Uname: Linux 2.6.31-16-generic i686

benste (benste) wrote :
Sense Egbert Hofstede (sense) wrote :

Thank you for helping with making Ubuntu and its file manager Nautilus better by reporting this bug. However, it's not very clear yet what the exact problem is you're trying to report.
What are you searching with? Is it with the tool located at Places->Search files, or do you click the search button when viewing a certain directory?
Furthermore I would like to know in what text field you're trying to insert the location of your NAS.

Thanks in advance.

Changed in nautilus (Ubuntu):
status: New → Incomplete
benste (benste) wrote :

HI Sense, I'll add an screenshot to give you a more detailed view.
The tool located in Places - search does have the same problem.

My way was - ceratin directory - CTRL-F -> get search results cutomize search through adding different criteria?field.comment=HI Sense, I'll add an screenshot to give you a more detailed view.
The tool located in Places - search does have the same problem.

My way was - ceratin directory - CTRL-F -> get search results cutomize search through adding different criteria

benste (benste) wrote :

sry looks like LP messed up my post:

it was simply posted twice, so don't care about the 2nd copy. - screenshot name is a bit weird, thought it would be a caption below the image.

Sense Egbert Hofstede (sense) wrote :

Ah, I think I understand your problem now.
By pasting the link in the Location field you go to that location, in this case your NAS. However, if you want to choose a directory you have to have it selected before you can press OK. When you are inside that directory this is not the case, which means you can't press OK here as well.
A solution would be to browse to the directory that contains the directory you want to select. In this case there is no real directory that does this, but you could go to 'computer:///' and select your NAS there.
Alternatively, you could select the NAS from the list of locations in the drop-down menu of the search criteria, instead of pressing "More..." there.

I'm marking this bug as Invalid since this is expected behaviour. However, please don't let this put you off from reporting other bugs; all input is appreciated!

Changed in nautilus (Ubuntu):
status: Incomplete → Invalid
benste (benste) wrote :

Problem is that it doesn't appear in the dropdown neither in computer:/// and not in the "more" selections, (it would be smb://192.168.2.2 but you can't enter a text as custom location in the "more dialog")
going to the directory first wouldn't be the expected behaviour, otherwise the dialog for choosing the location would be stupid wouldn't it ?

Changed in nautilus (Ubuntu):
status: Invalid → New
Pedro Villavicencio (pedro) wrote :

Thanks for the bug report. This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.

Changed in nautilus (Ubuntu):
status: New → Invalid
Pedro Villavicencio (pedro) wrote :

wrong comment on the wrong bug, forget previous comment.

Changed in nautilus (Ubuntu):
status: Invalid → New
importance: Undecided → Low
Sense Egbert Hofstede (sense) wrote :

What about the following entries:
"NAS - Samba"
"temp on 192.1..."
"music on 192.1..."
They appear to be the server you're talking about. What happens when you select those?

benste (benste) wrote :

ehm Sense, as i subtitled the image, the left side is the working nautilus window :-) - this one was for comparison what the "more" menu should look like

benste (benste) wrote :

have to correct myself, just wanted to add a ISO from my samba connected NAS for usage with vbox, but it looks like this custom choose file dialog doesn't except network storages too.

Either there is a reason why gvfs devices aren't listed or it's a really nice gvfs/nautilus bug - isn't it ?

summary: - nautilus does not offer gvfs entrys if you try a custom search
+ nautilus does not offer gvfs entrys in open dialogs
summary: - nautilus does not offer gvfs entrys in open dialogs
+ No VFS entries in the sidebar of QGtkStyle's GtkFileChooser
Sense Egbert Hofstede (sense) wrote :

Apologises for the delay of this response. I didn't have much time lately due to foreseen circumstances, I hope you understand.
I also didn't see through this bug completely and didn't interpret the symptoms correctly right away.

The file chooser dialogue is not a part of Nautilus, but of the GTK+ project. However, when using GtkFileChooserDialog, the VFS entries should be added correctly to the sidebar.
The bug you reported is in the GTK+ -- a graphical toolkit -- integration of Qt -- another graphical toolkit, called QGtkStyle. It tries to draw Qt applications with GTK+ and uses GtkFileChooser to draw the file chooser. This is where the bug lies.

affects: nautilus (Ubuntu) → qt4-x11 (Ubuntu)
Changed in qt4-x11 (Ubuntu):
status: New → Confirmed
benste (benste) wrote :

:-) kinda complicated

qt4-x11 is managed upstream or is there someone who'll fix this on LP ?

Jonathan Thomas (echidnaman) wrote :

It'd be best to pursue a fix upstream.

benste (benste) wrote :

If you're working upstream @ gtk project too I'd be glad to have you submitting this.

Jonathan Thomas (echidnaman) wrote :

I'm afraid I'm not involved with GTK upstream. :(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers