Ubuntu

visual bug with OpenGL application

Reported by Fabounet on 2009-10-27
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
qt4-x11 (Ubuntu)
Undecided
Unassigned

Bug Description

When an OpenGL application that uses an RGBA context is used, any Qt-based application will have visual artifact.
You can for instance reproduce the bug by running Cairo-dock2 with opengl backend (cairo-dock -o), then running either
vlc
Smplayer
Skype
ooffice packaged for KDE
etc

you will probably get a transparent window (borderes are displayed, but not the content of the window)
It is independant of the WM (Metacity/Compiz/Kwin), or the environnement (KDE/Gnome).
It occures with any version of Qt available in the Ubuntu repositories until now.

Jonathan Thomas (echidnaman) wrote :

Could you attach the output of the command lspci -vvnn, as well as a copy of the /var/log/Xorg.0.log file? Thanks in advance.

Changed in qt4-x11 (Ubuntu):
status: New → Incomplete

ok I'll do that when I'm at home, but I can add that this bug happens for
everybody (you can search on the net, it is already noticed several times).
also, a workaround is to start the Qt-based application with the following
command :
*export* XLIB_SKIP_ARGB_VISUALS=1 && *vlc*
(for vlc for exemple)
Hope this is a clue for you.

2009/10/27 Jonathan Thomas <email address hidden>

> Could you attach the output of the command lspci -vvnn, as well as a
> copy of the /var/log/Xorg.0.log file? Thanks in advance.
>
> ** Changed in: qt4-x11 (Ubuntu)
> Status: New => Incomplete
>
> --
> visual bug with OpenGL application
> https://bugs.launchpad.net/bugs/461817
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “qt4-x11” package in Ubuntu: Incomplete
>
> Bug description:
> When an OpenGL application that uses an RGBA context is used, any Qt-based
> application will have visual artifact.
> You can for instance reproduce the bug by running Cairo-dock2 with opengl
> backend (cairo-dock -o), then running either
> vlc
> Smplayer
> Skype
> ooffice packaged for KDE
> etc
>
> you will probably get a transparent window (borderes are displayed, but not
> the content of the window)
> It is independant of the WM (Metacity/Compiz/Kwin), or the environnement
> (KDE/Gnome).
> It occures with any version of Qt available in the Ubuntu repositories
> until now.
>

Jonathan Thomas (echidnaman) wrote :

It most certainly does not happen to everybody.

Fabounet (fabounet03) wrote :

of course, I meant to everybody using those apps with Cairo-dock in OpenGL
mode.
that's why we could guess that the problem was related to Qt.
well, I hope you can reproduce it (and fix it ;-) )
Thanks.

2009/10/28 Jonathan Thomas <email address hidden>

> It most certainly does not happen to everybody.
>
> --
> visual bug with OpenGL application
> https://bugs.launchpad.net/bugs/461817
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “qt4-x11” package in Ubuntu: Incomplete
>
> Bug description:
> When an OpenGL application that uses an RGBA context is used, any Qt-based
> application will have visual artifact.
> You can for instance reproduce the bug by running Cairo-dock2 with opengl
> backend (cairo-dock -o), then running either
> vlc
> Smplayer
> Skype
> ooffice packaged for KDE
> etc
>
> you will probably get a transparent window (borderes are displayed, but not
> the content of the window)
> It is independant of the WM (Metacity/Compiz/Kwin), or the environnement
> (KDE/Gnome).
> It occures with any version of Qt available in the Ubuntu repositories
> until now.
>

Jonathan Thomas (echidnaman) wrote :

Closing; still need those logs, as this is most likely a graphics driver issue.

Changed in qt4-x11 (Ubuntu):
status: Incomplete → Invalid
Fabounet (fabounet03) wrote :

I'm sorry but I have to insist oin this bug, it can't be ignored so easily.
It happens on any graphic card (Nvidia, ATI, probably Intel too), and a workaround exists, so it can't just be a "driver issue"
the VLC devs said that the problem comes from the Qt widget, which creates by default an RGBA context, when most application would just need an RGB one.
for instance, if VLC could allocate an RGB widget, there wouldn't be this problem any more.
they had to make a dirty hack (hardcode the XLIB_SKIP_ARGB_VISUALS variable to 1).
This is not a correct answer, at least Qt has to provide a way to avoid such hack, (the best would of course be to solve the bug definitely).

Changed in qt4-x11 (Ubuntu):
status: Invalid → Confirmed
Mitch Towner (kermiac) wrote :

I have to agree with Fabounet, this still is an issue. See my attached screenshots to see what is happening.
"QT-Issues.png" shows the issue when running QT-based apps.
"QT-using-workaround.png" shows these same apps when run using the "XLIB_SKIP_ARGB_VISUALS=1" workaround.

Mitch Towner (kermiac) wrote :

See http://ubuntu.pastebin.com/f65a81eee for output of "lspci -vvnn" command as requested above.
I have also attached a copy of the /var/log/Xorg.0.log file.

Please advise if any further info is required.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers