[intrepid] KDE 4 doesn't work due uim-qt issue

Bug #271101 reported by marcobra (Marco Braida) on 2008-09-16
42
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
qt4-x11 (Ubuntu)
Undecided
Unassigned
uim (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: qt4-designer

On a fully updated and upgraded Intrepid (17 September 2008 )

How to reproduce:

Start designer-qt4 from terminal or from menu...

It start without any error and put processor to 100% and begin to fill the ram it don't show any
graphic interface, we must kill it.

Removing the uim-qt package with:

sudo apt-get remove uim-qt

make designer-qt4 start again...

Thank you

Alberto Milone (albertomilone) wrote :

I can confirm the problem:

:~$ designer-qt4
QMetaProperty::read: Unable to handle unregistered datatype 'QList<QChar>' for property 'KCharSelect::displayedChars'
QMetaProperty::read: Unable to handle unregistered datatype 'QList<QColor>' for property 'KColorCombo::colors'
Error while reparenting!
QMetaProperty::read: Unable to handle unregistered datatype 'KUrl' for property 'KUrlRequester::url'
QMetaProperty::read: Unable to handle unregistered datatype 'KFile::Modes' for property 'KUrlRequester::mode'
QMetaProperty::read: Unable to handle unregistered datatype 'KUrl' for property 'KUrlRequester::url'
QMetaProperty::read: Unable to handle unregistered datatype 'KFile::Modes' for property 'KUrlRequester::mode'
Segmentation fault (core dumped)

Changed in qt4-x11:
status: New → Confirmed
Alberto Milone (albertomilone) wrote :

Problem solved with today's updates.

Changed in qt4-x11:
status: Confirmed → Fix Released

Not solved for me on 3/3 Ubuntu fully upgrade Intrepid pc...

How to reproduce:

Start designer-qt4 from terminal or from menu...

It start without any error and put processor to 100% and begin to fill the ram it don't show any
graphic interface, we must kill it.

Thank you

Alberto Milone (albertomilone) wrote :

can you post the output of this command?
apt-cache policy qt4-designer

Runing -> apt-cache policy qt4-designer

qt4-designer:
  Installato: 4.4.2-0ubuntu2
  Candidato: 4.4.2-0ubuntu2
  Tabella versione:
 *** 4.4.2-0ubuntu2 0
        500 http://archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

Thank you

Alberto Milone (albertomilone) wrote :

can you post the output of the following command?
designer-qt4

The designer-qt4 doesn't return any terminal screen messages and/or warnings by the way a have redirect some of strace to a file and i attach it here...
Kde 4 on this pc was working but now kde 4.1.2 at session startup don't go after the latest big "K" don't show any screen and fill the ram.

On this pc all kde4 apps now aren't working/starting good.

Is not a problem to me to reinstall, but i want to know, to helps debug, to know what is going wrong
Gnome on this pc is working good.

Into the kdm.log i have a lot of:
kdmgreet(5476) KLocalePrivate::initEncoding: Cannot resolve system encoding, defaulting to ISO 8859-1.

It seems something related to system locale. I use italian

locale
LANG=it_IT.UTF-8
LC_CTYPE="it_IT.UTF-8"
LC_NUMERIC="it_IT.UTF-8"
LC_TIME="it_IT.UTF-8"
LC_COLLATE="it_IT.UTF-8"
LC_MONETARY="it_IT.UTF-8"
LC_MESSAGES="it_IT.UTF-8"
LC_PAPER="it_IT.UTF-8"
LC_NAME="it_IT.UTF-8"
LC_ADDRESS="it_IT.UTF-8"
LC_TELEPHONE="it_IT.UTF-8"
LC_MEASUREMENT="it_IT.UTF-8"
LC_IDENTIFICATION="it_IT.UTF-8"
LC_ALL=

The file cat /usr/share/xsessions/kde.desktop
[Desktop Entry]
Encoding=UTF-8
Type=XSession
Exec=/usr/bin/startkde
TryExec=/usr/bin/startkde
Name=KDE4
....

Thank you

Alberto Milone (albertomilone) wrote :

You can try 2 things:
1) type:
mv .kde .kdebackup

and try to enter KDE 4 again.

2) If point 1 doesn't solve the problem, make sure that all the required packages are installed.
sudo apt-get install --reinstall kubuntu-desktop

Let me know how it goes.

I have already done this, but i tried again, kde session start with a black screen with usual KDE mouse cursor i don't get any desktop.
There are unusual amount of used ram i switched to a pseudo terminal (using top) i report some values here:

kded 230 mb
guidance-power 210
nm-applet 180
python 212
plasma 260 mb
krunner 350 mb
knotify4 129 mb

Alberto, i'm thinking to stop bug you with my KDE issue on a fixed bug... it is only a my bug may be some wrong Ubuntu update was killing only my kde. Any short suggstion or link to debug kde will be appreciated.

Thank you

Alberto Milone (albertomilone) wrote :

Ok, what graphics driver are you using?

With : 01:00.0 VGA compatible controller: ATI Technologies Inc Rage 128 Pro Ultra TF

my xorg.conf

Section "Device"
 Identifier "Configured Video Device"
EndSection

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
EndSection

I think i'm using:

ii xserver-xorg-video-ati 1:6.9.0+git20080826.a3cc1d7a-2ubuntu3 X.Org X server -- ATI display driver
wrapper

Compiz disabled...

Thanks

Alberto Milone (albertomilone) wrote :

I had the same problem with the ati driver. I'm assigning the bug report to the ati driver then.

Changed in qt4-x11:
status: Fix Released → Confirmed
description: updated

Not sure how this is a driver bug; feel free to reopen this task if it is, but please include Xorg.0.log and other evidence explaining how the -ati driver is involved in this bug.

Changed in xserver-xorg-video-ati:
status: Confirmed → Invalid
mir (mir-rodriguez) wrote :

I use the proprietary Nvidia driver and I'm having similar problems.

Qt4-assistant, qt4-linguist and qt4-designer as well as qtdemo all show the same behaviour: memory use increases non stop and CPU usage goes all the way up.

No messages are displayed in the terminal.

Using fully updated Intrepid on AMD64.

Yaohan Chen (yaohan-chen) wrote :

I use the Radeon driver with ATI Radeon 9200, and I also have the problem that KDE shows only a black screen where the cursor can be moved. When I open "top" in a console it shows that the X display manager (I'm also having to use xdm instead of kdm because kdm does not show the login window), krunner, and plasma use up all the CPU.

On Ubuntu 8.10 as a workaround that confirm the http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=501125
is to remove the uim-qt package and all start fine now.

Hope this helps

Changed in qt4-x11:
status: New → Confirmed

This isn't related to ati-driver i have this issue also on intel video cards the issue is the uim-qt package

description: updated
description: updated
Joshua H. Rothenberg (jhr) wrote :

I just upgraded to Intrepid. I was also having this issue (I couldn't run any qt4 applications) until I removed uim-qt. This is especially annoying since I use uim as my input method. I have an intel graphics card, but this is clearly not related to that.

Waba (waba) wrote :

This is actually a bug in uim, it has been fixed upstream in 1.5.3 (http://uim.googlecode.com/svn/tags/uim-1.5.3/NEWS).

I've been able to fix the package by updating the uim/qt4 source directory to 1.5.3, ie. this patch :
  svn diff -r 5493:5563 http://uim.googlecode.com/svn/trunk/qt4

This bug made a freshly installed and updated Intrepid system completely unusable for the end-user, as kdm_greet was affected and the user couldn't login in graphical mode. So the severity should be increased to grave/critical and the bug reassigned to uim.

Yevgen Antimirov (turist) wrote :

Guys, how thing work in Ubuntu, well we be able to see the solution of this bug in 8.10? As I understand this a bug and it was already fixed in October, but why the package is still not updated in Ubuntu repository?

Yevgen Antimirov (turist) wrote :

Guys, how things work in Ubuntu, well we be able to see the solution of this bug in 8.10? As I understand this a bug and it was already fixed in October, but why the package is still not updated in Ubuntu repository?

Artemis3 (artemis3) wrote :

I'm hit by this bug. Ubuntu 8.10 AMD64.

To reproduce: Install uim-qt, then run any qt4 app (such as vlc).

This causes the qt4 app to fill up all available memory and not display anything at all. As soon as you remove uim-qt, the problem is gone.

Please update the uim-qt packages to version 1.5.3 asap:

Overview of changes from 1.5.2 to 1.5.3
  - Qt4 bridge (experimental)
    * [CRITICAL] Fix bug with Qt4 >= 4.4.1, which makes applications
      infinite loop at the startup

fix/Workaround: install from jaunty: uim-common uim-utils uim-qt3 uim-qt

Jonathan Thomas (echidnaman) wrote :

Fixed in Jaunty.

Changed in uim (Ubuntu):
status: Invalid → Fix Released
Changed in qt4-x11 (Ubuntu):
status: Confirmed → Fix Released
Changed in debian:
status: Unknown → Confirmed
Changed in debian:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.