Stellarium, white screen with last libqt4

Bug #227922 reported by RaphAstronome on 2008-05-07
18
Affects Status Importance Assigned to Milestone
Hardy Backports
Undecided
Unassigned
qt4-x11 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libqt4-gui

I had upgraded libqt4-core and libqt4-gui to 4.4.0-1ubuntu1~hardy1 but after Stellarium show only a white screen instead of the sky, just some buttons are shown.

Reboot don't had corrected this bug and Stellarium don't show special errors on bash.

Downgrading libqt4-core and libqt4-gui to 4.3.4-0ubuntu3 had solved the problem.

$ lsb_release -rd
Description: Ubuntu 8.04
Release: 8.04
Version : x86_64

RaphAstronome (sp01) on 2008-05-07
description: updated
Axel Pospischil (apos) wrote :

This is due to enabled backports updates (unsupported).
See Bug #228067 in qt4-x11 (Ubuntu)

Andi (nudeldieb) wrote :

Hi,
have the same problem with stellarium, amd64, hardy and the latest updates.
My LANG is de_DE.UTF-8 and after starting stellarium the screen gets white and only the configuration knobs are visible, such as exit and stuff.
After applying the workaround (bash$ LANG=C stellarium) stellarium starts up normally and everything is seen as in the usual manner, except that the wrong language is used...

$ compiz --version
Checking for Xgl: not present.
Detected PCI ID for VGA: 01:00.0 0300: 10de:0045 (rev a1) (prog-if 00 [VGA controller])
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1280x1024) to maximum 3D texture size (4096): Passed.
Checking for nVidia: present.
Checking for FBConfig: present.
Checking for Xgl: not present.
compiz 0.7.4

$ stellarium --version
Stellarium 0.9.1

$ stellarium
 -------------------------------------------------------
[ This is Stellarium 0.9.1 - http://www.stellarium.org ]
[ Copyright (C) 2000-2008 Fabien Chereau et al ]
 -------------------------------------------------------
File search paths:
 0. .stellarium
 1. /usr/share/stellarium
Config file is: .stellarium/config.ini
Attempting to use an existing older config file.
Sky language is de_DE.
Application language is de_DE.
Warning can't find module called "StelUI" .
Loading Solar System data...ERROR: C/2006 P1 (McNaught): you must provide orbit_PericenterDistance or orbit_SemiMajorAxis
(loaded)
Loading star data...
Loading stars_0_0v0_1.cat: 0_0v0_1; stars: 5013
Loading stars_1_0v0_1.cat: 1_0v0_1; stars: 21999
Loading stars_2_0v0_1.cat: 2_0v0_1; stars: 151416
Loading stars_3_1v0_0.cat: 3_1v0_0; stars: 434064
ZoneArray::create( "stars_4_1v0_0.cat" ): warning while loading " "stars_4_1v0_0.cat" ": file not found: stars/default/stars_4_1v0_0.cat
ZoneArray::create( "mmap:stars_5_2v0_0.cat" ): warning while loading " "stars_5_2v0_0.cat" ": file not found: stars/default/stars_5_2v0_0.cat
ZoneArray::create( "mmap:stars_6_2v0_0.cat" ): warning while loading " "stars_6_2v0_0.cat" ": file not found: stars/default/stars_6_2v0_0.cat
ZoneArray::create( "mmap:stars_7_2v0_0.cat" ): warning while loading " "stars_7_2v0_0.cat" ": file not found: stars/default/stars_7_2v0_0.cat
ZoneArray::create( "mmap:stars_8_2v0_0.cat" ): warning while loading " "stars_8_2v0_0.cat" ": file not found: stars/default/stars_8_2v0_0.cat
finished, max_geodesic_level: 3
Loading location: ..., on Earth
Loading NGC data... (13226 items loaded [3175 dropped])
Loading NGC name data...( 222 names loaded)
Loading Nebula Textures for set default...(109 textures loaded)
Loading Constellation boundary data from /usr/share/stellarium/data/constellations_boundaries.dat... (782 segments loaded)
Loading star names from /usr/share/stellarium/skycultures/western/star_names.fab
Loading star sci names from /usr/share/stellarium/stars/default/name.fab
Loading Cities data for planet Earth...(2069 cities loaded)
Localizing TUI for locale: de_DE.
Localizing TUI for locale: de_DE.
Script completed.

Greetings

Andi (nudeldieb) wrote :

If I downgrade libqt4 to 4.3.4-0ubuntu3, stellarium (0.9.1-2) doesn't start at all with the following error:
Cannot mix incompatible Qt libraries

What's the problem now?

Andi (nudeldieb) wrote :

I found two orphans libqtcore4, libqtgui4 (not libqt4-core or libqt4-gui). Now it works!!!

oooioiii (zgeomml02) wrote :

@Andi:

thx for sharing, but what do I have to do in order to get it running?
if I make a apt-get remove libqtcore4 it is also going to remove stellarium...

thx for help & regards

Psy[H[] (vovik-wfa) wrote :

you have to:
remove all libqt4* packages and libqtcore4, libqtgui4
turn off backports repo
reload index, install stellarium and other packages that was deleted by dependencies
lock libqt4-core and libqt4-gui versions via Synaptic.
then you can enable backports repo again

Psy[H[] (vovik-wfa) wrote :

Is it a problem in new libqt4 or in Stellarium?

Kristian Rink (kawazu) wrote :

Also stumbled across this, two different machines upgraded to hardy just recently. Downgrading qt4 so far, seems likely to remove quite a bunch of other packages currently in use. Any chance of a better solution to that, here, before hardy+1?

siro3d (siro3d) wrote :

i had a similar problem recently, and found a solution without uninstaling and instaling anything
just run stellarium from konsole like this: "LANG=en stellarium"

MM

Psy[H[] (vovik-wfa) wrote :

I've upgraded from this ppa:
deb http://ppa.launchpad.net/kubuntu-members-kde4/ubuntu hardy main
Stellarium works fine now.

siro3d (siro3d) wrote :

this solution is great, thank you

Harald Sitter (apachelogger) wrote :

Problem with hardy-backports.

Changed in qt4-x11:
status: New → Invalid

Why don't we backport version 0.9.1-4? I've built this version with prevu and I confirm that resolves the issue with back-ported libqt4! See bug Bug #246315

Gabriel Rota (gabriel-rota) wrote :

prevu stellarium
ll /var/cache/prevu/hardy-debs/stellarium_0.9.1-4~8.04prevu1_amd64.deb
ll /var/cache/prevu/hardy-debs/stellarium-data_0.9.1-4~8.04prevu1_all.deb
sudo apt-get update
sudo apt-get install stellarium
stellarium
sudo apt-get remove stellarium
all ok

Changed in hardy-backports:
status: New → Confirmed
Scott Kitterman (kitterman) wrote :

The backport proposed in this bug has already been done.

stellarium | 0.9.1-4~hardy1 | hardy-backports/universe | source, amd64, i386

Changed in hardy-backports:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers