QT4 Trolltech.conf settings lost after reboot

Bug #1684506 reported by mrvanes on 2017-04-20
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
qt4-x11 (Ubuntu)
Undecided
Unassigned

Bug Description

Since the update to Kubuntu 17.04 / plasma 5.9.4 all qt4 based applications (e.g. KeePassX) render using wrong font instead of my personal configured font. When I run qtconfig-qt4 (4.8.7), change font and click 'save', a fresh .config/Trolltech.conf is saved, contains the correct font config and all qt4 applications now show correct font. These settings however do not survive a reboot although Trolltech.conf exists and contains correct settings.

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: xorg 1:7.7+16ubuntu3
Uname: Linux 4.10.11 x86_64
ApportVersion: 2.20.4-0ubuntu4
Architecture: amd64
CurrentDesktop: KDE
Date: Thu Apr 20 10:33:21 2017
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
UpgradeStatus: Upgraded to zesty on 2017-04-11 (8 days ago)

mrvanes (mrvanes) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
eugenez (eugene-zvyagintsev) wrote :

Same.
After saving the qtconfig settings and reboot, there are two lines "fonts=" appears in ~/.config/Trolltech.conf

#after reboot
$ cat ~/.config/Trolltech.conf | grep font=
font="Ubuntu,8,-1,5,50,0,0,0,0,0"
font="Sans Serif,9,-1,5,50,0,0,0,0,0"

#after manual qtconfig saving
$ cat ~/.config/Trolltech.conf | grep font=
font="Ubuntu,8,-1,5,50,0,0,0,0,0"

Timo Aaltonen (tjaalton) on 2017-04-27
affects: xorg (Ubuntu) → qt4-x11 (Ubuntu)
mrvanes (mrvanes) wrote :

Fixed, for me, in (K)Ubuntu 17.10, Artful.
libqt4 4.8.7
libqt5 5.9.1

eugenez (eugene-zvyagintsev) wrote :

Yes, in Artful all is ok.

dino99 (9d9) wrote :
Changed in qt4-x11 (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers