Fix for crashes due to ubuntu-specific accessibility patch

Bug #1289600 reported by Alexey Borzenkov on 2014-03-07
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qt4-x11 (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Saucy
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[Impact]
* Plasma can be crashed by clicking on "Show activities" and then "Add widgets"
* Backporting this fix would solve this crash and has been approved by the Qt4 a11y maintainer : https://lists.ubuntu.com/archives/kubuntu-devel/2014-March/008097.html

[Test Case]
* Click "Show activities"
* Click "Add widgets"
* Plasma should crash
* Upgrade to package from -proposed
* Logout / Login
* Click "Show activities"
* Click "Add widgets"
* Plasma should not crash

I wrote about this on kubuntu-devel and kubuntu-user, but maybe it's better for it to be a proper bug report:

https://lists.ubuntu.com/archives/kubuntu-devel/2014-February/007954.html

In short plasma can be easily crashed by clicking on "Show activities" and then "Add widgets", although reproducibility seems to depend on screen resolution. I traced this to an ubuntu-specific accessibility patch to qt4-x11, which incorrectly places QDeclarativeAccessibilityUpdater inside QDeclarativeEnginePrivate, making it possible for engine to be destroyed before QDeclarativeItem that are subscribed to it, causing crashes on destruction.

Although this is very reproducible in plasma the nature of the bug means any application that uses QtDeclarative may crash like that, e.g. searching shows many reports for crashes in settings with similar stack traces with QDeclarativeItem destructor.

Attached is the patch for qt 4.8.5 that should fix this issue (should be applied after kubuntu_97_a11y_qt_and_qml_backport.diff). Since this bug is present in Ubuntu 14.04, which is LTS and would be released soon, is it possible for the fix to make it into Ubuntu 14.04?

Alexey Borzenkov (snaury) wrote :

The attachment "kubuntu_98_a11y_crash_fix.diff" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

Alexey Borzenkov (snaury) wrote :

For reference, this is a fresh stack trace from a crash on Ubuntu 14.04.

Rohan Garg (rohangarg) wrote :

Thanks for filing the bug, I'm working on getting the SRU paperwork done

Rohan Garg (rohangarg) on 2014-03-12
description: updated
no longer affects: qt4-x11 (Ubuntu Quantal)
Harald Sitter (apachelogger) wrote :

FTR: patch approved by the original a11y patch author on kubuntu-devel

https://lists.ubuntu.com/archives/kubuntu-devel/2014-March/008097.html.

Rohan Garg (rohangarg) on 2014-03-12
Changed in qt4-x11 (Ubuntu Trusty):
status: New → Triaged
Changed in qt4-x11 (Ubuntu Saucy):
status: New → Triaged
status: Triaged → Confirmed
Changed in qt4-x11 (Ubuntu Precise):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt4-x11 - 4:4.8.5+git192-g085f851+dfsg-2ubuntu4

---------------
qt4-x11 (4:4.8.5+git192-g085f851+dfsg-2ubuntu4) trusty; urgency=medium

  [ Jonathan Riddell ]
  * Add kubuntu_glib-honor-ExcludeSocketNotifiers-flag.diff from LiMux
    fix crash in LibreOffice with KDE theme LP: #1290514

  [ Rohan Garg ]
  * Add kubuntu_98_a11y_fix_crash.diff to fix plasma crashing due to
    ubuntu-specific accessibility patch LP: #1289600
 -- Jonathan Riddell <email address hidden> Tue, 11 Mar 2014 13:29:27 +0000

Changed in qt4-x11 (Ubuntu Trusty):
status: Triaged → Fix Released
Jonathan Riddell (jr) wrote :

Fix uploaded as part of bug 1290514, awaiting approval from ~ubuntu-sru

Changed in qt4-x11 (Ubuntu Quantal):
status: New → Confirmed

Hello Alexey, or anyone else affected,

Accepted qt4-x11 into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/qt4-x11/4:4.8.4+dfsg-0ubuntu18.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in qt4-x11 (Ubuntu Saucy):
status: Confirmed → Fix Committed
tags: added: verification-needed
Scott Kitterman (kitterman) wrote :

Hello Alexey, or anyone else affected,

Accepted qt4-x11 into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/qt4-x11/4:4.8.3+dfsg-0ubuntu3.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Scott Kitterman (kitterman) wrote :

Hello Alexey, or anyone else affected,

Accepted qt4-x11 into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/qt4-x11/4:4.8.1-0ubuntu4.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in qt4-x11 (Ubuntu Quantal):
status: Confirmed → Fix Committed
Changed in qt4-x11 (Ubuntu Precise):
status: Confirmed → Fix Committed
Alexey Borzenkov (snaury) wrote :

Scott, I have confirmed that the crash was fixed when it was in trusty-proposed (sorry for not saying so back then). I also just checked with my saucy vm, plasma with 4:4.8.4+dfsg-0ubuntu18.1 reconfirmed to crash and (hurray!) plasma with 4:4.8.4+dfsg-0ubuntu18.2 confirmed NOT to crash. Hope this hits saucy-updates soon. :)

I don't have any good vm with precise right now, so can't test 4:4.8.1-0ubuntu4.7 yet.

tags: added: verification-done-saucy
Alexey Borzenkov (snaury) wrote :

Just installed and tested precise. For whatever reason I couldn't reproduce plasma-desktop crash with neither 4:4.8.1-0ubuntu4.6, nor 4:4.8.1-0ubuntu4.7, no matter how many times I switch between Activities and Add widgets. Maybe there's something different about 12.04 that makes it not crash like it was for saucy and trusty. Not sure whether it means verified or not...

Alexey Borzenkov (snaury) wrote :

Just tested quantal:

4:4.8.3+dfsg-0ubuntu3.2 crashes
4:4.8.3+dfsg-0ubuntu3.3 doesn't crash

tags: added: verification-done-quantal
Jonathan Riddell (jr) wrote :

Reuploaded without patch to bug 1290514 so that this one can proceed

Jonathan Riddell (jr) wrote :

Please reconfirm the new builds, sorry for the hassle.

tags: removed: verification-done-quantal verification-done-saucy
Alexey Borzenkov (snaury) wrote :

For saucy under VirtualBox with resolution 1280x960:

4:4.8.4+dfsg-0ubuntu18.1 crashes
4:4.8.4+dfsg-0ubuntu18.3 doesn't crash

tags: added: virification-done-saucy
tags: added: verification-done-saucy
removed: virification-done-saucy
Alexey Borzenkov (snaury) wrote :

I just read quantal release notes and it seems support period is 18 months, so isn't support over for quantal? It also seems odd that update package is for Quantal and not for Raring...

On Sunday, April 27, 2014 18:09:58 you wrote:
> I just read quantal release notes and it seems support period is 18
> months, so isn't support over for quantal? It also seems odd that update
> package is for Quantal and not for Raring...

Raring was the first release to drop to a 9 month support window. Quantal will
be retired shortly, but hasn't quite yet.

Alexey Borzenkov (snaury) wrote :

Quantal under VMWare Player, 1280x800:

-0ubuntu3.2 crashes
-0ubuntu3.4 doesn't crash

tags: added: verification-done-quantal
Alexey Borzenkov (snaury) wrote :

Tried again, but still couldn't reproduce plasma crash on precise.

Rohan Garg (rohangarg) wrote :

I can confirm that I can't reproduce the crash on 12.04.4, with/without the update. Not sure how to proceed here.

Rohan Garg (rohangarg) on 2014-05-21
tags: added: verification-done-precise
tags: removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt4-x11 - 4:4.8.4+dfsg-0ubuntu18.3

---------------
qt4-x11 (4:4.8.4+dfsg-0ubuntu18.3) saucy; urgency=medium

  [ Rohan Garg ]
  * Add kubuntu_98_a11y_fix_crash.diff to fix plasma crashing due to
    ubuntu-specific accessibility patch LP: #1289600
 -- Rohan Garg <email address hidden> Wed, 12 Mar 2014 16:33:21 +0100

Changed in qt4-x11 (Ubuntu Saucy):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for qt4-x11 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt4-x11 - 4:4.8.1-0ubuntu4.8

---------------
qt4-x11 (4:4.8.1-0ubuntu4.8) precise; urgency=medium

  [ Rohan Garg ]
  * Add kubuntu_98_a11y_fix_crash.diff to fix plasma crashing due to
    ubuntu-specific accessibility patch LP: #1289600
 -- Rohan Garg <email address hidden> Wed, 12 Mar 2014 18:13:21 +0100

Changed in qt4-x11 (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt4-x11 - 4:4.8.3+dfsg-0ubuntu3.4

---------------
qt4-x11 (4:4.8.3+dfsg-0ubuntu3.4) quantal-proposed; urgency=medium

  [ Rohan Garg ]
  * Add kubuntu_98_a11y_fix_crash.diff to fix plasma crashing due to
    ubuntu-specific accessibility patch LP: #1289600
 -- Rohan Garg <email address hidden> Wed, 12 Mar 2014 16:33:21 +0100

Changed in qt4-x11 (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers