qt4 apps doesn't start with symbol lookup error

Bug #115970 reported by humufr on 2007-05-21
52
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Qt
Invalid
Undecided
Unassigned
qt4-x11 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: qt4-qtconfig

Hi,

I tried this morning to use qt4-qtconfig to configure some fonts but the sofware doesn't start and give this error message:

$ qtconfig-qt4
qtconfig-qt4: symbol lookup error: /usr/lib/libQt3Support.so.4: undefined symbol: _ZNK9QMenuItem10metaObjectEv

I tried to reinstall libqt4-qt3support but nothing change.

Nicolas Valcarcel (nvalcarcel) wrote :

I have the same problem with lastfm:

$ lastfm
lastfm: symbol lookup error: /usr/lib/libQtNetwork.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv

And i have seen on the forums same problem with Skype:
http://ubuntuforums.org/showthread.php?t=634647

Changed in qt4-x11:
status: New → Confirmed
Jonathan Riddell (jr) wrote :

I can't recreate this, what's the output of

apt-cache policy libqt4-core libqt4-gui

Nicolas Valcarcel (nvalcarcel) wrote :

$ apt-cache policy libqt4-core libqt4-gui
libqt4-core:
  Installed: 4.3.2-0ubuntu3.1
  Candidate: 4.3.2-0ubuntu3.1
  Version table:
 *** 4.3.2-0ubuntu3.1 0
        500 http://pe.archive.ubuntu.com gutsy-updates/main Packages
        100 /var/lib/dpkg/status
     4.3.2-0ubuntu3 0
        500 http://pe.archive.ubuntu.com gutsy/main Packages
libqt4-gui:
  Installed: 4.3.2-0ubuntu3.1
  Candidate: 4.3.2-0ubuntu3.1
  Version table:
 *** 4.3.2-0ubuntu3.1 0
        500 http://pe.archive.ubuntu.com gutsy-updates/main Packages
        100 /var/lib/dpkg/status
     4.3.2-0ubuntu3 0
        500 http://pe.archive.ubuntu.com gutsy/main Packages

i also haven't kde installed, i use gnome

Jonathan Riddell (jr) wrote :

This report is for gutsy, that wasn't clear before.

I still can't recreate it and neither can another tester. However it's being reported from multiple sources.

Jonathan Riddell (jr) wrote :

Some other related issues:

http://suseforums.net/index.php?showtopic=42051
http://ubuntuforums.org/showthread.php?t=634647
https://bugs.edge.launchpad.net/ubuntu/+source/qt4-qtruby/+bug/128797
http://qa.mandriva.com/show_bug.cgi?id=32493

It's caused by Qt4 patch debian/patches/0180-window-role.diff which introduces a virtual function into QObjectPrivate creating an ABI change, but that patch is not a recent addition nor has it been removed or changed in gutsy-updates or hardy or the KDE 4 PPA.

Jonathan Riddell (jr) wrote :

Since there is an ABI change I can understand apps from outside our repository not building. I tested last.fm and skype and they both run fine against libqt4-core 4.3.2-0ubuntu3.1 from gutsy-updates.

Jonathan Riddell (jr) wrote :

s/building/running/

Jonathan Riddell (jr) wrote :

Has anyone built Qt 4 themselves?

Jonathan Riddell (jr) wrote :

This has been confirmed with one reporter to be caused by nessus which installs its own copy of Qt4.

Jonathan Riddell (jr) wrote :

Please paste the output of ldd /usr/bin/qtconfig-qt4 (or other problematic program) if this is still a problem.

Nicolas Valcarcel (nvalcarcel) wrote :

$ ldd /usr/bin/lastfm
 linux-gate.so.1 => (0xffffe000)
 libLastFmTools.so.1 => /usr/lib/libLastFmTools.so.1 (0xb7f3c000)
 libQtXml.so.4 => /opt/nessus/lib/libQtXml.so.4 (0xb7ed3000)
 libQtGui.so.4 => /opt/nessus/lib/libQtGui.so.4 (0xb76db000)
 libQtNetwork.so.4 => /usr/lib/libQtNetwork.so.4 (0xb764b000)
 libQtCore.so.4 => /opt/nessus/lib/libQtCore.so.4 (0xb74a2000)
 libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb748a000)
 libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7397000)
 libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7372000)
 libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7366000)
 libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb721c000)
 libz.so.1 => /usr/lib/libz.so.1 (0xb7207000)
 libX11.so.6 => /usr/lib/libX11.so.6 (0xb7116000)
 libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb7111000)
 librt.so.1 => /lib/tls/i686/cmov/librt.so.1 (0xb7107000)
 libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb704a000)
 libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7046000)
 libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb7023000)
 libSM.so.6 => /usr/lib/libSM.so.6 (0xb701b000)
 libICE.so.6 => /usr/lib/libICE.so.6 (0xb7002000)
 libXi.so.6 => /usr/lib/libXi.so.6 (0xb6ffa000)
 libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb6ff2000)
 libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb6fec000)
 libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb6fe7000)
 libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb6fde000)
 libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xb6fda000)
 libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb6f6a000)
 libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb6f3f000)
 libXext.so.6 => /usr/lib/libXext.so.6 (0xb6f31000)
 /lib/ld-linux.so.2 (0xb7fdd000)
 libXau.so.6 => /usr/lib/libXau.so.6 (0xb6f2e000)
 libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb6f28000)
 libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb6f08000)

D4nielfree (d4nielfree) wrote :

confirm this bug, just after i installed Nessus.
according to http://ubuntuforums.org/showthread.php?t=556058,
remove /opt/nessus/lib from /etc/ld.so.conf and re-run ldconfig just solved the problem

Terence Simpson (tsimpson) wrote :

If this is caused by installing third-party applications then it's not a bug in Qt but in the third-party application.

Changed in qt4-x11:
status: Confirmed → Invalid

This is not a third-party bug!! Please do not pass the "ball" from one to another maintainer or bug fixer or how ever do You guys call yourself !!
I am seek and tired being passed around.
Let some of you fix this problem once for all or even try doing so!!
I got error starting smplayer but I am sure that this error isn't caused installing third party applications :
/usr/lib/libQtNetwork.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv
In the next post i will give you some further logs and other stuff when I collect it from many other maintainers where I reported a bug but been sent around.

Thans!!

The output of ldd -r /usr/lib/libQtNetwork.so.4 :
undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv (/usr/lib/libQtNetwork.so.4)
 linux-gate.so.1 => (0xb7f6b000)
 libQtCore.so.4 => /lib/libQtCore.so.4 (0xb7d19000)
 libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb7cef000)
 libz.so.1 => /usr/lib/libz.so.1 (0xb7cd9000)
 libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb7cd4000)
 librt.so.1 => /lib/tls/i686/cmov/librt.so.1 (0xb7ccb000)
 libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb7c1a000)
 libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7c02000)
 libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7bfe000)
 libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7b0a000)
 libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7ae5000)
 libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7ada000)
 libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb798b000)
 libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb791b000)
 libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb78f9000)
 libselinux.so.1 => /lib/libselinux.so.1 (0xb78e0000)
 /lib/ld-linux.so.2 (0xb7f6c000)
 libpcre.so.3 => /usr/lib/libpcre.so.3 (0xb78b9000)

the output of lsb_release -rd :
Description: Ubuntu 8.04
Release: 8.04

the "dpkg -l "libqt4*" "smplayer" | grep "^ii" > dpkg-l.log " content is:

ii libqt4-core 4.3.4-0ubuntu3 Qt 4 core non-GUI functionality runtime library
ii libqt4-dev 4.3.4-0ubuntu3 Qt 4 development files
ii libqt4-gui 4.3.4-0ubuntu3 Qt 4 core GUI functionality runtime library
ii libqt4-qt3support 4.3.4-0ubuntu3 Qt 3 compatibility library for Qt 4
ii libqt4-sql 4.3.4-0ubuntu3 Qt 4 SQL database module

If You need more details please do not hesitate to contact me!!

Keith Baker (keibak) wrote :

D4nielfree wrote on 2008-04-21: remove /opt/nessus/lib from /etc/ld.so.conf and re-run ldconfig just solved the problem

That solves the Skype/Virtualbox/... problems, but Nessus won't start anymore. So I didn't remove /opt/nessus/lib from /etc/ld.so.conf, instead I deleted all qt-files (libQt*) from /opt/nessus/lib.

Now Nessus and Skype run and VirtalBox 2.0-Windows are drawn correctly.

Changed in qt4-x11:
status: Invalid → New
Changed in qt4-x11:
status: New → Invalid
Jimmy Happy (jimmyhappyi) wrote :

I have found this bug. This bug is VALID.

Many have reported about a bug with QT, with other libraries of QT in other directories.

(skype, nessus, etc.)
This bug has NOTHING to do with private copies of QT libraries.

ldd `which qtconfig` | grep Qt:
 libQt3Support.so.4 => /usr/lib/libQt3Support.so.4 (0xb7cab000)
 libQtSql.so.4 => /usr/lib/libQtSql.so.4 (0xb7c67000)
 libQtXml.so.4 => /usr/lib/libQtXml.so.4 (0xb7c0e000)
 libQtNetwork.so.4 => /usr/lib/libQtNetwork.so.4 (0xb7b7d000)
 libQtGui.so.4 => /usr/lib/libQtGui.so.4 (0xb7343000)
 libQtCore.so.4 => /usr/lib/libQtCore.so.4 (0xb6f96000)

This affects 8.04, a LTS release. So far, I've heard that 8.10 works fine.
Isn't 8.04 a LTS? It's not acting like one! So far, NO FIXES for QT in this version! :(

Ramon (donramon) wrote :
Download full text (3.9 KiB)

I also have a problem in 8.10.

I have identified at least the following programs not running: skype, last.fm, virtualbox.

I have not installed nessus so the solution provided in some forums does not apply.

Following the posts in this thread, I have tried to extract some extra information:

My /etc/ld.so.conf:

include /etc/ld.so.conf.d/*.conf

/usr/lib
/usr/local/lib
/usr/local/lib/siscardplugins

Some ldd messages:

$ ldd /usr/bin/lastfm
 not a dynamic executable

$ ldd /usr/bin/skype
 linux-gate.so.1 => (0xb7f03000)
 libasound.so.2 => /usr/lib/libasound.so.2 (0xb7e06000)
 libXv.so.1 => /usr/lib/libXv.so.1 (0xb7e00000)
 libXss.so.1 => /usr/lib/libXss.so.1 (0xb7dfb000)
 librt.so.1 => /lib/tls/i686/cmov/librt.so.1 (0xb7df2000)
 libQtDBus.so.4 => /usr/lib/libQtDBus.so.4 (0xb7d84000)
 libQtGui.so.4 => /usr/local/lib/libQtGui.so.4 (0xb754d000)
 libQtNetwork.so.4 => /usr/lib/libQtNetwork.so.4 (0xb744c000)
 libQtCore.so.4 => /usr/local/lib/libQtCore.so.4 (0xb729d000)
 libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7283000)
 libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7195000)
 libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb716f000)
 libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7160000)
 libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7002000)
 libX11.so.6 => /usr/lib/libX11.so.6 (0xb6f13000)
 libXext.so.6 => /usr/lib/libXext.so.6 (0xb6f03000)
 libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb6eff000)
 /lib/ld-linux.so.2 (0xb7ee9000)
 libQtXml.so.4 => /usr/lib/libQtXml.so.4 (0xb6ebb000)
 libz.so.1 => /usr/lib/libz.so.1 (0xb6ea5000)
 libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0xb6ea2000)
 libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb6e88000)
 libXau.so.6 => /usr/lib/libXau.so.6 (0xb6e85000)
 libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb6e80000)

$ ldd /usr/bin/virtualbox
 not a dynamic executable

$ dpkg -l "libqt4*" "skype" | grep "^ii" > dpkg-l.log
ii libqt4-assistant 4.4.3-0ubuntu1.2 Qt 4 assistant module
ii libqt4-core 4.4.3-0ubuntu1.2 transitional package for Qt 4 core non-GUI r
ii libqt4-dbus 4.4.3-0ubuntu1.2 Qt 4 D-Bus module
ii libqt4-designer 4.4.3-0ubuntu1.2 Qt 4 designer module
ii libqt4-gui 4.4.3-0ubuntu1.2 transitional package for Qt 4 GUI runtime li
ii libqt4-network 4.4.3-0ubuntu1.2 Qt 4 network module
ii libqt4-opengl 4.4.3-0ubuntu1.2 Qt 4 OpenGL module
ii libqt4-qt3support 4.4.3-0ubuntu1.2 Qt 3 compatibility library for Qt 4
ii libqt4-script 4.4.3-0ubuntu1.2 Qt 4 script module
ii libqt4-sql 4.4.3-0ubuntu1.2 ...

Read more...

Terence Simpson (tsimpson) wrote :

You have a mix of /usr/lib and /usr/local/lib there, mixing libraries like that is bound to cause problems.

Ramon (donramon) wrote :

Thanks for the hint Terence, but what does that mean? It is not like if I chose where to put the libs myself, I rely on synaptic for that.

Any ideas for a solution?

Terence Simpson (tsimpson) wrote :

No Ubuntu packages will install anything to /usr/local, it must be something you installed manually or a .deb you installed from a 3rd party repository.
If it's the latter you can find the package with: dpkg -S usr/local/lib/libQtCore.so.4

Ramon (donramon) wrote :

Thank you Terence.

The thing that I installed automatically out of synaptic was Adobe Air, when I clicked on the install button for TweetDeck or Twhirl in their page. I guess that could be the source of the problem. I guess that an automatic install like that is too good to be true!

When I run dpkg -S usr/local/lib/libQtCore.so.4 as you mention, I get a "not found" message.

Could you please tell me what do I have to do to properly reinstall QT? I have done a preliminary search, but most of the packages people mention are not present, although I have Universe repositories checked.

Ramon (donramon) wrote :

libQTCore is in the usr/local/lib directory. I cd to it and run dpkg -S usr/local/lib/libQtCore.so.4

The computer says:

libqtcore4: /usr/lib/libQtCore.so.4.4.3
libqtcore4: /usr/lib/libQtCore.so.4
libqtcore4: /usr/lib/libQtCore.so.4.4

Terence Simpson (tsimpson) wrote :

I would suggest just moving (or removing) those libraries from /usr/local/lib and seeing if Qt applications start to work

Ramon (donramon) wrote :

It works !

Thanks a lot Terence :)

mike.simonson (mike-simonson) wrote :

worked for me too

thanks a lot Terence because i had kdenlive virtualbox and many other application not working anymore.

mike.simonson (mike-simonson) wrote :

Hum the solution works perfectly for me but each time i reboot the files in /usr/local/lib are recreated or maybe it's a program i run that put them back there.
Anyway is there a solution to know which program has created the files?

vpxavier (vpxavier-gmail) wrote :

Hello, I have the same problem with ubuntu 9.04.

When trying to launch virtualbox-ose:

vpxavier (vpxavier-gmail) wrote :

sorry... when trying to launch virtualbox-ose:
VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: /usr/lib/libQtNetwork.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv

when trying to launch skype:
skype: symbol lookup error: /usr/lib/libQtNetwork.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv

For info:
# dpkg -S usr/lib/libQtCore.so.4 gives me:
            libqtcore4: /usr/lib/libQtCore.so.4
            libqtcore4: /usr/lib/libQtCore.so.4.5.0
            libqtcore4: /usr/lib/libQtCore.so.4.5

Hey,

This solved also my problem. It occured after installing the belgian identity card reader software (beid) provided by the government. Their software installer is a piece of crap :-p I read on another forum that they are actually advising to use the beid that is in the ubuntu repo.

Anyhow, what the installer did was putting some custom libQtCore.so.4 and libQtGui.so.4 in the /usr/local/lib directory. Just removing those and running ldconfig again did the trick.

Thanks guys!

Thanks Yarlie and all others
Same here with the Belgian ID reader :-' - I didn't realise there was a package for that.

Jack (jgreindl) wrote :

Thanks all
Same here with the Belgian ID reader...

Belgian Gov really needs help ;-)

SX (sx-simpson) wrote :

Hi,

I have the same issue with my eid card reader but I can't remove permanently the two files libQtCore.so.4 and libGTGui.so.4 in /usr/local/lib/beidqt/. To remove it I make a sudo nautilus and remove it manually. VLC and co work good after this removal but when I make a sudo ldconfig or I restart my computer the two files are back. I'm not a geek. Somebody could give me a solution please?

Thanks

Ubuntu LinuXer (akifkucet) wrote :

I get it with Ubuntu 10.04 64 bit too.

Ubuntu LinuXer (akifkucet) wrote :

None of the solution worked for me.

Shane (shane-h-1) wrote :

What the hell, one day I was using skype, the next I get this flippin error. I ran through the above troubleshooting, and got nowhere.

Prosper (prosper-nl) wrote :

Ran into it today too. Trying to play kshisen.
I don't have any libQtSvg files in /usr/local/lib, only in /usr/lib.
None of the above workarounds gave any help.
Neither did reinstalling.

Jezscha (jezschaj) wrote :

Hi, unfortunately i have similar problem.. Since i have installed new Ubuntu 10.04 (brand new installation) i cannot access VLC, QT_setting_utility, QT_designer, qBittorrent, and so on. Non of QT apps works except the application with their own qt library (NUKE, MAYA). I have already reinstalled QT many times but unsuccessfully.

qt4-designer:
my@me-laptop:~$ /usr/bin/designer-qt4: symbol lookup error: /usr/lib/libQtScript.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv

VLC:
my@me-laptop:~$ VLC media player 1.0.6 Goldeneye
(it works to play film but without qtGui...)

my@me-laptop:~$ qbittorrent: symbol lookup error: /usr/lib/libQtGui.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv

my@me-laptop:~$ ldd /usr/lib/libQtGui.so.4
 linux-vdso.so.1 => (0x00007fffb25ff000)
 libaudio.so.2 => /usr/lib/libaudio.so.2 (0x00007fceba07a000)
 libpng12.so.0 => /lib/libpng12.so.0 (0x00007fceb9e53000)
 libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007fceb9bcc000)
 libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x00007fceb9984000)
 libSM.so.6 => /usr/lib/libSM.so.6 (0x00007fceb977b000)
 libICE.so.6 => /usr/lib/libICE.so.6 (0x00007fceb955f000)
 libQtCore.so.4 => /usr/lib/libQtCore.so.4 (0x00007fceb921a000)
 libz.so.1 => /lib/libz.so.1 (0x00007fceb9003000)
 libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x00007fceb8d24000)
 libpthread.so.0 => /lib/libpthread.so.0 (0x00007fceb8b07000)
 libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00007fceb88fd000)
 libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00007fceb86c7000)
 libXext.so.6 => /usr/lib/libXext.so.6 (0x00007fceb84b5000)
 libX11.so.6 => /usr/lib/libX11.so.6 (0x00007fceb817f000)
 libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007fceb7e6a000)
 libm.so.6 => /lib/libm.so.6 (0x00007fceb7be7000)
 libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00007fceb79d0000)
 libc.so.6 => /lib/libc.so.6 (0x00007fceb764c000)
 libXt.so.6 => /usr/lib/libXt.so.6 (0x00007fceb73e7000)
 libXau.so.6 => /usr/lib/libXau.so.6 (0x00007fceb71e3000)
 libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0x00007fceb6fdd000)
 librt.so.1 => /lib/librt.so.1 (0x00007fceb6dd5000)
 libpcre.so.3 => /lib/libpcre.so.3 (0x00007fceb6ba7000)
 libuuid.so.1 => /lib/libuuid.so.1 (0x00007fceb69a1000)
 libdl.so.2 => /lib/libdl.so.2 (0x00007fceb679d000)
 /lib64/ld-linux-x86-64.so.2 (0x00007fcebae66000)
 libexpat.so.1 => /lib/libexpat.so.1 (0x00007fceb6573000)
 libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007fceb6357000)
 libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007fceb6150000)

I am trying to make it work last 5 days and even copying the same library-pack from already mentioned applications (maya, nuke) didn't work... So i am really stuck.. Please help my somebody!! Any suggestion will be appreciated!

Joost Ringoot (joost) wrote :

Thanks guys, it worked for me too.
I did this:
mkdir -p Desktop/usr/local/lib/beidqt/
mv /usr/local/lib/beidqt/libQtGui.so.4 Desktop/usr/local/lib/beidqt/
mv /usr/local/lib/beidqt/libQtCore.so.4 Desktop/usr/local/lib/beidqt/

All those broken apps like : k3b, vlc, kate, amarok work again.
Heartgroundily: "THANK YOU!"

Leonid Evdokimov (darkk) wrote :

Google Earth package does same evil thing while placing path to their own Qt version into /etc/ld.so.conf.d/googleearth.conf - that break skype, for example.

Ditto Prosper. Kshishen will not launch on 10.04. Recently reinstalled Google Earth, so that is probable culprit. No QT4 in /usr/local/lib. Does anyone have a solution for this on 10.04?

Mannex (russ-mannex) wrote :

The only solution I came up with was reinstalling the OS, not as a solution (because that would be rather drastic!), but because I had to -- my hard drive crashed. When I got everything running again, I just didn't install GoogleEarth. Sorry. Not much help.

Nixblicker (el-lunatico) wrote :
Download full text (14.4 KiB)

Hello,

i have the same problem on 10.04
"ldd -d -r /usr/lib/libQt*.so.4 | grep undefined" gives the following

undefined symbol: _Z9qBadAllocv (/usr/lib/libQtXml.so.4)
undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv (/usr/lib/libQtSql.so.4)
undefined symbol: _Z9qBadAllocv (/usr/lib/libQtSql.so.4)
undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN14QWidgetPrivate15checkWindowRoleEv (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZNK9QMenuItem10metaObjectEv (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN9QMenuItem11qt_metacastEPKc (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN9QMenuItem11qt_metacallEN11QMetaObject4CallEiPPv (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZTI9QMenuItem (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZTV9QMenuItem (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN6QTimerC1EP7QObjectPKc (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN7QWidget5eraseERK7QRegion (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN12QCustomEventC1EiPv (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN7QPixmapC1ERK6QImage (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN11QPushButtonC1EP7QWidgetPKc (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN6QLabelC1ERK7QStringP7QWidgetPKc6QFlagsIN2Qt10WindowTypeEE(/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN11QToolButton13setPopupDelayEi (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZNK17QContextMenuEvent5stateEv (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN11QGridLayoutC2EP7QWidgetiiiiPKc (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN15QSocketNotifierC1EiNS_4TypeEP7QObjectPKc (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN5QMenu10insertItemEP9QMenuItemii (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZNK7QWidget14backgroundModeEv (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZNK10QTextCodec11fromUnicodeERK7QStringRi (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN6QTimer5startEib (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZNK7QWidget11visibleRectEv (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN11QPushButtonC1ERK7QStringP7QWidgetPKc (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZNK7QString12ascii_helperEv (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZNK8QPalette16createColorGroupENS_10ColorGroupE (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN4QDir15setMatchAllDirsEb (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN6QLabelC1EP7QWidgetRK7QStringS1_PKc6QFlagsIN2Qt10WindowTypeEE (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN7QDialogC2EP7QWidgetPKcb6QFlagsIN2Qt10WindowTypeEE (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN9QMenuItemC2Ev (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN8QSpinBoxC1EiiiP7QWidgetPKc (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZNK7QObject9queryListEPKcS1_bb (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN11QGridLayoutC1EP7QWidgetiiiiPKc (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN9QIODevice11resetStatusEv (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZNK8QPainter12translationXEv (/usr/lib/libQt3Support.so.4)
undefined symbol: _ZN11QTextStream11setEncodingENS_8EncodingE (/usr/lib/libQt3Support.so.4)
...

Mannex (russ-mannex) wrote :

Nixblicker, the only thing I can say is that for the majority of the cases I've encountered since opening this issue, it seems that installation of GoogleEarth is the culprit. If you have that installed, that is likely the cause. The only solution I have found is a reinstallation of the OS and NOT installing GoogleEarth. Apparently, they don't play well with Ubuntu anymore.

Nixblicker (el-lunatico) wrote :

Hey guys,

seems that i have solved this problem for me - i recently moved over to a newer PC, and our admin tried to recover as much software as possible from that has been installed previously. I didn't even knew i had GoogleEarth installed before, but it was now - and most likely this was really the culprit.
But there is absolutely no need to reinstall your entire system - i simply found duplicate (obsolete) copies of
/usr/lib/libQtCore.so.4
/usr/lib/libQtGui.so.4
/usr/lib/libQtNetwork.so.4
/usr/lib/libQtWebKit.so.4

in /lib - i guess this screwed the library linking in ld. So make sure you do not have duplicates in the Path, may it be /usr/local/lib or /lib or wherever.
All i did was to move those suspects to another folder not in the Path, update ld via "ldconfig" and all "undefined symbols" were gone.

Good luck!
Cheers, Nix

Mannex (russ-mannex) wrote :

Hey Nix, thanks very much for the info! Definitely something to keep note of. I have another question. Did you leave GoogleEarth installed? In other words, now that you've removed the errant libraries, does GoogleEarth run? If you already removed it, don't install it just to find out (since I think it caused the problem in the first place). Just curious. If it works now, that may be the solution to those who absolutely have to have GoogleEarth installed. Thanks again for the solution!

Terje Andre Arnøy (terjeaar) wrote :

Ok, I have a similar error, but no Google Earth. Are there any other known culprits for this error?

Changed in qt:
status: New → Invalid

The problem is caused by 3rd party application installing own versions of Qt libraries. In my case, it is MF 710 3G modem used by sold by some mobile operators here (Bangladesh). The libraries are in `/opt/Teletalk_3G/usr/lib` (for Teletalk provider). The solution is just remove those libraries.

cd /opt/Teletalk_3G/usr/lib
sudo mv libQt* /tmp/

Then use `ldconfig` command to reload the libraries.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.