Qt 3D fails to build against Qt 5.4.0 beta

Bug #1395657 reported by Timo Jyrinki
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qt3d-opensource-src (Ubuntu)
Albert Astals Cid

Bug Description

Qt 3D fails to build against Qt 5.4.0 beta on amd64 on armhf (but succeeds on i386): https://launchpad.net/~canonical-qt5-edgers/+archive/ubuntu/qt5-beta2/+sourcepub/4581018/+listing-archive-extra

However, Qt Location 5.4.0 no longer depends on Qt 3D so there's the option to simply remove the obsolete Qt 3D from archives too. The rewritten Qt 3D 2.0 can be included later when it's released.

More information about Qt testing at https://wiki.ubuntu.com/Touch/QtTesting

Changed in qt3d-opensource-src (Ubuntu):
status: New → In Progress
assignee: nobody → Albert Astals Cid (aacid)
Revision history for this message
Albert Astals Cid (aacid) wrote :

I agree we could just obsolete it since Qt 3D is probably not used anywhere, but since fixing the compilation is easy we should fix the compilation first and then see if we can obsolete it in a second step.

Revision history for this message
Albert Astals Cid (aacid) wrote :

The said patch

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "noprecompile.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

Seems to work, great! https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/landing-005/+sourcepub/4703418/+listing-archive-extra

I think I tried https://codereview.qt-project.org/#/c/84325/ in December but it didn't help even though it tried to do the same thing.

Changed in qt3d-opensource-src (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt3d-opensource-src - 5.0~git20130731-0ubuntu9

qt3d-opensource-src (5.0~git20130731-0ubuntu9) vivid; urgency=medium

  * Build against Qt 5.4.0
  * debian/patches/noprecompile.patch (LP: #1395657)
 -- Timo Jyrinki <email address hidden> Fri, 13 Feb 2015 06:45:53 +0000

Changed in qt3d-opensource-src (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers