QT program doesn't select Chinese font correctly

Bug #94282 reported by Peng Deng on 2007-03-21
56
Affects Status Importance Assigned to Milestone
qt-x11-free (Debian)
Fix Released
Unknown
qt-x11-free (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libqt3-mt

In Feisty, with non-Chinese locale (e.g. en_US.UTF-8), if set default system font to an English font (Sans serif, Bitstream Vera San, etc.) in kcontrol/qtconfig, QT programs neglect all the Chinese fonts in Fontconfig's "alias" list or QT's own font substitution list. Chinese characters are displayed ugly using possibly a Japanese font.

GTK+ program will conform the settings in fontconfig and correctly display all the Chinese characters with proper font.

If locale is set to zh_CN.UTF-8, Chinese font then get the highest priority in QT apps, even the font Sans serif are displayed using the Chinese font.

libqt3-mt version: 3:3.3.8-0ubuntu2 (feisty)

Related branches

Peng Deng (d6g) on 2007-03-21
description: updated
Peng Deng (d6g) on 2007-03-22
Changed in qt-x11-free:
status: Unconfirmed → Confirmed
magisu (magi-mail) wrote :

I have met the same problem. It seems the only way is recompile the corresponding libraries.

Michael Ummels (urmel291) wrote :

This bug has been giving me headaches since Dapper. I could work around the bug by adding font substitutions in qtrc in Dapper and Edgy, but apparently this does not work anymore in Feisty. I really hope this bug gets fixed very soon!

Yes, it's really annoying and i hope someone could fix it before the
final release.

On 3/25/07, Michael Ummels <email address hidden> wrote:
> This bug has been giving me headaches since Dapper. I could work around
> the bug by adding font substitutions in qtrc in Dapper and Edgy, but
> apparently this does not work anymore in Feisty. I really hope this bug
> gets fixed very soon!
>
> --
> QT program doesn't select Chinese font correctly
> https://launchpad.net/bugs/94282
>

ZhengPeng Hou (zhengpeng-hou) wrote :

will revert to use qt-3.3.7, and Riddell is working on it.

Changed in qt-x11-free:
status: Confirmed → In Progress
Abel Cheung (abelcheung) wrote :

Is it in some way related to the following upstream KDE/QT bug?
https://bugs.kde.org/show_bug.cgi?id=39185

ZhengPeng Hou (zhengpeng-hou) wrote :

After upgrade to qt-3.3.8, seems qt can not select Chinese fonts correctly under latin locales, but it could do in qt-3.3.7. And it's a known bug of QT, for qt's font redenring mechanism, it have some improvement in QT4.

Michael Ummels (urmel291) wrote :

I would not say that it really "worked" in qt-3.3.7. Altohough I could get Chinese fonts to display in qt-3.3.7 by setting up substitution rules using QT's font substitution mechanism, I don't think this is the way it should work. QT really should use the preference rules made in fontconfig here (as do all GTK applications).

ZhengPeng Hou (zhengpeng-hou) wrote :

2007/3/26, Michael Ummels <email address hidden>:
> I would not say that it really "worked" in qt-3.3.7. Altohough I could
> get Chinese fonts to display in qt-3.3.7 by setting up substitution
> rules using QT's font substitution mechanism, I don't think this is the
> way it should work. QT really should use the preference rules made in
> fontconfig here (as do all GTK applications).
Using qt-3.3.8, Chinese characters can be displayed , but it can not
handle latin characters well when you under zh_CN.UTF-8 locales.
> --
> QT program doesn't select Chinese font correctly
> https://launchpad.net/bugs/94282
>

Peng Deng (d6g) wrote :

I totally agree with you, Michael, as for font rendering, it's better to have one and only one uniform mechanism in the system.

Magi Su (magisu) wrote :

it seems that a new libqt3-mt is out, i don't know if it works.

Peng Deng (d6g) wrote :

It works very well for Chinese font now and a better change is, it uses at present the settings in fontconfig prior to qtconfig's font substitution rules, which i longed to see ever since in edgy era.

But the interface of all qt apps becomes very ugly and I can not change them back to the default KDE theme using qtconfig/kcontrol because the "Plastik" is not longer in the "Style" list.

Michael Ummels (urmel291) wrote :

Indeed, the font bug seems to have been fixed by the latest update, and QT is using fontconfig for font substitution at last. However, I have the same problem as Peng with the missing KDE styles. Not only Plastik is gone, but also Polyester, the new standard theme!

Peng Deng (d6g) wrote :

Well, as for now, you can install polymer which can give the qt apps
similiar look as Plastik.

On 3/26/07, Michael Ummels <email address hidden> wrote:
> Indeed, the font bug seems to have been fixed by the latest update, and
> QT is using fontconfig for font substitution at last. However, I have
> the same problem as Peng with the missing KDE styles. Not only Plastik
> is gone, but also Polyester, the new standard theme!
>
> --
> QT program doesn't select Chinese font correctly
> https://launchpad.net/bugs/94282
>

Michael Ummels (urmel291) wrote :

After another dist-upgrade, all the styles are back there and everything seems to be working fine.

Michael Ummels (urmel291) wrote :

I have just noticed that there are still problems with QT selecting the right font. It seems that only the default fonts "Sans-Serif", "Serif" and "Monospace" are substituted correctly, but not other sans-serif, serif or monospace fonts. I have attached an HTML file demonstrating the bug. In Konqueror, only the paragraph with "sans-serif" as font is substitued correctedly. For other sans-serif fonts like "Bitstram Vera Sans", "Kochi Gothic" is selected wrongly to display Chinese characters. Other serif fonts like "Bitstream Vera Serif" are substituted with the right font but characters which are not in the range of the Kochi Gothic font are not displayed at all (which is very strange). On the contrary, in Firefox, all fonts are substituted with the Chinese sans-serif font (which is not quite correct, as serif fonts should be replaced with the Chinese serif font).

Michael Ummels (urmel291) wrote :

This is my .fonts.conf which should do the substitutions for reference.

ZhengPeng Hou (zhengpeng-hou) wrote :

To Michael:
 please have a look at /etc/fonts/language-selector.conf

We have already had alias for Sans-Serif Sans, and if you use kubuntu, ~/.fonts.conf will be chaged if you login KDE, for qt use different font rendering mechanism, so its useless to have such a configure. :)
Attached is the result of rendering your page

Michael Ummels (urmel291) wrote :

Okay, I have removed my .fonts.conf and issued
fontconfig-voodoo -f -s zh_CN
instaed to activate Chinese fonts (this sets a symlink from /etc/fonts/language-selector.conf to /usr/share/language-selector/fontconfig/zh_CN). Still, the result is nearly the same. The only difference is that Sans-Serif is substituted with ShanHeiSun Uni now rather than ZenKai Uni. I reckon that you are under a Chinese locale. As Peng mentions in the bug report, this problem only arises when you are under a non-chinese locale!

Peng Deng (d6g) wrote :

I have the same problem like Michael with all fonts other than "Sans
serif", "Serif" or "Monospace", which have specific name. And my
locale is en_US.UTF-8 currently.

Actually the problem is quite like in Edgy: you _have to_ use qtconfig
to assign Chinese font for those "specific" fonts, like Bitstream Vera
Sans, Luxi Sans, Verdana, etc. because qt apps will not use settings
in any fontconfig files for these fonts.

Well, I don't remeber in Edgy if qt apps conform the rules in
fontconfig for "Sans serf", "Serif" and "Monospace".

ZhengPeng Hou (zhengpeng-hou) wrote :

2007/3/27, Peng <email address hidden>:
> I have the same problem like Michael with all fonts other than "Sans
> serif", "Serif" or "Monospace", which have specific name. And my
> locale is en_US.UTF-8 currently.
>
> Actually the problem is quite like in Edgy: you _have to_ use qtconfig
> to assign Chinese font for those "specific" fonts, like Bitstream Vera
> Sans, Luxi Sans, Verdana, etc. because qt apps will not use settings
> in any fontconfig files for these fonts.
>
> Well, I don't remeber in Edgy if qt apps conform the rules in
> fontconfig for "Sans serf", "Serif" and "Monospace".
>
> --
> QT program doesn't select Chinese font correctly
> https://launchpad.net/bugs/94282
>
As I have siad it's a known bug of qt, it can not handle CJK font
under non-CJK locales. So how about close this bug here?

Emmet Hikory (persia) wrote :

I'd rather keep the bug open until it is fixed upstream (or a patch is generated). It may be useful for new people encountering the issue to find this bug instead of reporting a new one.

Michael Ummels (urmel291) wrote :

Yes, I agree. I had spent some time to get Chinese fonts working under Qt until I found out that it can apparently only be solved by setting up font substitution rules in Qt. People who stumble over the problem might find this report helpful.

Peng Deng (d6g) wrote :

I don't know whether there is any side effects or not if we keep this
bug open. If not, I agree with Michael and Emmet's idea to keep this
helpful information for other people.

On 3/27/07, Michael Ummels <email address hidden> wrote:
> Yes, I agree. I had spent some time to get Chinese fonts working under
> Qt until I found out that it can apparently only be solved by setting up
> font substitution rules in Qt. People who stumble over the problem might
> find this report helpful.
>
> --
> QT program doesn't select Chinese font correctly
> https://launchpad.net/bugs/94282
>

MilchFlasche (robertus0617) wrote :

Wow, finally I find this bug have already been recorded since March! Now it's the end of July, has the bug or upstream bug been fixed? Qt should really follow the fontconfig settings as Gtk does!

Magi Su (magisu) wrote :

Already, the QT works fine for me now!

--
学而不会是为学。

MilchFlasche (robertus0617) wrote :

Hi, it seems that later Qt releases (3.3.9+?) has solved this problem. But in my Kubuntu Feisty, I still can't see English fonts using correct Chinese substitutes following X11 fontconfig settings without any patch. So Magi or anyone else, could you please show me the way to solve this problem? Thank you in advance!

MilchFlasche (robertus0617) wrote :

And allow me to explain my situation more in detail:

I have installed Ubuntu, set fontconfig preferences ,mainly in etc/fonts/language-selector.conf (which is linked to /usr/......./zh-TW), following various instructions on the Web, and in GNOME and for Gtk+ applications, all English fonts can find subtitutions according to the substitutions of Sans, Serif or Monospace. But such thing doesn't happen in KDE, even if I have installed kde-i18n-zhTW, so for example if I set Purisa as the menu font, the Chinese characters would be rendered from Kochi, not Microsoft JhengHei which I have set in fontconfig --- just the same with all those symptoms you have reported above.

So, it seems that nothing has been fixed radically in Feisty since March, although on Trolltech track system it's said this issue of Qt was fixed since 3.3.9. What should I do to fix my Kubuntu (actually I just installed kde-desktop on Ubuntu) ? Do I have to change my locale somewhere? (But I am using zh-TW translations already!) I'd really appreciate you because there doesn't seem to be any decisive solution on the Web along my search.

Cheers.

Magi Su (magisu) wrote :

On Friday 27 July 2007 12:12:33
MilchFlasche wrote:
> Hi, it seems that later Qt releases
> (3.3.9+?) has solved this problem.
> But in my Kubuntu Feisty, I still
> can't see English fonts using correct
> Chinese substitutes following X11
> fontconfig settings without any
> patch. So Magi or anyone else, could
> you please show me the way to solve
> this problem? Thank you in advance!

let me show you my ~/.fonts.conf
well, simsun/simhei are cracked from M$
windows.

<?xml version="1.0"?>
<fontconfig>
<!--Fonts rendering sequence--> <alias>
  <family>serif</family>
  <prefer>
   <family>Bitstream Vera Serif</family>
   <family>DejaVu Serif</family>
   <family>SimSun</family>
   <family>SimHei</family>
   <family>AR PL ShanHeiSun Uni</family>
   <family>AR PL ZenKai Uni</family>
  </prefer>
 </alias>
 <alias>
  <family>sans-serif</family>
  <prefer>
   <family>Bitstream Vera Sans</family>
   <family>DejaVu Sans</family>
   <family>SimSun</family>
   <family>SimHei</family>
   <family>AR PL ShanHeiSun Uni</family>
   <family>AR PL ZenKai Uni</family>
  </prefer>
 </alias>
 <alias>
  <family>monospace</family>
  <prefer>
   <family>Bitstream Vera Sans
Mono</family>
   <family>DejaVu Sans Mono</family>
   <family>SimHei</family>
   <family>SimSun</family>
   <family>AR PL ShanHeiSun Uni</family>
   <family>AR PL ZenKai Uni</family>
  </prefer>
 </alias>
 <match target="font" >
  <edit mode="assign" name="rgba" >
   <const>none</const>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="hinting" >
   <bool>true</bool>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="hintstyle" >
   <const>hintmedium</const>
  </edit>
 </match>
 <match target="font" >
  <edit mode="assign" name="antialias" >
   <bool>true</bool>
  </edit>
 </match>
</fontconfig>

--
学而不会是为学。

Magi Su (magisu) wrote :

you have to modify .fonts.conf file to
implement the font substitution.
otherwise, every chinese character
would go to boxes..

MilchFlasche (robertus0617) wrote :

Hi Magi,

Could I ask if you have tried to use any English fonts in KDE Control Center to display? Such as Nimbus XXXX, Bitstream XXX, etc. If you use them, can they grab Simsun or Simhei as you have set for Chinese character fallback correctly? If Qt is doing this well on your machine, then I will try your suggestion thoroughly again.

I'm having problems here because I have set "Microsoft Jhenghei" (微軟正黑體) for fallback in the fontconfig files (I have tried /etc/fonts/language-selector.conf, /etc/fonts/local.conf, /etc/fonts/conf.d/xxxx, and I think ~/.font.conf already too), but now only serif, sans-serif and monospace these three fonts can grab Microsoft Jhenghei correctly; other English fonts in KDE are still grabbing some really ugly CJK font as fallback. So the problem is not that they display Chinese characters as boxes, but they just display Chinese characters awfully. But in GNOME, there's no problem with fontconfig. I guess this is the main issue in this bug report.

By the way, do we have to add XML dtd in the beginning of every conf file? Because I have seen many conf files with them, but many not. Would this affect how Qt handles fonts?

Cheers.

Magi Su (magisu) wrote :

On Friday 27 July 2007 15:29:05 MilchFlasche wrote:
> Hi Magi,
>
> Could I ask if you have tried to use any English fonts in KDE Control
> Center to display? Such as Nimbus XXXX, Bitstream XXX, etc. If you use
> them, can they grab Simsun or Simhei as you have set for Chinese
> character fallback correctly? If Qt is doing this well on your machine,
> then I will try your suggestion thoroughly again.
>
> I'm having problems here because I have set "Microsoft Jhenghei" (微軟正黑體)
> for fallback in the fontconfig files (I have tried /etc/fonts/language-
> selector.conf, /etc/fonts/local.conf, /etc/fonts/conf.d/xxxx, and I
> think ~/.font.conf already too), but now only serif, sans-serif and
> monospace these three fonts can grab Microsoft Jhenghei correctly; other
> English fonts in KDE are still grabbing some really ugly CJK font as
> fallback. So the problem is not that they display Chinese characters as
> boxes, but they just display Chinese characters awfully. But in GNOME,
> there's no problem with fontconfig. I guess this is the main issue in
> this bug report.
>
> By the way, do we have to add XML dtd in the beginning of every conf
> file? Because I have seen many conf files with them, but many not. Would
> this affect how Qt handles fonts?
>
> Cheers.

Dear MilchFlasche
My suggestions are: 1. do not touch /etc/fonts, only work on ~/.fonts.conf 2.
if you can read Simplified Chinese, go to forum.ubuntu.org.cn in the
section "中文支持" (chinese support) you might find some useful information. Just
go to the forum and find what you need, plenty of solutions there. AndI think
my system deal with the fonts like "bitstream" or "dejavu" in chinese well.
just put them into the XML file, at <alias> section, I suppose.

Indeed, the Qt library work well after the final version of Feisty come out,
at least in my computer. The only problem is in some JAVA programs like
stellarium, no chinese could be shown, I don't know why, but I seldom use
JAVA.

Well, I can answer the question of XML now but not a week ago, since I've
learnt that just three days before~^_^. DTD is useful, but not necessary for
XML files. DTD section only control the structure of XML file, to force the
XML data follow the structure defined in that section. If the XML file data
do not follow, parser will report an error and try to recover. However, it is
not necessary for XML files. Without that, a well-formed XML file will work.
But there will be NO check of structure. A simple example:

<?xml version="1.0"?>
<HEAD>
 <DATA>
  <TEXT>HELLO</TEXT>
  <TEXT>WORLD</TEXT>
 </DATA>
 <DATA>
  <VALUE>3.1415</VALUE>
 </DATA>
</HEAD>

this is a standard XML file, without DTD section. it will be parsed as it is
well-formed.

however, if DTD information is inserted at the 2nd line like this:

<!DOCTYPE HEAD
 [
 <!ELEMENT DATA (TEXT)*>
 <!ELEMENT TEXT (#PCDATA)>
 ]
>

will be parsed with error because the DTD section restricted the XML file so
DATA could only have element with TEXT.

XML is simple, just spend a few hours you can work on it, though not
mastering.

Good Luck!

--
学而不会是为学。

MilchFlasche (robertus0617) wrote :

Thank you Magi, for the information you provided. :)

This morning I finally get Qt working with font substitution, however still not conforming to the Fontconfig settings automatically as GNOME does. I found that there's no "qt3-qtconfig" package installed on my system, only "qt4-qtconfig"; and since Kubuntu is still using KDE 3 mainly, I guess all those applications, including kicker, can only be configured with qtconfig of respective version, so that's why I have customized in "qt4-qtconfig" but without success. I don't know if this is the result of my installing kde-desktop on Ubuntu, not installing Kubuntu itself directly, so that I lack qt3-qtconfig by default.

So now I can get Purisa, Nimbus, Chandas, or any other English fonts to mobilize fallback fonts such as Microsoft JhengHei now. But even with qtconfig, we still have to set fallback information to "each" font which we'd like to be substituted. I remember that with Fontconfig files, only setting preferences for Sans Serif, Serif, and Monospace would do all the work, and GNOME would apply settings of these three generic font family to all other specific fonts, so that any fonts in the list can mobilize Chinese fonts automatically. And I'm still not satisfied with the way KDE and Qt behaves...

As of the Ubuntu forum of China (zh-CN), I appreciate that it has a section just for Chinese language support, but searching with "kde OR kubuntu" didn't yield many results relating to the fontconfig issue in KDE. Anyway, thank you for showing me the way!

Magi Su (magisu) wrote :

On Saturday 28 July 2007 17:49:46 MilchFlasche wrote:
> Thank you Magi, for the information you provided. :)
>
> This morning I finally get Qt working with font substitution, however
> still not conforming to the Fontconfig settings automatically as GNOME
> does. I found that there's no "qt3-qtconfig" package installed on my
> system, only "qt4-qtconfig"; and since Kubuntu is still using KDE 3
> mainly, I guess all those applications, including kicker, can only be
> configured with qtconfig of respective version, so that's why I have
> customized in "qt4-qtconfig" but without success. I don't know if this
> is the result of my installing kde-desktop on Ubuntu, not installing
> Kubuntu itself directly, so that I lack qt3-qtconfig by default.
>
> So now I can get Purisa, Nimbus, Chandas, or any other English fonts to
> mobilize fallback fonts such as Microsoft JhengHei now. But even with
> qtconfig, we still have to set fallback information to "each" font which
> we'd like to be substituted. I remember that with Fontconfig files, only
> setting preferences for Sans Serif, Serif, and Monospace would do all
> the work, and GNOME would apply settings of these three generic font
> family to all other specific fonts, so that any fonts in the list can
> mobilize Chinese fonts automatically. And I'm still not satisfied with
> the way KDE and Qt behaves...
>
> As of the Ubuntu forum of China (zh-CN), I appreciate that it has a
> section just for Chinese language support, but searching with "kde OR
> kubuntu" didn't yield many results relating to the fontconfig issue in
> KDE. Anyway, thank you for showing me the way!

you should search "kde AND 中文", then you will get what you want. it is said
that qt3 is not using the X11 fontconfig, but its own system. so I am not
surprised that kde have good font system. after all, let's wait for KDE4 with
better Chinese support!

--
学而不会是为学。

Michael Ummels (urmel291) wrote :

I have written a Python script that sets up font substitution in QT3 to work as with fontconfig. The idea is to check for each font that exists on the system which fonts can be substituted for it using the fc-match command. A corresponding substitution entry is then written to the user's qtrc file. If you provide the --system option, the substitutions are written to the global qtrc file. Be warned however: The script will replace any existing font substitution in the qtrc file (e.g. ones written by qtconfig). To keep the old substitutions copy all entries in the [Font Substitution] section of the old qtrc file into the new one. A backup of the old qtrc file is saved under the name qtrc.old in the same directory where the qtrc file is located (i.e. $HOME/.qt or /etc/qt3 if you use the --system option).

magisu (magi-mail) wrote :

On Thursday 27 December 2007 22:12:59 Michael Ummels wrote:
> I have written a Python script that sets up font substitution in QT3 to
> work as with fontconfig. The idea is to check for each font that exists
> on the system which fonts can be substituted for it using the fc-match
> command. A corresponding substitution entry is then written to the
> user's qtrc file. If you provide the --system option, the substitutions
> are written to the global qtrc file. Be warned however: The script will
> replace any existing font substitution in the qtrc file (e.g. ones
> written by qtconfig). To keep the old substitutions copy all entries in
> the [Font Substitution] section of the old qtrc file into the new one. A
> backup of the old qtrc file is saved under the name qtrc.old in the same
> directory where the qtrc file is located (i.e. $HOME/.qt or /etc/qt3 if
> you use the --system option).

Well, I have given up the idea of substitution. I am using Qt3-QtConfig, font
substitution engine. After all, thanks a lot for your code!!!

Michael Ummels (urmel291) wrote :

Well, that's exactly what the script does. QtConfig does nothing else than write substitution entries into the user's qtrc file. The only difference is that the script does this automatically by asking fontconfig for the right substitutions.

MilchFlasche (robertus0617) wrote :

Wow! Thanks for that, Michael, I'd love to try this script so that my KDE font can have the same look with GNOME. After all, it's far easier not to set manually.

MilchFlasche (robertus0617) wrote :

Hi, Michael, I have tried your script. The weird thing is, after I executed it, it made substitution for *all* my fonts with my Sans alias in the font.conf file, and that brought abundant unnecessary substitutions. Is this because we set font.conf in different ways?

Michael Ummels (urmel291) wrote :

Hi! Well, on my system it does the same. That's because fontconfig works like that. After all, if a font does not have a certain character, it's not a bad idea to check whether the default sans or serif font does have this character and only after that try more special fonts like Chinese or Japanese ones. You can check in which order fontconfig tries to substitute a font with the fc-match command. For example, to see the sorted list of matches for Verdana, run 'fc-match -s Verdana'. What the script does is just to call this command for each font on the system and copy the respective list of substitutions into the qtrc file, because this should give you the same substitution behaviour with Qt and fontconfig. Of course, if you are only interested in Chinese text, it would suffice to setup just one substitution for each font. But then, it is not clear which font the system will use for a text in a different language.

Michael Ummels (urmel291) wrote :

Chinese font support in QT is again completely broken in Hardy (libqt3-mt version is 3:3.3.8-b-0ubuntu1). I have removed all Japanese fonts but installed the Chinese "WenQuanYi Zen Hei" fonts. However, all QT applications just display boxes instead of Chinese characters (see the attached screenshot of the Chinese wikipedia in Konqueror). Can we revert back to qt 3.3.7?

Changed in qt-x11-free:
status: In Progress → Confirmed
rookie1 (mr-rookie1) wrote :

I believe this is the same as Debian bug #468430 (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=468430). According to the latest update in that bug report, it has been fixed in Debian in 3.3.8b-5. Will Hardy pick up this upstream change?

Michael Ummels (urmel291) wrote :

After reading the Debian bug report, I am also convinced that this is indeed the same bug. So it would be great if Hardy could incorporate the fix from Debian.

D4nielfree (d4nielfree) wrote :

i think its the same bug, hope Hardy can fix it from Debian

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt-x11-free - 3:3.3.8-b-0ubuntu3

---------------
qt-x11-free (3:3.3.8-b-0ubuntu3) hardy; urgency=low

  * Add 61_eastern_asian_languagues.diff from Debian,
    closes LP: #94282
    "Qt program doesn't select Chinese font correctly"

 -- Jonathan Riddell <email address hidden> Wed, 09 Apr 2008 16:56:29 +0100

Changed in qt-x11-free:
status: Confirmed → Fix Released
Michael Ummels (urmel291) wrote :

Everything seems to work fine now! Thank you, Jonathan for incorporating the Debian patch.

Changed in qt-x11-free:
status: Unknown → Fix Released
MilchFlasche (robertus0617) wrote :

Hi, I'm glad that the patch has been released and also incorporated into Debian and Ubuntu. Meanwhile, the only package I found relating to qt-x11-free is "qt-x11-free-dbg" in the Hardy repository. Is this the package that I should install so to fix this font issue?

Michael Ummels (urmel291) wrote :

Hi! qt-x11-free is just the name of the source package. The corresponding binary package is libqt3-mt, which has to be installed anyway, if you want to use Qt applications.

MilchFlasche (robertus0617) wrote :

Or should I compile and install the source package qt-x11-free of Hardy manually?

MilchFlasche (robertus0617) wrote :

Hi,

I see I have installed the 3:3.3.8-b-0ubuntu3 version of libqt3-mt, but my Qt applications still display Chinese characters differetly with Gtk applications on my Hardy, i.e. Qt applications still don't recognize my fontconfig settings. Or should I delete all my qt3-config font settings first?

Ning Bao (ningbao) wrote :

Sorry, man,

I have abandoned Ubuntu for years for Archlinux.
Also, I am not running that many QT based apps anymore.
Nowadays, I am more leaning towards CLI apps. :)

I am not able to help you.

Billy

On Tue, Sep 16, 2008 at 1:20 PM, MilchFlasche <email address hidden>wrote:

> Hi,
>
> I see I have installed the 3:3.3.8-b-0ubuntu3 version of libqt3-mt, but
> my Qt applications still display Chinese characters differetly with Gtk
> applications on my Hardy, i.e. Qt applications still don't recognize my
> fontconfig settings. Or should I delete all my qt3-config font settings
> first?
>
> --
> QT program doesn't select Chinese font correctly
> https://bugs.launchpad.net/bugs/94282
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Hello Bug 94282,

Your contact "\\<email address hidden>\\" invited you to join our TestitandKeepit program.

At this time we are actively searching for people who will be willing to test the new Apple iPad. The testing period will take only two months, after which you may keep it as compensation.

To see more details and register to our program, follow the link below:

http://www.testitandkeepit.com/1

Thanks,

The TestitandKeepit Team

___

This message was intended for <email address hidden>.

TestitandKeepit.com, 98 Springgate rd, Toronto, ON, Canada

I just became an iPad apps tester, and thought you might like to try it out. Here's an invitation to become a tester too. They say you can keep the iPad when testing is finished. Grab it!

------------------------------------------------------------------

<email address hidden> has invited you to become an iPAD apps tester.

To accept this invitation and enter as a tester, click on
http://www.Apps-Test-Center.com

If you haven't already heard about test iPAD Apps, we are a firm that helps Apple iPAD applications developers make better Apps, by involving testers.

- We look for 5000 iPAD Apps testers
- It's free to become a tester
- Test iPad apps for 2 months
- Send weekly reports, suggestions
- Keep iPad when finished

If you want to learn more about this, go to:
http://www.Apps-Test-Center.com

Thank You

Apps Research Team

------------------------------------------------------------------

This is a one-time only invite. You will NEVER receive anymore mail from us!

One Silber Way, Vancouver, BC

Hi,

This is an HTML-enabled message. Please view it as HTML or go to this address to view it online: http://24iappz.info/efm64wjjdyuq

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.