FFe: Add python 3 version packages

Bug #608962 reported by Oreolek on 2010-07-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
qscintilla2 (Ubuntu)
Wishlist
Scott Kitterman

Bug Description

This package is a python2 version only. There is no python3.1 version - however, there is a python3.1 package.

Felix Geyer (debfx) on 2011-02-14
Changed in qscintilla2 (Ubuntu):
importance: Undecided → Wishlist

I've just uploaded a new Qscintialla2 revision to Debian experimental that is sitting in Debian New at the moment. It adds the python3 package. I'd like an FFe for adding the new binary. Debdiff attached. I'll either upload this directly or sync (identical except for changelog and maintainer) depending on when this is approved and how fast it gets out of Debian New.

summary: - there is no python 3 version
+ FFe: Add no python 3 version packages
Changed in qscintilla2 (Ubuntu):
assignee: nobody → Scott Kitterman (kitterman)
milestone: none → ubuntu-12.04-beta-2
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qscintilla2 (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

This looks fine, approved.

summary: - FFe: Add no python 3 version packages
+ FFe: Add python 3 version packages
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qscintilla2 - 2.6.1-3ubuntu1

---------------
qscintilla2 (2.6.1-3ubuntu1) precise; urgency=low

  [ Thomas Kluyver ]
  * Package for Python 3 (LP: #608962)

  [ Scott Kitterman ]
  * Use Python policy compliant binary name for Python 3 (python3-pyqt4.qsci)
  * Remove pointless Build-depends and Depends versioning
  * Fix debian/rules to build for all python3 variants, not just the default
  * Use dh_sip3 for python3-pyqt4.qsci, not dh_sip
  * Drop incorrect Multi-Arch: same for libqscintilla2-8
 -- Scott Kitterman <email address hidden> Tue, 13 Mar 2012 22:19:28 -0400

Changed in qscintilla2 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches