python-qscintilla2: sip api version incompatibility

Bug #392820 reported by Ville M. Vainio on 2009-06-27
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
qscintilla2 (Ubuntu)
Undecided
Unassigned

Bug Description

Trying to import QScintilla does not work:

ville@ville-desktop:~$ python
Python 2.6.2+ (release26-maint, Jun 19 2009, 15:14:35)
[GCC 4.4.0] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import PyQt4.Qsci
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
RuntimeError: the sip module implements API v5.0 but the ���6� module requires API v3.8

ville@ville-desktop:~$ lsb_release -rd
Description: Ubuntu karmic (development branch)
Release: 9.10

ville@ville-desktop:~$ apt-cache policy python-qscintilla2
python-qscintilla2:
  Installed: 2.3.2-1.1ubuntu1

ville@ville-desktop:~$ apt-cache policy python-sip4
python-sip4:
  Installed: 4.8.1-0ubuntu1

ville@ville-desktop:~$ apt-cache policy python-qt4
python-qt4:
  Installed: 4.5.1-1ubuntu1

description: updated
Philip Muškovac (yofel) on 2009-06-29
affects: ubuntu → qscintilla2 (Ubuntu)
Changed in qscintilla2 (Ubuntu):
status: New → Confirmed

This problem is fixed in Karmic or in Lucid for you?
Thanks

Changed in qscintilla2 (Ubuntu):
status: Confirmed → Incomplete
Philip Muškovac (yofel) wrote :

Works fine in maverick with 2.4.4-0ubuntu1.

Changed in qscintilla2 (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers