Please update qscintilla2 package to fix crashing

Bug #304622 reported by Vadim Peretokin on 2008-12-03
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mudlet
Fix Released
Critical
Unassigned
qscintilla2 (Ubuntu)
High
Unassigned
Nominated for Hardy by Vadim Peretokin
Nominated for Intrepid by Vadim Peretokin
Jaunty
High
Unassigned

Bug Description

The qscintilla2 package that is in Ubuntu 8.04, 8.10, and 9.04 (at dec 2) has a serious issue in it - it'll crash when given a blank line, if any lexers (syntax highlighting) are loaded. So just pressing enter a couple of times will crash the application that embeds the editor widget.

This crash is also reproducible on Fedora 9, but not 10. Also, if you install updated qscintilla verison 2.3.2 from source (http://www.riverbankcomputing.co.uk/static/Downloads/QScintilla2/QScintilla-gpl-2.3.2.tar.gz), the application will not crash. This leads me to believe there is a problem with the 2.2 version.

Here is a gdb log:

Fatal: Assertion [(position >= 0) && (position <= lengthBody)] failed at ../src/SplitVector.h 155

Program received signal SIGABRT, Aborted.
[Switching to Thread 0x7fd3e8f196f0 (LWP 8595)]
0x00007fd3e5babfd5 in raise () from /lib/libc.so.6
(gdb) bt
#0 0x00007fd3e5babfd5 in raise () from /lib/libc.so.6
#1 0x00007fd3e5badb43 in abort () from /lib/libc.so.6
#2 0x0000000000427380 in debugOutput ()
#3 0x00007fd3e6915653 in qt_message_output () from /usr/lib/libQtCore.so.4
#4 0x00007fd3e69157fd in qFatal () from /usr/lib/libQtCore.so.4
#5 0x00007fd3e8a34128 in CellBuffer::InsertLine ()
   from /usr/lib/libqscintilla2.so.3
#6 0x00007fd3e8a34442 in CellBuffer::BasicInsertString ()
   from /usr/lib/libqscintilla2.so.3
#7 0x00007fd3e8a34750 in CellBuffer::InsertString ()
   from /usr/lib/libqscintilla2.so.3
#8 0x00007fd3e8a3b3c4 in Document::InsertString ()
   from /usr/lib/libqscintilla2.so.3
#9 0x00007fd3e8a4de99 in Editor::NewLine () from /usr/lib/libqscintilla2.so.3
#10 0x00007fd3e8a4ea6d in Editor::KeyCommand ()
   from /usr/lib/libqscintilla2.so.3
#11 0x00007fd3e8a4ff02 in Editor::WndProc () from /usr/lib/libqscintilla2.so.3
#12 0x00007fd3e8ae46fe in ScintillaBase::WndProc ()
   from /usr/lib/libqscintilla2.so.3
#13 0x00007fd3e8a4a30a in Editor::KeyDown () from /usr/lib/libqscintilla2.so.3
#14 0x00007fd3e8a0d0e6 in QsciScintillaBase::keyPressEvent ()
   from /usr/lib/libqscintilla2.so.3
#15 0x00007fd3e7213218 in QWidget::event () from /usr/lib/libQtGui.so.4

Potential people affected: The only package in Ubuntu that currently embeds qscintilla2 is "universalindentgui". However that package is installed by only 34 out of 827,179 people on popcon - so not a high number.

This also affects the Mudlet project however, and is rather a major showstopper.

Related branches

Vadim Peretokin (vperetokin) wrote :

Getdeb.net has provided the updated version, here are the sources.

Vadim Peretokin (vperetokin) wrote :
Vadim Peretokin (vperetokin) wrote :
Heiko (koehnheiko) on 2009-02-02
Changed in mudlet:
importance: Undecided → Critical
status: New → Fix Released
Matthias Klose (doko) wrote :

the current version in jaunty fails to build:

make[1]: Entering directory `/scratch/packages/tmp/py/qscintilla2-2.2/Python/build-2.5'
g++ -c -pipe -fPIC -g -O2 -Os -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_CORE_LIB -DQT_GUI_LIB -I. -I/scratch/packages/tmp/py/qscintilla2-2.2/Qt4 -I/usr/include/python2.5 -I/usr/share/qt4/mkspecs/default -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4 -I/usr/X11R6/include -o sipQscipart0.o sipQscipart0.cpp
sipQscipart0.cpp: In function 'PyObject* meth_QsciCommandSet_commands(PyObject*, PyObject*)':
sipQscipart0.cpp:38641: error: 'QsciCommandList' was not declared in this scope
sipQscipart0.cpp:38641: error: 'sipRes' was not declared in this scope
make[1]: *** [sipQscipart0.o] Error 1
make[1]: Leaving directory `/scratch/packages/tmp/py/qscintilla2-2.2/Python/build-2.5'
make: *** [Python/build-2.5/build-stamp] Error 2

attaching the proposed update for jaunty, including the new major version.

Changed in qscintilla2:
importance: Undecided → High
milestone: none → jaunty-alpha-6
status: New → Triaged
Matthias Klose (doko) wrote :
Matthias Klose (doko) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qscintilla2 - 2.3.2-0ubuntu1

---------------
qscintilla2 (2.3.2-0ubuntu1) jaunty; urgency=low

  * Build for python2.6. Closes LP: #304622

qscintilla2 (2.3.2-1~getdeb1) intrepid; urgency=low

  * New upstream version.

 -- Matthias Klose <email address hidden> Mon, 23 Feb 2009 16:58:54 +0000

Changed in qscintilla2:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers