SIP files for Qscintilla2 python bindings are not installed

Bug #1346197 reported by Martin Dobias on 2014-07-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qscintilla2 (Ubuntu)
Wishlist
Scott Kitterman

Bug Description

If you extend QScintilla classes and then want to provide Python bindings based on SIP, it is necessary to have also access to .sip files used for python bindings of QScintilla library. For example, for PyQt4 (python-qt4) there is package python-qt4-dev which contains .sip files to allow that. Unfortunately for python-qscintilla2 there does not seem to be any such development package.

It helps to manually copy SIP files from source package's Python/sip/ directory to /usr/share/sip/PyQt4/Qsci - but that is obviously not a real solution...

(these files are now required by master branch of QGIS project)

Scott Kitterman (kitterman) wrote :

Fix is in New in Debian. 2.8.3+dfsg-3.

Changed in qscintilla2 (Ubuntu):
assignee: nobody → Scott Kitterman (kitterman)
importance: Undecided → Wishlist
milestone: none → ubuntu-14.10
status: New → Fix Committed
Scott Kitterman (kitterman) wrote :

2.8.3+dfsg-3 is in Utopic now.

Changed in qscintilla2 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers