qgit dependency problem

Bug #145453 reported by Daniel Hackney on 2007-09-27
12
Affects Status Importance Assigned to Milestone
qgit (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: qgit

I am using the backported version of git-core on Ubuntu Feisty (1:1.5.2.5-2~feisty1) and am trying to install qgit. When I try to install, I get the following:

  $ sudo apt-get install qgit
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  qgit: Depends: git-core (>= 1.3.0) but it is not going to be installed
E: Broken packages

I am not all that familiar with the version naming system, but it looks like the problem could be that qgit expects a version like "1.5.0" while the latest backported version of git is "1:1.5.2.5", so the "1:" at the beginning could be throwing it off.

Daniel T Chen (crimsun) on 2008-10-25
Changed in qgit:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers