Please merge qgis 1.4.0+12730-4 from Debian unstable

Bug #707791 reported by Micah Gersten
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qgis (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

Binary package hint: qgis

qgis (1.4.0+12730-4) unstable; urgency=high

  * set "CFLAGS += -fno-strict-aliasing" for powerpc to avoid crash
    Thanks to Gabriele Giacone <email address hidden> (Closes: #603986)

 -- Francesco Paolo Lovergine <email address hidden> Tue, 11 Jan 2011 11:08:54 +0100

Tags: ftbfs

Related branches

Revision history for this message
Micah Gersten (micahg) wrote :

Setting to medium as it fixes an RC bug

Changed in qgis (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → Medium
status: New → In Progress
Revision history for this message
Micah Gersten (micahg) wrote :
Revision history for this message
Micah Gersten (micahg) wrote :

FTBFS, pbuilder log attached, you can use grab-merge to get the merge

Changed in qgis (Ubuntu):
assignee: Micah Gersten (micahg) → nobody
status: In Progress → Incomplete
Micah Gersten (micahg)
tags: added: ftbfs
Revision history for this message
Johan Van de Wauw (johanvdw) wrote :

I think the severity of this bug can be downgraded: powerpc is not a supported architecture on ubuntu, and the changes are only necessary for that architecture.

Revision history for this message
Micah Gersten (micahg) wrote :

powerpc is a community supported architecture in Ubuntu. This is a community supported package. The same build failure occured with Lucas' latest rebuild: http://udd.debian.org/cgi-bin/ubuntu_ftbfs.cgi. If you fix the FTBFS in either case, I'm happy to finish with the merge.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qgis - 1.4.0+12730-5ubuntu1

---------------
qgis (1.4.0+12730-5ubuntu1) natty; urgency=low

  * Merge from Debian unstable (LP: #707791), remaining changes:
    - Fix compilation issues with QT 4.7
    - Add build-depends on libqtwebkit-dev
    - Fix build failure with GCC 4.5
  * Fix build failure with python-qt4 4.8
  * Build-depend on python-sip-dev instead of *sip4* transitional packages.

qgis (1.4.0+12730-5) unstable; urgency=high

  * Missing ${python:Depends} added to python-qgis dependencies
    (closes: #611492)

qgis (1.4.0+12730-4) unstable; urgency=high

  * set "CFLAGS += -fno-strict-aliasing" for powerpc to avoid crash
    Thanks to Gabriele Giacone <email address hidden> (Closes: #603986)
 -- Felix Geyer <email address hidden> Fri, 18 Feb 2011 20:06:52 +0100

Changed in qgis (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers