QGIS fails after upgrade to 16.10 from 16.04

Bug #1659029 reported by Christopher Barrington-Leigh on 2017-01-24
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
qgis (Ubuntu)
Undecided
Unassigned

Bug Description

Trying to run qgis results in the following (QGIS closes immediately / fails to run).
I just upgraded from 16.04 to 16.10

$ qgis
Warning: loading of qgis translation failed [/usr/share/qgis/i18n//qgis_en_CA]
Warning: loading of qt translation failed [/usr/share/qt4/translations/qt_en_CA]
Warning: QCss::Parser - Failed to load file "/style.qss"
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
Warning: QFileSystemWatcher: failed to add paths: /home/cpbl/.qgis2//project_templates
Warning: QMetaObject::connectSlotsByName: No matching signal for on_wvDetails_linkClicked(QUrl)
Warning: QVariantMap DBusMenuExporterDBus::getProperties(int, const QStringList&) const: Condition failed: action
Warning: QVariantMap DBusMenuExporterDBus::getProperties(int, const QStringList&) const: Condition failed: action
Warning: void DBusMenuExporterPrivate::addAction(QAction*, int): Already tracking action "&Toolbox" under id 296
QH6248 qh_lib_check: Incorrect qhull library called. Caller uses reentrant Qhull while library is non-reentrant
QH6249 qh_lib_check: Incorrect qhull library called. Size of qhT for caller is 8184, but for library is 2896.
QH6255 qh_lib_check: Cannot continue. Library 'qhull 7.2.0 (2015.2 2016/01/18)' uses a dynamic qhT via qh_QHpointer (e.g., qhull_p.so)

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: qgis 2.14.5+dfsg-2
ProcVersionSignature: Ubuntu 4.8.0-34.36-generic 4.8.11
Uname: Linux 4.8.0-34-generic x86_64
ApportVersion: 2.20.3-0ubuntu8.2
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Jan 24 10:13:12 2017
EcryptfsInUse: Yes
InstallationDate: Installed on 2016-02-12 (346 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
SourcePackage: qgis
UpgradeStatus: Upgraded to yakkety on 2017-01-21 (2 days ago)

Bas Couwenberg (sebastic) wrote :

I'm sorry to hear QGIS doesn't work on yakkety, unfortunately the qgis package is in universe which is entirely unsupported.

You can give the upstream QGIS packages a try which have more recent LTR versions available:

 http://qgis.org/en/site/forusers/alldownloads.html#debian-ubuntu

Changed in qgis (Ubuntu):
status: New → Invalid

Thanks, but I don't know how. They don't seem to have a yakkety version. Trying to use the xenial version of the ltr or bleeding repository on yakkety leads to failure to install qgis.

Ah, in fact, a workaround for the original problem for me turns out to be do delete or rename my ~/.qgis2 folder.

Johan Van de Wauw (johanvdw) wrote :

I tested the universe package on a fresh yaketi install and it works fine for me. I think it is indeed a problem with your config.

Thanks. Yes, my config was fine before the upgrade. The bug is in the upgrading when users already have a configuration.

Petras (klavishas) wrote :

just to share some light...

the same error happens in debian recently after upgrading the qgis-2.99 to more recent dev version, so probably it propagates from debian...

Changed in qgis (Ubuntu):
status: Invalid → Confirmed
Bas Couwenberg (sebastic) wrote :

"the same error happens in debian recently after upgrading the qgis-2.99 to more recent dev version, so probably it propagates from debian..."

QGIS 2.99 is not in Debian, nor Ubuntu. This is not the venue for issues with the upstream packages.

Changed in qgis (Ubuntu):
status: Confirmed → Invalid
Mairin Deith (mdeith) wrote :

I also had this problem after upgrading my scipy to version 0.19.1, which was interfering with loading QGIS. The issue was solved after downgrading scipy to version 0.11:

pip install scipy==0.11

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers