qgis has to be built against python-sip 4.14

Bug #1103458 reported by Till Sachau on 2013-01-23
74
This bug affects 15 people
Affects Status Importance Assigned to Milestone
qgis (Ubuntu)
Undecided
Unassigned

Bug Description

Hi!

On Raring Ringtail, Ubuntu 13.04.
Package version: qgis 1.7.4+1.7.5~20120320-1.1

Starting qgis results in the error message that PyQGIS could not be loaded.

Reason is an update of the sip module to version 4.14, which seems to implement a new API.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qgis (Ubuntu):
status: New → Confirmed

I think the original poster understands more than me, but when I start QGIS under 13.04, I get a nasty error; in full, below. Also, apt reports that my python-qgis is fully up to date.

Couldn't load PyQGIS.
Python support will be disabled.

Traceback (most recent call last):
  File "", line 1, in
RuntimeError: the sip module implements API v9.0 to v9.2 but the qgis.core module requires API v8.1

Python version:
2.7.4rc1 (default, Mar 25 2013, 00:33:21)
[GCC 4.7.2]

QGIS version:
1.7.5-Wroclaw 'Wroclaw', exported

Python path:
['/usr/share/qgis/python',, '/usr/share/qgis/python/plugins', [etc; other paths hidden] '/usr/lib/python2.7', '/usr/lib/python2.7/plat-x86_64-linux-gnu', '/usr/lib/python2.7/lib-tk', '/usr/lib/python2.7/lib-old', '/usr/lib/python2.7/lib-dynload', '/usr/local/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages/PILcompat', '/usr/lib/python2.7/dist-packages/gtk-2.0', '/usr/lib/pymodules/python2.7', '/usr/lib/python2.7/dist-packages/ubuntu-sso-client', '/usr/lib/python2.7/dist-packages/ubuntuone-client', '/usr/lib/python2.7/dist-packages/ubuntuone-control-panel', '/usr/lib/python2.7/dist-packages/ubuntuone-storage-protocol']

Sean Baskin (seanbaskin) wrote :

I just upgraded to Ubuntu 13.04 and have the same error.

sudo apt-get install qgis

Upon starting QGIS I receive the same error message:

Couldn't load PyQGIS.
Python support will be disabled.

Traceback (most recent call last):
  File "", line 1, in
RuntimeError: the sip module implements API v9.0 to v9.2 but the qgis.core module requires API v8.1

Python version:
2.7.4 (default, Apr 19 2013, 18:30:41)
[GCC 4.7.3]

QGIS version:
1.7.5-Wroclaw 'Wroclaw', exported

Python path:
['/usr/share/qgis/python', '/home/sean/.qgis/python', '/home/sean/.qgis/python/plugins', '/usr/share/qgis/python/plugins', '/usr/lib/python2.7', '/usr/lib/python2.7/plat-x86_64-linux-gnu', '/usr/lib/python2.7/lib-tk', '/usr/lib/python2.7/lib-old', '/usr/lib/python2.7/lib-dynload', '/usr/local/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages/PILcompat', '/usr/lib/python2.7/dist-packages/gtk-2.0', '/usr/lib/python2.7/dist-packages/ubuntu-sso-client', '/usr/lib/python2.7/dist-packages/ubuntuone-client', '/usr/lib/python2.7/dist-packages/ubuntuone-control-panel', '/usr/lib/python2.7/dist-packages/ubuntuone-storage-protocol']

afdal fs (afdalfs) wrote :

yeah, i have problem with my python qgis,

afdal@afdal-00000000000000000000000000000000:~$ sudo apt-get install python-qgisReading package lists... Done
Building dependency tree
Reading state information... Done
E: The package python-qgis needs to be reinstalled, but I can't find an archive for it.

Bas Couwenberg (sebastic) wrote :

Since QGIS 2.2.0 dh_sip is used to generate the python-sip dependency, causing it be tracked in sip transitions and being rebuilt as part of those transitions.

Changed in qgis (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers