Ubuntu

Qemu hangs at "...trying to set up timer as Virtual Wire IRQ"

Reported by John McCabe-Dansted on 2009-05-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qemu (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: qemu

I try to start the UNR 9.04 in qemu, however it hangs at:
   "...trying to set up timer as Virtual Wire IRQ"

The command I use is:
   qemu ubuntu-9.04-netbook-remix-i386.img

Using other commands like
   qemu-system-x86_64 ...
   qemu-system-i386 ...
etc. do not seem to help.

I also get the warning
   Could not open '/dev/kqemu' - QEMU acceleration layer not activated: No such file or directory
In the terminal I start qemu on. My CPU does not have special VM support.

This bug appears to be related to Bug #320320, which reports the same problem in KVM. The problem in KVM has been fixed, but I still get this problem in qemu (0.10.0-1ubuntu1).

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: fglrx
Package: qemu 0.10.0-1ubuntu1
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_AU.UTF-8
SourcePackage: qemu
Uname: Linux 2.6.28-11-generic x86_64

John McCabe-Dansted (gmatht) wrote :
Jiang Bian (bianjiang) wrote :

I had the same problem. Ubuntu 9.04

uname -a
Linux wifihack 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux

qemu
QEMU PC emulator version 0.10.0,

qemu -s -hda /dev/zero -kernel /mnt/build/linux-2.6.30/arch/x86/boot/bzImage

Hayden Callow (hayden-callow) wrote :

Hmm,

I get the same using Fedora Applicance OS under ubuntu 9.04

dpkg-query --list qemu
ii qemu 0.10.0-1ubuntu fast processor emulator

qemu -m 1024 Fedora-11-i686-AOS-sda.raw

booting with (virtual host) kernel options set to noapic works for me YMMV.

goldcove (goldcove) wrote :

This bug seems to be isolated to 0.10.0-1ubuntu. I downgraded to 0.9.1-5ubuntu3 (http://packages.ubuntu.com/intrepid/qemu) and it was OK.

Dustin Kirkland  (kirkland) wrote :

Fix released in Karmic's qemu-kvm-0.11.

Please reopen if you can reproduce with that package.

:-Dustin

Changed in qemu (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers