package qemu-system-common 1:4.2-1ubuntu1 failed to install/upgrade: trying to overwrite '/usr/bin/ivshmem-client', which is also in package qemu-utils 1:4.0+dfsg-0ubuntu10

Bug #1862287 reported by Alex Murray on 2020-02-07
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
qemu (Ubuntu)
Critical
Unassigned

Bug Description

During a recent dist-upgrade apt error'd out with the specified error - doing an 'apt install -f' afterwards appeared to work fine and finish the dist-upgrade without further errors.

ProblemType: Package
DistroRelease: Ubuntu 20.04
Package: qemu-system-common 1:4.2-1ubuntu1
ProcVersionSignature: Ubuntu 5.4.0-12.15-generic 5.4.8
Uname: Linux 5.4.0-12-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu16
Architecture: amd64
Date: Fri Feb 7 13:17:03 2020
ErrorMessage: trying to overwrite '/usr/bin/ivshmem-client', which is also in package qemu-utils 1:4.0+dfsg-0ubuntu10
InstallationDate: Installed on 2019-11-18 (80 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
KvmCmdLine: COMMAND STAT EUID RUID PID PPID %CPU COMMAND
MachineType: LENOVO 20KHCTO1WW
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.4.0-12-generic root=/dev/mapper/vgubuntu-root ro quiet splash psmouse.synaptics_intertouch=1 vt.handoff=7
Python3Details: /usr/bin/python3.7, Python 3.7.6, python3-minimal, 3.7.5-1ubuntu1
PythonDetails: N/A
SourcePackage: qemu
Title: package qemu-system-common 1:4.2-1ubuntu1 failed to install/upgrade: trying to overwrite '/usr/bin/ivshmem-client', which is also in package qemu-utils 1:4.0+dfsg-0ubuntu10
UpgradeStatus: Upgraded to focal on 2020-01-22 (15 days ago)
dmi.bios.date: 11/25/2019
dmi.bios.vendor: LENOVO
dmi.bios.version: N23ET69W (1.44 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20KHCTO1WW
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40697 WIN
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: dmi:bvnLENOVO:bvrN23ET69W(1.44):bd11/25/2019:svnLENOVO:pn20KHCTO1WW:pvrThinkPadX1Carbon6th:rvnLENOVO:rn20KHCTO1WW:rvrSDK0J40697WIN:cvnLENOVO:ct10:cvrNone:
dmi.product.family: ThinkPad X1 Carbon 6th
dmi.product.name: 20KHCTO1WW
dmi.product.sku: LENOVO_MT_20KH_BU_Think_FM_ThinkPad X1 Carbon 6th
dmi.product.version: ThinkPad X1 Carbon 6th
dmi.sys.vendor: LENOVO

Related branches

Alex Murray (alexmurray) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qemu (Ubuntu):
status: New → Confirmed

Hi ALex,
IIRC this was moved in Debian and it could be the breaks/conflicts they added don't apply correctly for all our upgrade paths. I'll take a look - thanks you the the report!

Changed in qemu (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Critical

Old:
root@e:~# dpkg -S ivshmem-client ivshmem-server
qemu-utils: /usr/bin/ivshmem-client
qemu-utils: /usr/bin/ivshmem-server

New
root@f:~# dpkg -S ivshmem-client ivshmem-server
qemu-system-common: /usr/bin/ivshmem-client
qemu-system-common: /usr/bin/ivshmem-server

Changed in 1:3.1+dfsg-3
Oh yeah things make sense, we were ahead at the time for some releases/versions.
The re-merge brought this in and since we effectively gained it "later" it might fail the ordering.

Upgrades from Bionic would not be affected (from 2.11) and also upgrades in Focal could by chance not trigger it. Lets add proper ordering in d/control ...

/me is sad to not have hit this in any of my many pre-checks :-/
I beg your pardon @ anyone affected

Original change in Debian:
https://salsa.debian.org/qemu-team/qemu/commit/ce43f003b6dde9404a1f519a66830916cba193c4

Bumping those versions to when we introduced the change ...

I was trying to reproduce this with upgrades from Eoan and from a bunch of older Focal containers I had around - all with qemu-system-common and qemu-utils installed before upgrade.

None of them hit the same bug. So either it is not as common to be hit as I was afraid - or I'm cursed by not seeing it but the rest of the world will. That makes testing hard, but the fix is rather straight forward and non invasive so this time once I can go as-is to resolve it for those affected asap.

For completeness I checked for similar changes since Bionic:
7e77abb9 debian/qemu_2.12+dfsg-2~5 <- ok from Bionic, ok from Eoan/Focal
ce43f003 debian/qemu-3.1+dfsg-3~3 <- This issue
2b5df4f8 debian/qemu_4.1-2~8 <- ok from Bionic, ok from Eoan/Focal

Ok, the reported issue seems to be the only one that really has a bad effect.

FYI - Fix uploaded to Focal

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qemu - 1:4.2-1ubuntu2

---------------
qemu (1:4.2-1ubuntu2) focal; urgency=medium

  * d/control: avoid upgrade issues triggered by moving ivshmem tools after
    Debian. Fixed by by bumping the related Breaks/Replaces to the
    Version Ubuntu introduced the change (LP: #1862287)

 -- Christian Ehrhardt <email address hidden> Fri, 07 Feb 2020 07:31:21 +0100

Changed in qemu (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers