SDL support missing from qemu-1:3.1+dfsg-2ubuntu3.1

Bug #1829945 reported by Lee Trager on 2019-05-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qemu (Ubuntu)
Undecided
Unassigned

Bug Description

SDL support is missing from qemu-1:3.1+dfsg-2ubuntu3.1 on Disco. This is despite qemu --help saying its available. SDL support is needed to use Packer(https://www.packer.io/) in graphical mode.

# qemu-system-x86_64 -cpu host -smp 2,sockets=2,cores=1,threads=1 -machine type=pc,accel=kvm -display sdl -cdrom ubuntu.iso
qemu-system-x86_64: Display 'sdl' is not available.

# qemu-system-x86_64 --help | grep sdl
-display sdl[,frame=on|off][,alt_grab=on|off][,ctrl_grab=on|off]
-sdl shorthand for -display sdl

Lee Trager (ltrager) on 2019-05-22
description: updated
Thomas Huth (th-huth) on 2019-05-22
affects: qemu → qemu (Ubuntu)

Hi Lee,
TL;DR: there will be no sdl support anymore for newer qemu's. (make it) Use "-display gtk" instead.

Details:
#1 SDL 1.2 vs SDL 2.0 vs working fine
1.2 was in main all the time and worked, but got unsupportable over time.
SDL2 was tried, but failed badly in quite some experiments for Debain and
Ubuntu. That led to the choice of both distributions to go with the more
modern GTK backend instead.
Ubuntu (at Bionic staying at SDL1.2):
- sdl2 is yet too unstable for the LTS Ubuntu release given the reports
  we still see upstream and in Debian - furthermore sdl2 isn't in main yet,
  so we revert related changes to stick with the proven for now:
Debian then followed for #839695, #886671, #879536, #879534, #879532, #879193, #894852
That also matches upstream where GTK backend for graphics is the #1 thing.

#2 Supportability
The reason everyone wanted to get off SDL was maintainability as I mentioned. And as of today you'll find that none of the SDL libs is in main anymore (since Cosmic).
*sdl* is universe nowadays.
And we can't make a good case for it (to MIR it) as GTK solves it - at least from the qemu POV.

#3 About the man page, this isn't patched for features enabled/disabled by the upstream build system. For example it also contains "pvrdma" which is disabled for security reasons (and many other things).

I must conclude that as-is I won't enable sdl, but then why does it insist on `-display sdl` in the first place. `-display gtk` is just as good or better. Is that our package of packer.io that we'd want to adapt or a PR for upstream maybe?

Also misfiled against upstream's Qemu - this clearly was meant for Ubuntu's Qemu as technically upstream is still fine enabling sdl (if the package builder wants to).

Changing the bug tasks ...

Ha, Thomas beat me to re-target the bug while I was checking my inbox - thanks :-)

Changed in qemu (Ubuntu):
status: New → Won't Fix
Lee Trager (ltrager) wrote :

Thanks for the explanation. MAAS is starting to use Packer to create custom images so we may be packaging this soon. I will filed an upstream bug[1] and created a patch[2] to fix the issue.

[1] https://github.com/hashicorp/packer/issues/7675
[2] https://github.com/hashicorp/packer/pull/7676

Thanks, I subscribed there and already participate in the discussion

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.