[Ubuntu-18.04][LTC-Test] Warning: "qemu-system-ppc64: System page size 0x40000000 is not enabled in page_size_mask (0x11000). Performance may be slow" Noticed while booting guest backed by Hugepages.

Bug #1806104 reported by bugproxy on 2018-11-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Ubuntu-power-systems project
Medium
Canonical Server Team
qemu (Ubuntu)
Medium
Ubuntu on IBM Power Systems Bug Triage
Bionic
Low
Christian Ehrhardt 
Cosmic
Low
Unassigned

Bug Description

[Impact]

 * There is a message which was identified more confusing and misleading
   than helpful that should be dropped to avoid users being unsure about
   it.

 * Fix: Backport the upstream change dropping the message

[Test Case]

 * Run huge page backed guest on a power9 system
    <memory unit='KiB'>1048576</memory>
    <currentMemory unit='KiB'>1048576</currentMemory>
    <memoryBacking>
     <hugepages>
      <page size='1048576' unit='KiB'/>
     </hugepages>
    </memoryBacking>
   Make sure to have huge pages available e.g. via boot arg:
     default_hugepagesz=1G hugepagesz=1G hugepages=8
   Then start the guest and check guest log in
   /var/log/libvirt/qemu/<guestname.log>

   Without fix:
   2019-02-01T11:39:18.295357Z qemu-system-ppc64: System page size
   0x40000000 is not enabled in page_size_mask (0x11000). Performance may
   be slow

   With the fix this message should not appear.

[Regression Potential]

 * This drops a warning (that was almost never useful and often
   confusing). But it had no functional change to the behavior,
   therefore no regression should be seen at all (unless somebody
   missing the old message counts).

[Other Info]

 * n/a

----

Problem :
The following warning message is noticed when booting guest backed by hugepages.

"2018-03-28T07:45:18.500173Z qemu-system-ppc64: System page size 0x40000000 is not enabled in page_size_mask (0x11000). Performance may be slow"

Guest bootsup, however the warning message is see in qemu.log.

Test Environment :

Boston-LC

Linux : 4.15.0-12-generic

NAME="Ubuntu"
VERSION="18.04 LTS (Bionic Beaver)"
ID=ubuntu

Guest is backed by hugepages. Guest xml

  <memoryBacking>
    <hugepages>
      <page size='1048576' unit='KiB'/>
    </hugepages>
  </memoryBacking>

Host Hugepages.
cat /sys/kernel/mm/hugepages/hugepages-1048576kB/nr_hugepages
4

One the guest is started, we see the warning message in the qemu.log

cat /var/log/libvirt/qemu/Hari_compact_mode.log
----
----
----
2018-03-28T07:45:18.370804Z qemu-system-ppc64: -chardev pty,id=charserial0: char device redirected to /dev/pts/2 (label charserial0)
2018-03-28T07:45:18.500173Z qemu-system-ppc64: System page size 0x40000000 is not enabled in page_size_mask (0x11000). Performance may be slow

Leonardo/Breno,

Is it possible we can request canonical to backport the below commit into Ubuntu 18.04 level ?

https://github.com/qemu/qemu/commit/30f79dc13f116a79ff45d37ad0f5c035012064a7

Related branches

bugproxy (bugproxy) wrote : guest.xml

Default Comment by Bridge

tags: added: architecture-ppc64le bugnameltc-166118 severity-medium targetmilestone-inin18043
bugproxy (bugproxy) wrote : qemu log

Default Comment by Bridge

Changed in ubuntu:
assignee: nobody → Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage)
affects: ubuntu → qemu (Ubuntu)
Changed in ubuntu-power-systems:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Canonical Server Team (canonical-server)

Hi,
dfor 19.04 it should be fixed once we merged qemu 3.1 which is the current plan, but for SRUs I'm not so sure.
The backport isn't hard at all, but removing a warning is certainly not worth an SRU cycle and dropping an update of qemu to everybody out there.

How about keeping it open for now and bundling it with whatever the next SRU will be?
Would that be ok for you?

tags: added: qemu-19.04
Changed in qemu (Ubuntu Bionic):
status: New → Triaged
Changed in qemu (Ubuntu Cosmic):
status: New → Triaged
Changed in qemu (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in qemu (Ubuntu Bionic):
importance: Undecided → Low
Changed in qemu (Ubuntu Cosmic):
importance: Undecided → Low
description: updated
description: updated
Launchpad Janitor (janitor) wrote :
Download full text (11.4 KiB)

This bug was fixed in the package qemu - 1:3.1+dfsg-2ubuntu1

---------------
qemu (1:3.1+dfsg-2ubuntu1) disco; urgency=medium

  * Merge with Debian testing, Among many other things this fixes LP Bugs:
    LP: #1806104 - fix misleading page size error on ppc64el
    LP: #1782205 - SnowRidge enabled new ISAs
    LP: #1786956 - upgrade to qemu >= 3.0
    LP: #1809083 - Backward migration to Xenial on ppc64el
    LP: #1803315 - s390x Huge page enablement
    LP: #1657409 - enable virglrenderer
    Remaining Changes:
    - qemu-kvm to systemd unit
      - d/qemu-kvm-init: script for QEMU KVM preparation modules, ksm,
        hugepages and architecture specifics
      - d/qemu-kvm.service: systemd unit to call qemu-kvm-init
      - d/qemu-system-common.install: install systemd unit and helper script
      - d/qemu-system-common.maintscript: clean old sysv and upstart scripts
      - d/qemu-system-common.qemu-kvm.default: defaults for
        /etc/default/qemu-kvm
      - d/rules: install /etc/default/qemu-kvm
    - Enable nesting by default
      - d/qemu-system-x86.modprobe: set nested=1 module option on intel.
        (is default on amd)
      - d/qemu-system-x86.postinst: re-load kvm_intel.ko if it was loaded
        without nested=1
      - d/p/ubuntu/expose-vmx_qemu64cpu.patch: expose nested kvm by default
        in qemu64 cpu type.
      - d/p/ubuntu/enable-svm-by-default.patch: Enable nested svm by default
        in qemu64 on amd
      - d/qemu-system-x86.README.Debian: document intention of nested being
        default is comfort, not full support
    - Distribution specific machine type (LP: 1304107 1621042 1776189 1761372)
      - d/p/ubuntu/define-ubuntu-machine-types.patch: define distro machine
        types
      - d/qemu-system-x86.NEWS Info on fixed machine type defintions
        for host-phys-bits=true (LP: 1776189)
      - add an info about -hpb machine type in debian/qemu-system-x86.NEWS
      - d/p/ubuntu/lp-1761372-*: provide pseries-bionic-2.11-sxxm type as
        convenience with all meltdown/spectre workarounds enabled by default.
        (LP: 1761372).
    - improved dependencies
      - Make qemu-system-common depend on qemu-block-extra
      - Make qemu-utils depend on qemu-block-extra
      - let qemu-utils recommend sharutils
    - s390x support
      - Create qemu-system-s390x package
      - Enable numa support for s390x
    - arch aware kvm wrappers
    - d/control: update VCS links (updated to match latest Ubuntu)
    - qemu-guest-agent: freeze-hook fixes (LP: 1484990)
      - d/qemu-guest-agent.install: provide /etc/qemu/fsfreeze-hook
      - d/qemu-guest-agent.dirs: provide /etc/qemu/fsfreeze-hook.d
    - d/control-in: enable RDMA support in qemu (LP: 1692476)
        - enable RDMA config option
        - add libibumad-dev build-dep
    - tolerate ipxe size change on migrations to >=18.04 (LP: 1713490)
      - d/p/ubuntu/pre-bionic-256k-ipxe-efi-roms.patch: old machine types
        reference 256k path
      - d/control-in: depend on ipxe-qemu-256k-compat-efi-roms to be able to
        handle incoming migrations from former releases.
    - d/control-in: Disable capstone disassembler library support (universe...

Changed in qemu (Ubuntu):
status: Triaged → Fix Released
Changed in ubuntu-power-systems:
status: Triaged → In Progress
description: updated

FYI - the fix for this bug as an SRUs is ready and testable from a PPA for
Cosmic [1] and Bionic [2].

I'm gonna check the test instructions myself by testing that from the PPA before uploading to the SRU queue.

In addition I'll push these PPAs through the automated regression tests for qemu/libvirt.

[1]: https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/3620
[2]: https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/3621

I tested the SRU testcase
1. it triggers as expected
2. the builds from the PPA fix it as expected

That said this would be ready to go to the SRU queue, but there are other bundled cases that I need to test first.

description: updated

FYI: All Pre-Tests and Review complete - Uploaded to the SRU queue of Bionic and Cosmic

Changed in qemu (Ubuntu Bionic):
status: Triaged → In Progress
Changed in qemu (Ubuntu Cosmic):
status: Triaged → In Progress

Hello bugproxy, or anyone else affected,

Accepted qemu into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/qemu/1:2.12+dfsg-3ubuntu8.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in qemu (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Download full text (5.8 KiB)

Started on Disco with the config described in the SRU header.

2019-02-07T09:08:54.779681Z qemu-system-ppc64: warning: System page size 0x40000000 is not enabled in page_size_mask (0x11000). Performance may be slow

Installing Cosmic qemu from proposed worked fine
$ sudo apt install $(apt list --upgradable 2>&1 | awk '/^qemu/ {gsub("/.*",""); print $0}' | xargs)
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  samba vde2 openbios-ppc openhackware debootstrap
The following packages will be upgraded:
  qemu-block-extra qemu-kvm qemu-system-common qemu-system-data qemu-system-gui qemu-system-ppc qemu-utils
7 upgraded, 0 newly installed, 0 to remove and 16 not upgraded.
Need to get 10.3 MB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://ports.ubuntu.com/ubuntu-ports cosmic-proposed/main ppc64el qemu-utils ppc64el 1:2.12+dfsg-3ubuntu8.3 [1055 kB]
Get:2 http://ports.ubuntu.com/ubuntu-ports cosmic-proposed/main ppc64el qemu-system-common ppc64el 1:2.12+dfsg-3ubuntu8.3 [32.4 kB]
Get:3 http://ports.ubuntu.com/ubuntu-ports cosmic-proposed/main ppc64el qemu-block-extra ppc64el 1:2.12+dfsg-3ubuntu8.3 [42.4 kB]
Get:4 http://ports.ubuntu.com/ubuntu-ports cosmic-proposed/main ppc64el qemu-system-data all 1:2.12+dfsg-3ubuntu8.3 [703 kB]
Get:5 http://ports.ubuntu.com/ubuntu-ports cosmic-proposed/main ppc64el qemu-kvm ppc64el 1:2.12+dfsg-3ubuntu8.3 [12.7 kB]
Get:6 http://ports.ubuntu.com/ubuntu-ports cosmic-proposed/main ppc64el qemu-system-ppc ppc64el 1:2.12+dfsg-3ubuntu8.3 [8429 kB]
Get:7 http://ports.ubuntu.com/ubuntu-ports cosmic-proposed/main ppc64el qemu-system-gui ppc64el 1:2.12+dfsg-3ubuntu8.3 [35.0 kB]
Fetched 10.3 MB in 7s (1440 kB/s)
(Reading database ... 114642 files and directories currently installed.)
Preparing to unpack .../0-qemu-utils_1%3a2.12+dfsg-3ubuntu8.3_ppc64el.deb ...
Unpacking qemu-utils (1:2.12+dfsg-3ubuntu8.3) over (1:2.12+dfsg-3ubuntu8.2) ...
Preparing to unpack .../1-qemu-system-common_1%3a2.12+dfsg-3ubuntu8.3_ppc64el.deb ...
Unpacking qemu-system-common (1:2.12+dfsg-3ubuntu8.3) over (1:2.12+dfsg-3ubuntu8.2) ...
Preparing to unpack .../2-qemu-block-extra_1%3a2.12+dfsg-3ubuntu8.3_ppc64el.deb ...
Unpacking qemu-block-extra:ppc64el (1:2.12+dfsg-3ubuntu8.3) over (1:2.12+dfsg-3ubuntu8.2) ...
Preparing to unpack .../3-qemu-system-data_1%3a2.12+dfsg-3ubuntu8.3_all.deb ...
Unpacking qemu-system-data (1:2.12+dfsg-3ubuntu8.3) over (1:2.12+dfsg-3ubuntu8.2) ...
Preparing to unpack .../4-qemu-kvm_1%3a2.12+dfsg-3ubuntu8.3_ppc64el.deb ...
Unpacking qemu-kvm (1:2.12+dfsg-3ubuntu8.3) over (1:2.12+dfsg-3ubuntu8.2) ...
Preparing to unpack .../5-qemu-system-ppc_1%3a2.12+dfsg-3ubuntu8.3_ppc64el.deb ...
Unpacking qemu-system-ppc (1:2.12+dfsg-3ubuntu8.3) over (1:2.12+df...

Read more...

tags: added: verification-done verification-done-cosmic
removed: verification-needed verification-needed-cosmic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qemu - 1:2.12+dfsg-3ubuntu8.3

---------------
qemu (1:2.12+dfsg-3ubuntu8.3) cosmic; urgency=medium

  * d/p/ubuntu/lp-1806104-spapr_pci-Remove-unhelpful-pagesize-warning.patch:
    remove misleading page size warning on qemu-system-ppc64 (LP: #1806104)
  * d/p/ubuntu/lp-1812384-s390x-Return-specification-exception.patch: ensure
    a proper exception on unknown diag 308 subcodes
    (LP: #1812384)
  * d/p/ubuntu/lp-1809083-*: fix backward migration on ppc64el (LP: #1809083)

 -- Christian Ehrhardt <email address hidden> Thu, 31 Jan 2019 14:28:19 +0100

Changed in qemu (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for qemu has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Manoj Iyer (manjo) on 2019-02-18
Changed in qemu (Ubuntu Bionic):
assignee: nobody → Christian Ehrhardt  (paelzer)

------- Comment From <email address hidden> 2019-02-19 09:13 EDT-------
As per previous comment, it is mentioned that the issue is fixed in qemu (1:2.12+dfsg-3ubuntu8.3), How ever I am able to see the same message in log on Bionic Ubuntu 18.04.2 LTS.

# dpkg -l | grep qemu
ii qemu 1:2.12+dfsg-3ubuntu8.3 ppc64el fast processor emulator, dummy package

cat /var/log/libvirt/qemu/Hari_compact_mode.log | grep slow
2019-02-19T14:05:01.945694Z qemu-system-ppc64: System page size 0x40000000 is not enabled in page_size_mask (0x11000). Performance may be slow

System Information

# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.2 LTS
Release: 18.04
Codename: bionic

# uname -a
Linux ltc-kvmfvtzz 4.18.0-16-generic #17-Ubuntu SMP Fri Feb 8 00:06:40 UTC 2019 ppc64le ppc64le ppc64le GNU/Linux

Hello bugproxy, or anyone else affected,

Accepted qemu into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/qemu/1:2.11+dfsg-1ubuntu7.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in qemu (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
removed: verification-done
Changed in ubuntu-power-systems:
status: In Progress → Fix Committed

Tested with the config described in the bug:
 System page size 0x40000000 is not enabled in page_size_mask (0x11000). Performance may be slow

Updated to proposed and restarted the same guest, no such message in /var/log/libvirt/qemu/b-huge.log where you'd usually see it.

Therefore setting verified.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic

@SRU Team - I beg your pardon and wanted to make clear that I try to care for my SRUs.
This looks all good except autopkgtest failing for other reasons.
Those are handled in bug 1817721.
IMHO: Feel free to release this as-is and/or to help getting the MP associated to 1817721 accepted.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qemu - 1:2.11+dfsg-1ubuntu7.10

---------------
qemu (1:2.11+dfsg-1ubuntu7.10) bionic; urgency=medium

  * d/p/ubuntu/lp-1806104-spapr_pci-Remove-unhelpful-pagesize-warning.patch:
    remove misleading page size warning on qemu-system-ppc64 (LP: #1806104)
  * d/p/ubuntu/lp-1812384-s390x-Return-specification-exception.patch: ensure
    a proper exception on unknown diag 308 subcodes
    (LP: #1812384)
  * d/p/ubuntu/lp-1809083-*: fix backward migration on ppc64el (LP: #1809083)

 -- Christian Ehrhardt <email address hidden> Thu, 31 Jan 2019 14:07:51 +0100

Changed in qemu (Ubuntu Bionic):
status: Fix Committed → Fix Released
Changed in ubuntu-power-systems:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments