Ubuntu16.04 LTS - PCI Pass Through in Ubuntu KVM 16.04.x must use QEMU with DDW support from PPA (Documentation)

Bug #1801674 reported by bugproxy on 2018-11-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Ubuntu-power-systems project
Undecided
Unassigned
qemu (Ubuntu)
Undecided
Ubuntu on IBM Power Systems Bug Triage

Bug Description

== Comment: #0 - Siraj M. Ismail <email address hidden> - 2016-10-05 11:35:38 ==
---Problem Description---

Customer running PCI pass through with 16.04.1 KVM and with the stock QEMU packages will hit a DI if they do not update to the QEMU packages with DDW support. The packages are in PPA for customers to download, and test has verified the fix. The details are in Bugzilla 144123.

---uname output---
Ubuntu 16.04.1 with 4.4.0 Kernel

Machine Type = 8247-22L

---Debugger---
A debugger is not configured

---Steps to Reproduce---
 Run guest with adapters assigned via PCI PT, The guest will start having DI issues as soon as I/O started on the Pass Through adapter.

Contact Information = <email address hidden>

---Patches Installed---
QEMU was updated from 2.5 version to 2.6.1 with patches for DDW support, can be found at PPA location :
https://launchpad.net/~ibmpackages/+archive/ubuntu/ddw

Userspace tool common name: QEMU

Documentation version: N/A

The userspace tool has the following bit modes: N/A

Userspace rpm: N/A

Userspace tool obtained from project website: na

*Additional Instructions for <email address hidden>:
-Post a private note with access information to the machine that the bug is occuring on.
-Attach ltrace and strace of userspace application.

== Comment: #5 - Leonardo Augusto Guimaraes Garcia <email address hidden> - 2017-04-25 16:23:57 ==
I would rephrase to:

-------------------------------

Under KVM recommendations

PCI passthrough recommendations

If you are running PCI passthrough with 16.04.x KVM and with the stock QEMU package, update to the QEMU package that have DDW support. If you do not update the package, you will hit data integrity issues as soon as I/O is started on the adapter.

The package is available at: https://launchpad.net/~ibmpackages/+archive/ubuntu/ddw

-------------------------------

bugproxy (bugproxy) on 2018-11-05
tags: added: architecture-ppc64le bugnameltc-147287 severity-critical targetmilestone-inin16041
Changed in ubuntu:
assignee: nobody → Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage)
affects: ubuntu → qemu (Ubuntu)
no longer affects: qemu
Frank Heimes (frank-heimes) wrote :

Some time ago DDW was discussed in this ticket:
https://bugs.launchpad.net/ubuntu/+source/qemu/+bug/1541902
And it got introduced in Yakkety and higher only.
Due to pretty complex changes and changes in the virtual machine attributes there is no plan to get it into xenial.
Also 'bugproxy' changed "targetmilestone-inin16041" to "targetmilestone-inin1610".
We are wondering why this now came up again?

summary: Ubuntu16.04 LTS - PCI Pass Through in Ubuntu KVM 16.04.x must use QEMU
- with DDW support from PPA
+ with DDW support from PPA (Documentation)

------- Comment From <email address hidden> 2018-11-05 05:57 EDT-------
(In reply to comment #14)
> Some time ago DDW was discussed in this ticket:
> https://bugs.launchpad.net/ubuntu/+source/qemu/+bug/1541902
> And it got introduced in Yakkety and higher only.
> Due to pretty complex changes and changes in the virtual machine attributes
> there is no plan to get it into xenial.
> Also 'bugproxy' changed "targetmilestone-inin16041" to
> "targetmilestone-inin1610".
> We are wondering why this now came up again?

This bug was lying in LTC bugzilla since a while and i happen to
mirror it today after the previous QA left IBM. Its a documentation
bug for 16.04.x

Frank Heimes (frank-heimes) wrote :
Changed in qemu (Ubuntu):
status: New → Fix Released
Changed in ubuntu-power-systems:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers