qemu-system-s390x. Could not read keymap file: 'en-us'

Bug #1798084 reported by bugproxy on 2018-10-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Medium
Christian Ehrhardt 
qemu (Ubuntu)
Low
Unassigned

Bug Description

[Impact]

 * Debian has split some common files like icons, keymaps, base man&doc
   pages (e.g. of interfaces), trace event defintion into an extra package
   called "qemu-system-data". The ubuntu-only package qemu-system-s390x
   needs to follow that split.

 * The impact of missing that isn't huge, you'll miss key maps or not find
   docs, but it is easy to resolve and feels wrong to have the default
    experience (e.g. calling it with no arguments) to report an error.

 * Fix is "just" adding the right dependency to the qemu-system-s390x
   package.

[Test Case]

 * on s390x, install qemu-system-s390x
 * Before the fix this would not pull qemu-system-data, for testing make
   sure this isn't by accident installed by another dependency or you
   won't be able to reproduce this issue.
 * run it
    $ qemu-system-s390x
    Could not read keymap file: 'en-us'

[Regression Potential]

 * The change is to the s390x package only and only an extra dependency.
   So if anything it will consume slightly more disk space by pulling
   things in, but since those were formerly part of qemu-common which is
   pulled in still that is fine.

[Other Info]

 * Mostly this issue was hidden for various reasons
   - dependencies often pull in qemu-system which pulls qemu-system-
     <arch*> and the others pull qemu-system-data correctly.
   - Furthermore unless you need non en-us input, inist on the icon or
     need the api doc you'll run in no issues - for example all the tests
     we ran on cosmic were happy

== Comment: #0 - Christian Borntraeger - 2018-10-08 07:14:51 ==
---Problem Description---

found on cosmic beta:
# dpkg -l | grep qemu
ii qemu-block-extra:s390x 1:2.12+dfsg-3ubuntu7 s390x extra block backend modules for qemu-system and qemu-utils
ii qemu-kvm 1:2.12+dfsg-3ubuntu7 s390x QEMU Full virtualization on x86 hardware
ii qemu-system-common 1:2.12+dfsg-3ubuntu7 s390x QEMU full system emulation binaries (common files)
ii qemu-system-s390x 1:2.12+dfsg-3ubuntu7 s390x QEMU full system emulation binaries (s390x)
ii qemu-utils 1:2.12+dfsg-3ubuntu7 s390x QEMU utilities

When installing qemu-kvm and running without -nographic
I get the following error:
# qemu-system-s390x -enable-kvm
Could not read keymap file: 'en-us'

When I use -nographic everything is fine.

So it seems that the qemu-kvm package has some missing dependencies (or misses some files).

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1798084/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment

------- Comment From <email address hidden> 2018-10-16 13:36 EDT-------
This commit can give a clue:

https://git.launchpad.net/ubuntu/+source/qemu/commit/?id=de0f9c45e0abbfe987775eeb2d8137a6ed721920

- d/control-in: qemu-keymaps is provided by qemu-system-data now (from yet
unreleased Debian version)

Perhaps system is missing this qemu-system-data package that delivers /usr/share/qemu/keymaps/en-us file.

https://packages.ubuntu.com/cosmic/all/qemu-system-data/filelist

tags: added: architecture-s3903164 bugnameltc-172145 severity-medium targetmilestone-inin---
Frank Heimes (fheimes) on 2018-10-17
Changed in ubuntu-z-systems:
importance: Undecided → Medium
bugproxy (bugproxy) on 2018-10-17
tags: added: architecture-s39064
removed: architecture-s3903164
Frank Heimes (fheimes) wrote :

I can confirm that the message:
"Could not read keymap file: 'en-us'"
does not occur in case the "qemu-system-data" package is installed.

$ sudo qemu-system-s390x -enable-kvm
Could not read keymap file: 'en-us'
$ sudo apt install qemu-system-data
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  qemu-system-data
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 706 kB of archives.
After this operation, 2,731 kB of additional disk space will be used.
Get:1 http://us.ports.ubuntu.com/ubuntu-ports cosmic/main s390x qemu-system-data all 1:2.12+dfsg-3ubuntu7 [706 kB]
Fetched 706 kB in 0s (20.4 MB/s)
Selecting previously unselected package qemu-system-data.
(Reading database ... 54122 files and directories currently installed.)
Preparing to unpack .../qemu-system-data_1%3a2.12+dfsg-3ubuntu7_all.deb ...
Unpacking qemu-system-data (1:2.12+dfsg-3ubuntu7) ...
Setting up qemu-system-data (1:2.12+dfsg-3ubuntu7) ...
Processing triggers for man-db (2.8.4-2) ...
$ sudo qemu-system-s390x -enable-kvm
VNC server running on ::1:5900

Frank Heimes (fheimes) on 2018-10-17
affects: ubuntu → qemu (Ubuntu)

Yes,
in qemu 2.12 that was split in Debian and the only-Ubuntu qemu-system-s390x package misses that following the split.

Diff would be like:
diff --git a/debian/control-in b/debian/control-in
index 1506331cef..6fa2b39b60 100644
--- a/debian/control-in
+++ b/debian/control-in
@@ -487,7 +487,7 @@ Description: QEMU Full virtualization on x86 hardware
 :ubuntu:Package: qemu-system-s390x
 :ubuntu:Architecture: amd64 arm arm64 armel armhf hppa i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mipsel powerpc powerpcspe ppc64 ppc64el s390x sparc sparc64
 :ubuntu:Multi-Arch: foreign
-:ubuntu:Depends: ${shlibs:Depends}, ${misc:Depends}, qemu-system-common (>> 2.0.0+dfsg-8~),
+:ubuntu:Depends: ${shlibs:Depends}, ${misc:Depends}, qemu-system-common (>> 2.0.0+dfsg-8~), qemu-system-data (>> ${source:Version}~),
 :ubuntu:Recommends: qemu-utils,
 :ubuntu:Suggests: qemu-block-extra (= ${binary:Version}),
 :ubuntu:Provides: ${sysprovides:s390x}

Changed in qemu (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Frank Heimes (fheimes) on 2018-10-17
Changed in ubuntu-z-systems:
assignee: nobody →  Christian Ehrhardt  (paelzer)

Thanks for the report Christian.

This isn't severe but should be fixed.

Due to Cosmic being in the last steps to be released I doubt the Release Team will make the update soon.
But I'll prepare it as it would be an SRU then they can decide to
a) get it into cosmic-release
b) accept it as day-0 SRU

Thereby I hope to avoid having to wait the opening for 19.04 to fix that.

Frank Heimes (fheimes) on 2018-10-17
Changed in ubuntu-z-systems:
status: New → Triaged

Fix is pushed and tagged in Git.
Test PPA is building in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/3489

Once build I'll ran a test and a few other verifications and then push it for the Release Team to decide on accepting now or as 0-day SRU.

description: updated

Multi-repo confusion, refreshed PPA and git :-)

Frank Heimes (fheimes) on 2018-10-17
Changed in qemu (Ubuntu):
status: Triaged → In Progress
Changed in ubuntu-z-systems:
status: Triaged → In Progress

Working fine as expected from the PPA.

Uploaded to Cosmic, but as outlined before we have to check when/where it lands due to the release being finalized at the moment.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qemu - 1:2.12+dfsg-3ubuntu8

---------------
qemu (1:2.12+dfsg-3ubuntu8) cosmic; urgency=medium

  * d/control-in: our addition of a qemu-system-s390x package needs to follow
    the split of qemu-system-data by adding a dependency to it (LP: #1798084)

 -- Christian Ehrhardt <email address hidden> Wed, 17 Oct 2018 10:50:27 +0200

Changed in qemu (Ubuntu):
status: In Progress → Fix Released
Frank Heimes (fheimes) on 2018-10-18
Changed in ubuntu-z-systems:
status: In Progress → Fix Released
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-10-18 04:12 EDT-------
IBM Bugzilla status-> closed, Fix Released in Cosmic

tags: added: targetmilestone-inin1810
removed: targetmilestone-inin---
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-10-18 05:30 EDT-------
Confirmed and tested with
qemu-kvm 1:2.12+dfsg-3ubuntu8

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers