Ubuntu

Activity log for bug #156085

Date Who What changed Old value New value Message
2007-10-23 04:52:41 TJ bug added bug
2007-10-23 04:53:05 TJ bug assigned to kvm (Ubuntu)
2007-10-23 04:54:35 TJ description Binary package hint: qemu On Gutsy 64-bit using qemu/kvm and the "-usb" switch no USB devices are available since qemu/kvm looks for them in /proc/bus/usb/devices but they are now in /sys/bus/usb/devices qemu/kvm reports: info usbhost Could not open /proc/bus/usb/devices $ ls -l /proc/bus/usb total 0 $ ls /sys/bus/usb/devices 1-0:1.0 3-1 3-1:1.2 5-2 5-3:1.0 5-8:1.1 usb3 2-0:1.0 3-1:1.0 4-0:1.0 5-2:1.0 5-8 usb1 usb4 3-0:1.0 3-1:1.1 5-0:1.0 5-3 5-8:1.0 usb2 usb5 Binary package hint: qemu On Gutsy 64-bit using qemu/kvm and the "-usb" switch no USB devices are available since qemu/kvm looks for them in /proc/bus/usb/devices but they are now in /sys/bus/usb/devices qemu/kvm reports: qemuctl -qemu vdeq kvm -boot c -m 512 -hda /home/all/VirtualMachines/WindowsXP-SP2.ovl -net nic,vlan=0 -soundhw es1370 -usb -net vde info usbhost Could not open /proc/bus/usb/devices $ ls -l /proc/bus/usb total 0 $ ls /sys/bus/usb/devices 1-0:1.0 3-1 3-1:1.2 5-2 5-3:1.0 5-8:1.1 usb3 2-0:1.0 3-1:1.0 4-0:1.0 5-2:1.0 5-8 usb1 usb4 3-0:1.0 3-1:1.1 5-0:1.0 5-3 5-8:1.0 usb2 usb5
2007-10-23 07:01:10 TJ bug added attachment 'kvm-qemu-usb-linux.diff' (Patch to use /sys/bus/usb)
2007-10-27 13:10:10 TJ qemu: importance Undecided Low
2007-10-27 13:10:10 TJ qemu: assignee intuitivenipple
2007-10-27 13:10:10 TJ qemu: status New In Progress
2007-10-27 13:10:20 TJ kvm: importance Undecided Low
2007-10-27 13:10:20 TJ kvm: assignee intuitivenipple
2007-10-27 13:10:20 TJ kvm: status New In Progress
2007-10-28 14:50:04 TJ bug assigned to sysvinit (Ubuntu)
2007-10-29 03:32:03 Scott James Remnant (Canonical) sysvinit: status New Invalid
2007-10-29 19:10:28 TJ bug added attachment 'kvm_28-4ubuntu3-gutsy.debdiff' (kvm -4ubuntu3 gutsy-proposed debdiff)
2007-10-29 19:11:09 TJ bug added attachment 'kvm_28-4ubuntu3-hardy.debdiff' (kvm -4ubuntu3 hardy debdiff)
2007-10-29 19:12:05 TJ bug added attachment 'qemu_0.9.0-2ubuntu5-gutsy.debdiff' (qemu -2ubuntu5 gutsy-proposed debdiff)
2007-10-29 19:15:54 TJ bug added attachment 'qemu_0.9.0-2ubuntu5-hardy.debdiff' (qemu -2ubuntu5 hardy debdiff)
2007-10-29 19:16:45 TJ bug added subscriber Ubuntu Stable Release Updates Team
2007-10-29 19:17:20 TJ kvm: status In Progress Fix Committed
2007-10-29 19:17:29 TJ qemu: status In Progress Fix Committed
2007-10-29 21:55:38 TJ kvm: status Fix Committed In Progress
2007-10-29 22:00:57 TJ qemu: status Fix Committed Confirmed
2007-10-29 22:00:57 TJ qemu: assignee intuitivenipple
2007-10-29 22:01:07 TJ kvm: status In Progress Confirmed
2007-10-29 22:01:07 TJ kvm: assignee intuitivenipple
2007-10-29 22:07:21 TJ bug added subscriber Ubuntu Sponsors for universe
2007-10-31 12:32:44 TJ bug added attachment 'Screenshot-1.png' (Screenshot of qemuctl displaying USB devices (846x708))
2007-11-08 12:58:54 Emmet Hikory qemu: status Confirmed In Progress
2007-11-08 12:58:54 Emmet Hikory qemu: assignee persia
2007-11-08 12:59:05 Emmet Hikory kvm: status Confirmed In Progress
2007-11-08 12:59:05 Emmet Hikory kvm: assignee persia
2007-11-08 13:49:45 Emmet Hikory kvm: status In Progress Fix Committed
2007-11-08 14:06:28 Emmet Hikory qemu: assignee persia intuitivenipple
2007-11-08 14:07:08 Emmet Hikory bug added subscriber Ubuntu Sponsors for universe
2007-11-08 14:07:39 Emmet Hikory sysvinit: status New Invalid
2007-11-08 16:20:53 TJ description Binary package hint: qemu On Gutsy 64-bit using qemu/kvm and the "-usb" switch no USB devices are available since qemu/kvm looks for them in /proc/bus/usb/devices but they are now in /sys/bus/usb/devices qemu/kvm reports: qemuctl -qemu vdeq kvm -boot c -m 512 -hda /home/all/VirtualMachines/WindowsXP-SP2.ovl -net nic,vlan=0 -soundhw es1370 -usb -net vde info usbhost Could not open /proc/bus/usb/devices $ ls -l /proc/bus/usb total 0 $ ls /sys/bus/usb/devices 1-0:1.0 3-1 3-1:1.2 5-2 5-3:1.0 5-8:1.1 usb3 2-0:1.0 3-1:1.0 4-0:1.0 5-2:1.0 5-8 usb1 usb4 3-0:1.0 3-1:1.1 5-0:1.0 5-3 5-8:1.0 usb2 usb5 Binary package hint: qemu On Gutsy 64-bit using qemu/kvm and the "-usb" switch no USB devices are available since qemu/kvm looks for them in /proc/bus/usb/devices but they are now in /dev/bus/usb/devices qemu/kvm reports: qemuctl -qemu vdeq kvm -boot c -m 512 -hda /home/all/VirtualMachines/WindowsXP-SP2.ovl -net nic,vlan=0 -soundhw es1370 -usb -net vde info usbhost Could not open /proc/bus/usb/devices $ ls -l /proc/bus/usb total 0
2007-11-08 16:22:54 TJ bug added attachment 'qemu_0.9.0+20070816-1ubuntu2.debdiff' (Rebased qemu -1ubuntu2 Hardy debdiff)
2007-11-08 16:23:50 TJ qemu: status In Progress Confirmed
2007-11-08 16:23:50 TJ qemu: assignee intuitivenipple
2007-11-11 08:36:45 Chris Halse Rogers kvm: status Fix Committed Fix Released
2007-11-14 00:13:02 Daniel Hahler bug assigned to usbview (Ubuntu)
2007-11-14 00:13:52 Daniel Hahler usbview: status New Confirmed
2007-11-14 00:31:45 Daniel Hahler usbview: status New Confirmed
2007-11-14 00:32:25 Daniel Hahler bug added attachment 'usbview_1.0-11ubuntu1.dsc.diff' (usbview: Debdiff for Hardy)
2007-11-14 00:39:30 Daniel Hahler bug added attachment 'usbview_1.0-11ubuntu1.dsc.diff' (usbview: Debdiff for Hardy)
2007-11-14 00:40:52 Daniel Hahler bug added attachment 'usbview_1.0-7ubuntu0.1.dsc.diff' (usbview: Debdiff for gutsy-proposed)
2007-11-14 00:51:54 Daniel Hahler bug added attachment 'usbview_1.0-11ubuntu1.dsc.diff' (usbview: Debdiff for Hardy)
2007-11-14 00:52:24 Daniel Hahler bug added attachment 'usbview_1.0-7ubuntu0.1.dsc.diff' (usbview: Debdiff for gutsy-proposed)
2007-11-14 00:59:03 Daniel Hahler bug assigned to usbview (Debian)
2007-11-14 11:20:05 Bug Watch Updater usbview: status Unknown New
2007-11-14 22:06:28 Emmet Hikory usbview: status Confirmed In Progress
2007-11-14 22:06:28 Emmet Hikory usbview: assignee blueyed
2007-11-14 23:58:54 Daniel Hahler usbview: status In Progress Confirmed
2007-11-14 23:58:54 Daniel Hahler usbview: assignee blueyed
2007-11-15 13:28:33 TJ description Binary package hint: qemu On Gutsy 64-bit using qemu/kvm and the "-usb" switch no USB devices are available since qemu/kvm looks for them in /proc/bus/usb/devices but they are now in /dev/bus/usb/devices qemu/kvm reports: qemuctl -qemu vdeq kvm -boot c -m 512 -hda /home/all/VirtualMachines/WindowsXP-SP2.ovl -net nic,vlan=0 -soundhw es1370 -usb -net vde info usbhost Could not open /proc/bus/usb/devices $ ls -l /proc/bus/usb total 0 On Gutsy 64-bit using qemu/kvm (also VirtualBox and, I believe, VMWare) and the "-usb" switch no USB devices are available since qemu/kvm looks for the description of them in the 'devices' file of a usbfs mount at /proc/bus/usb/ but the code previously providing the usbfs mount that is created at start-up via /etc/rcS/S11mountdevsubfs.sh --> /etc/init.d/mountdevsubfs.sh was commented out. The USB devices are now reported at /dev/bus/usb/ but currently there is no usbfs file-system mounted/linked there to provide the 'devices' text-file. qemu/kvm reports: qemuctl -qemu vdeq kvm -boot c -m 512 -hda /home/all/VirtualMachines/WindowsXP-SP2.ovl -net nic,vlan=0 -soundhw es1370 -usb -net vde info usbhost Could not open /proc/bus/usb/devices $ ls -l /proc/bus/usb total 0
2007-11-15 14:44:57 TJ bug added attachment 'mountdevusbfs.sh' (Proposed /etc/init.d/mountdevusbfs.sh)
2007-12-08 20:09:38 Daniel Hahler bug assigned to vmware-server (Ubuntu)
2007-12-08 20:11:58 Daniel Hahler description On Gutsy 64-bit using qemu/kvm (also VirtualBox and, I believe, VMWare) and the "-usb" switch no USB devices are available since qemu/kvm looks for the description of them in the 'devices' file of a usbfs mount at /proc/bus/usb/ but the code previously providing the usbfs mount that is created at start-up via /etc/rcS/S11mountdevsubfs.sh --> /etc/init.d/mountdevsubfs.sh was commented out. The USB devices are now reported at /dev/bus/usb/ but currently there is no usbfs file-system mounted/linked there to provide the 'devices' text-file. qemu/kvm reports: qemuctl -qemu vdeq kvm -boot c -m 512 -hda /home/all/VirtualMachines/WindowsXP-SP2.ovl -net nic,vlan=0 -soundhw es1370 -usb -net vde info usbhost Could not open /proc/bus/usb/devices $ ls -l /proc/bus/usb total 0 On Gutsy 64-bit using qemu/kvm (also VirtualBox and, I believe, VMWare) and the "-usb" switch no USB devices are available since qemu/kvm looks for the description of them in the 'devices' file of a usbfs mount at /proc/bus/usb/ but the code previously providing the usbfs mount that is created at start-up via /etc/rcS/S11mountdevsubfs.sh --> /etc/init.d/mountdevsubfs.sh was commented out. The USB devices are now reported at /dev/bus/usb/ but currently there is no usbfs file-system mounted/linked there to provide the 'devices' text-file. qemu/kvm reports: qemuctl -qemu vdeq kvm -boot c -m 512 -hda /home/all/VirtualMachines/WindowsXP-SP2.ovl -net nic,vlan=0 -soundhw es1370 -usb -net vde info usbhost Could not open /proc/bus/usb/devices $ ls -l /proc/bus/usb total 0 WORKAROUND: To re-enable it edit the file '/etc/init.d/mountdevsubfs.sh' and uncomment the code after line 40 so it reads: # Magic to make /proc/bus/usb work # mkdir -p /dev/bus/usb/.usbfs domount usbfs "" /dev/bus/usb/.usbfs -obusmode=0700,devmode=0600,listmode=0644 ln -s .usbfs/devices /dev/bus/usb/devices mount --rbind /dev/bus/usb /proc/bus/usb Execute the script manually to enable the change before a system reboot: $ sudo /etc/init.d/mountdevsubfs.sh start
2008-02-12 19:15:58 Malte S. Stretz bug assigned to qemu
2008-02-12 19:21:22 Malte S. Stretz bug assigned to virtualbox
2008-02-13 12:03:24 Bug Watch Updater virtualbox: status Unknown New
2008-02-13 16:32:50 Emmet Hikory kvm: status Fix Released Confirmed
2008-02-13 16:32:50 Emmet Hikory kvm: assignee persia
2008-03-14 22:25:58 Daniel Hahler sysvinit: importance Undecided High
2008-03-14 22:25:58 Daniel Hahler sysvinit: status Invalid Triaged
2008-03-14 22:25:58 Daniel Hahler sysvinit: milestone ubuntu-8.04-beta
2008-03-21 21:47:39 Steve Langasek sysvinit: milestone ubuntu-8.04-beta ubuntu-8.04
2008-04-11 16:13:13 Scott James Remnant (Canonical) sysvinit: status Triaged Won't Fix
2008-04-11 16:45:22 Steve Langasek sysvinit: status Triaged Won't Fix
2008-04-11 16:49:23 Scott James Remnant (Canonical) sysvinit: milestone ubuntu-8.04
2008-08-03 17:09:05 Shirish Agarwal bug added attachment 'mountdevsubfs.sh' (mountdevubfs.sh)
2008-08-17 10:43:32 Matt Zimmerman bug assigned to qemu (openSUSE)
2008-08-17 10:46:47 Bug Watch Updater qemu: status Unknown Fix Released
2008-09-03 20:38:19 TJ kvm: importance Low Medium
2008-09-03 20:38:19 TJ kvm: assignee intuitivenipple
2008-09-03 20:38:19 TJ kvm: statusexplanation I'm working on a patch that will allow legacy support for /proc/bus/usb and current support for /sys/bus/usb. I'm working with kvm userspace git head, which is just after kvm-74. The reason for working with the recent version is the substantial improvements in USB device support introduced with kvm-74, after a QEMU merge.
2008-09-04 23:16:42 TJ qemu: importance Low Medium
2008-09-04 23:16:42 TJ qemu: assignee intuitivenipple
2008-10-26 09:16:08 Danny Wood bug added attachment 'usb-linux.patch' (Patch to kvm-77 to allow USB passthrough with qemu)
2008-12-06 17:51:28 Tim Cole bug assigned to midisport-firmware (Ubuntu)
2008-12-18 23:26:05 Dustin Kirkland  bug added attachment '156085-b.debdiff' (156085-b.debdiff)
2008-12-19 00:33:59 Dustin Kirkland  kvm: status Confirmed In Progress
2008-12-19 00:33:59 Dustin Kirkland  kvm: assignee intuitivenipple kirkland
2008-12-19 00:33:59 Dustin Kirkland  kvm: statusexplanation I'm working on a patch that will allow legacy support for /proc/bus/usb and current support for /sys/bus/usb. I'm working with kvm userspace git head, which is just after kvm-74. The reason for working with the recent version is the substantial improvements in USB device support introduced with kvm-74, after a QEMU merge.
2008-12-19 00:34:42 Dustin Kirkland  kvm: status New Won't Fix
2008-12-19 00:34:42 Dustin Kirkland  kvm: statusexplanation
2008-12-19 00:35:45 Dustin Kirkland  midisport-firmware: status New Won't Fix
2008-12-19 00:35:45 Dustin Kirkland  midisport-firmware: statusexplanation
2008-12-19 00:36:11 Dustin Kirkland  qemu: status New Won't Fix
2008-12-19 00:36:11 Dustin Kirkland  qemu: statusexplanation
2008-12-19 00:36:41 Dustin Kirkland  usbview: status Confirmed Won't Fix
2008-12-19 00:36:41 Dustin Kirkland  usbview: statusexplanation Reported also for usbview in bug #151585.
2008-12-19 00:37:07 Dustin Kirkland  vmware-server: status New Won't Fix
2008-12-19 00:37:07 Dustin Kirkland  vmware-server: statusexplanation
2008-12-19 03:19:06 TJ bug added attachment 'qemu-usb-sysfs.patch' (QEMU (KVM) USB sys-fs support)
2009-02-03 10:08:41 Dimitrios Symeonidis usbview: status Confirmed Triaged
2009-02-03 10:08:41 Dimitrios Symeonidis usbview: importance Undecided Medium
2009-02-03 10:08:41 Dimitrios Symeonidis usbview: statusexplanation Upgrading to triaged-medium for Jaunty, to get some developer attention. This package has been broken for more than a year now, are we going to fix it or remove it? (I can't believe gregk-h is the maintainer of this!!!) http://www.kroah.com/linux/usb/
2009-02-13 06:00:30 TJ qemu: assignee intuitivenipple
2009-02-13 06:00:30 TJ qemu: statusexplanation
2009-02-19 09:29:30 Matt Zimmerman kvm: status In Progress Fix Released
2009-02-19 09:29:30 Matt Zimmerman kvm: statusexplanation Marking kvm as fixed in Jaunty per TJ's comment
2009-02-20 08:41:03 Bug Watch Updater virtualbox: status New Fix Released
2009-03-06 13:27:25 Noel J. Bergman bug assigned to apcupsd (Ubuntu)
2009-03-11 17:05:06 Colin Watson apcupsd: importance Undecided High
2009-03-11 17:05:06 Colin Watson apcupsd: statusexplanation
2009-03-12 00:26:18 Colin Watson vmware-server: importance Undecided High
2009-03-12 00:26:18 Colin Watson vmware-server: statusexplanation
2009-03-12 00:27:15 Colin Watson midisport-firmware: importance Undecided High
2009-03-12 00:27:15 Colin Watson midisport-firmware: statusexplanation
2009-03-16 15:33:10 Scott James Remnant (Canonical) apcupsd (Ubuntu Jaunty): assignee scott
2009-03-16 15:33:55 Scott James Remnant (Canonical) midisport-firmware (Ubuntu Jaunty): assignee scott
2009-03-16 15:34:16 Scott James Remnant (Canonical) qemu (Ubuntu Jaunty): assignee scott
2009-03-16 15:34:33 Scott James Remnant (Canonical) usbview (Ubuntu Jaunty): assignee scott
2009-03-16 15:34:33 Scott James Remnant (Canonical) usbview (Ubuntu Jaunty): statusexplanation Upgrading to triaged-medium for Jaunty, to get some developer attention. This package has been broken for more than a year now, are we going to fix it or remove it? (I can't believe gregk-h is the maintainer of this!!!) http://www.kroah.com/linux/usb/
2009-03-16 19:27:59 Noel J. Bergman apcupsd: status New Invalid
2009-03-16 19:27:59 Noel J. Bergman apcupsd: statusexplanation apcupsd works without /proc/bus/usb/devices -- documentation error
2009-03-16 19:29:00 Noel J. Bergman apcupsd: status New Invalid
2009-03-16 19:29:00 Noel J. Bergman apcupsd: statusexplanation apcupsd works without /proc/bus/usb/devices -- documentation error
2009-03-16 19:30:02 Noel J. Bergman apcupsd: status New Invalid
2009-03-16 19:30:02 Noel J. Bergman apcupsd: statusexplanation apcupsd works without /proc/bus/usb/devices --- documentation error
2009-03-16 20:40:39 Max Romantschuk bug added attachment 'udev' (/var/log/udev with Midisport plugged in)
2009-03-17 10:02:32 Scott James Remnant (Canonical) bug assigned to fxload (Ubuntu)
2009-03-17 10:10:06 Launchpad Janitor fxload: status New Fix Released
2009-03-17 10:10:14 Launchpad Janitor midisport-firmware: status New Fix Released
2009-03-17 11:00:36 Scott James Remnant (Canonical) qemu (Ubuntu Jaunty): assignee scott kirkland
2009-03-17 11:01:58 Scott James Remnant (Canonical) usbview (Ubuntu Jaunty): status Triaged Won't Fix
2009-03-17 11:01:58 Scott James Remnant (Canonical) usbview (Ubuntu Jaunty): statusexplanation usbview will be removed from the archive, it's functionality is available from lsusb or gnome-device-manager
2009-03-17 15:03:36 Dustin Kirkland  qemu (Ubuntu Jaunty): status Confirmed In Progress
2009-03-17 15:06:51 Dustin Kirkland  qemu (Ubuntu Jaunty): status In Progress Fix Released
2009-03-17 15:06:51 Dustin Kirkland  qemu (Ubuntu Jaunty): statusexplanation I'm marking QEMU as 'fix released' as well. The relevant patch that we were carrying for kvm has been included in QEMU upstream, and is already present in qemu 0.10.0 in Jaunty. :-Dustin
2009-03-17 15:07:25 Dustin Kirkland  qemu: status New Fix Released
2009-03-17 15:07:25 Dustin Kirkland  qemu: statusexplanation
2009-03-20 01:57:20 Steve Langasek vmware-server: status New Invalid
2009-03-20 01:57:20 Steve Langasek vmware-server: statusexplanation there is no vmware-server package in jaunty; marking this task invalid.
2009-03-31 16:20:08 Tim Cole bug assigned to madfuload (Ubuntu)
2009-04-01 08:45:06 Launchpad Janitor madfuload: status New Fix Released
2009-04-26 15:57:42 Malte S. Stretz removed subscriber Malte S. Stretz
2009-05-07 13:41:43 Sergio Zanchetta fxload (Ubuntu Gutsy): status New Won't Fix
2009-05-07 13:42:31 Sergio Zanchetta madfuload (Ubuntu Gutsy): status New Won't Fix
2009-08-17 09:36:27 Launchpad Janitor branch linked lp:ubuntu/karmic/madfuload
2009-08-18 22:25:50 Launchpad Janitor branch linked lp:ubuntu/karmic/midisport-firmware
2009-08-22 11:48:20 Launchpad Janitor branch linked lp:ubuntu/karmic/fxload
2009-09-19 22:55:16 ivan vucic qemu: status Fix Released Fix Committed
2009-09-20 00:09:50 Steve Langasek qemu: status Fix Committed Fix Released
2009-11-09 18:09:43 Scott James Remnant (Canonical) usbview (Ubuntu Jaunty): assignee Scott James Remnant (scott)
2009-11-09 18:10:34 Scott James Remnant (Canonical) usbview (Ubuntu): assignee Scott James Remnant (scott)
2010-05-10 22:14:59 Scott James Remnant (Canonical) removed subscriber Scott James Remnant
2010-06-04 10:00:29 Launchpad Janitor branch linked lp:ubuntu/fxload
2010-08-20 15:55:10 Dimitrios Symeonidis removed subscriber Dimitrios Symeonidis
2010-12-23 21:53:51 Id2ndR removed subscriber Id2ndR
2011-03-13 19:23:01 Pedro Nicolás removed subscriber Pedro Nicolás
2011-08-06 17:23:17 Tom Scholl bug added subscriber Tom Scholl
2012-10-08 09:49:30 Bug Watch Updater qemu (openSUSE): importance Unknown Critical
2012-11-22 08:59:34 Bug Watch Updater usbview (Debian): status New Fix Released
2012-11-22 19:38:46 f5pvg bug added subscriber f5pvg
2012-11-22 19:38:57 f5pvg removed subscriber f5pvg