OpenGL support is disabled

Bug #1553999 reported by Lafa on 2016-03-07
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
qemu (Ubuntu)
Wishlist
Unassigned

Bug Description

$ qemu-system-x86_64 -enable-kvm -display sdl,gl=on -vga qxl
SDL1 display code has no opengl support.
Please recompile qemu with SDL2, using
./configure --enable-sdl --with-sdlabi=2.0
qemu-system-x86_64: OpenGL support is disabled

Can you please recompile qemu with support for opengl. The -display mode allows for opengl support.

Lafa (luis-alves) wrote :

This feature allows for the guest OS to have opengl 2 support, that is require for several 3d applications.
It also opens the way for supporting acceleration on windows and Linux guest systems.

Thomas Huth (th-huth) wrote :

Since you're talking about a pre-compiled binary, I assume you wanted to open this bug against Ubuntu's QEMU package, not against the QEMU project?

affects: qemu → qemu (Ubuntu)
Thiago Martins (martinx) wrote :

Looks like that this bug is duplicate of https://bugs.launchpad.net/ubuntu/+source/qemu/+bug/1540692

Isn't it?

Changed in qemu (Ubuntu):
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qemu (Ubuntu):
status: New → Confirmed
Changed in qemu (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → New
status: New → Incomplete
Changed in qemu (Ubuntu):
status: Incomplete → Confirmed

Opengl in general as requested was enabled and backported up to Bionic (18.04).

There are several usability enhancements to use that with either mdev passthrough and virtgl which I work on upstream and are going into Disco (19.04).

Changed in qemu (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers