Merge 2.0.0+dfsg-2 to fix spice crashes

Bug #1309452 reported by Fantu on 2014-04-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qemu (Ubuntu)
High
Unassigned

Bug Description

Qemu of trusty need update to 2.0.0 final or backport of this patch:
http://git.qemu.org/?p=qemu.git;a=commit;h=dc491cfc14074064ed54a872b62cce6ca1330644
That is needed to solve qemu crash in many cases when using spice.

Fantu (fantonifabio) on 2014-04-18
summary: - Patch to backport to fix qemu crash when using spice
+ Patch to backport to fix Trusty's qemu crash when using spice

Thanks for submitting this bug. I'm uploading based on 2.0 final today.

Changed in qemu (Ubuntu):
importance: Undecided → High
status: New → In Progress
summary: - Patch to backport to fix Trusty's qemu crash when using spice
+ Merge 2.02.0.0+dfsg-2 to fix spice crashes
summary: - Merge 2.02.0.0+dfsg-2 to fix spice crashes
+ Merge 2.0.0+dfsg-2 to fix spice crashes
Serge Hallyn (serge-hallyn) wrote :

For reference, this is the full upstream diff from v2.0.0-rc1 to v2.0.0 final.

Thanks for uploading the fix for this bug report to -proposed. However, when reviewing the package in -proposed and the details of this bug report I noticed that the bug description is missing information required for the SRU process. You can find full details at http://wiki.ubuntu.com/StableReleaseUpdates#Procedure but essentially this bug is missing some of the following: a statement of impact, a test case and details regarding the regression potential. Thanks in advance!

Hello Fantu, or anyone else affected,

Accepted qemu into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/qemu/2.0.0+dfsg-2ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Fantu (fantonifabio) wrote :

Thanks.
I confirm that crashes with spice have been solved since I installed qemu 2.0-rc2 from source.
About the Trusty's qemu package qemu I cannot try it now, I'll use it when I'll migrate my work laptop to Trusty, perhaps one of the following weekends.
However qemu 2.0 defined by including the patches I already tested certainly solves crashes with spice.

Serge Hallyn (serge-hallyn) wrote :

Ran a utopic livecd over spice for some time and had a minion play a game of sudoku on it, all worked well.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qemu - 2.0.0+dfsg-2ubuntu2

---------------
qemu (2.0.0+dfsg-2ubuntu2) utopic; urgency=medium

  * debian/rules: install the proper /etc/init/qemu-kvm.conf (LP: #1315402)
  * debian/control: drop the versioning requirement from libfdt-dev
    build-dependency, as it is longer needed (LP: #1295072)
 -- Serge Hallyn <email address hidden> Fri, 02 May 2014 11:43:44 -0500

Changed in qemu (Ubuntu):
status: In Progress → Fix Released

The verification of the Stable Release Update for qemu has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers