[ppa 2.0~git-20140225] mouse cursor invisible with Ubuntu live system

Bug #1285508 reported by Martin Pitt on 2014-02-27
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
qemu (Ubuntu)
Medium
Unassigned

Bug Description

As requested on u-devel@, I tested QEMU 2.0~git-20140225.aa0d1f4-0ubuntu2 from ppa:ubuntu-virt/candidate. This has a regression with the mouse cursor.

I downloaded the current Ubuntu Desktop trusty beta-1 amd64 image, and booted it in QEMU:

  $ kvm -m 2048 -cdrom trusty-desktop-amd64.iso

This boots fine, but in the desktop I don't see any mouse cursor.

Serge Hallyn (serge-hallyn) wrote :

Interestingly this only happens with sdl. Using vga it works fine.

It also works fine in qxl/spice (qemu ... -spice disable-ticketing,port=5930; spicy -h localhost -p 5930).

Changed in qemu (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Huck-bernhard (huck-bernhard) wrote :

i have the same, I don't see any mouse cursor. System is working.

Host: Ubuntu release 14.04 x86_64
Gast: Ubuntu release 14.04 x86_64

Graphic: GeForce GTX 650 Ti BOOST/PCIe/SSE2
Driver: nvidia 331.38

Huck-bernhard (huck-bernhard) wrote :

there are my terminal commands:

$ qemu-img create -f qcow2 BOOTSYSTEM.img 10G
$ qemu-system-x86_64 -enable-kvm -hda BOOTSYSTEM.img -cdrom /dev/cdrom -boot d -m 1024

Martin Pitt (pitti) wrote :

I still regularly get this. The workaround is to open a terminal, which causes the cursor shape to change. Once that is done, the cursor stays visible.

Serge Hallyn (serge-hallyn) wrote :

Hi Martin,

when you get this, I assume that is with the standard trusty or utopic package?

I ask because the subject says 'ppa' - i'd like to remove that.

Martin Pitt (pitti) wrote :

It's actually fine for me with current utopic's 2.1+dfsg-2ubuntu2. I tested both the default graphics card as well as "-vga vmware".

Changed in qemu (Ubuntu):
status: Triaged → Fix Released
Thomas Huth (th-huth) on 2016-10-27
no longer affects: qemu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers