qemu-s390x-static: segmentation fault entering chroot

Bug #1256546 reported by Ken Sharp on 2013-11-30
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned
qemu (Debian)
Fix Released
Unknown
qemu (Ubuntu)
Medium
Unassigned

Bug Description

Host: Ubuntu Trusty i386
Guest: Debian Sid s390x

When attempting to debootstrap a Debian Sid s390x guest the second stage process immediately fails with a segmentation fault, and any subsequent attempts to run any command while in the chroot.

I: Running command: chroot s390x /debootstrap/debootstrap --second-stage
Segmentation fault (core dumped)
# chroot s390x/
# ps
Segmentation fault (core dumped)
# ls
Segmentation fault (core dumped)
# exit
exit

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: qemu-user-static 1.6.0+dfsg-2ubuntu4
ProcVersionSignature: Ubuntu 3.12.0-4.12-generic 3.12.1
Uname: Linux 3.12.0-4-generic i686
ApportVersion: 2.12.7-0ubuntu1
Architecture: i386
Date: Sat Nov 30 18:19:59 2013
InstallationDate: Installed on 2013-11-29 (1 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20131126)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: qemu
UpgradeStatus: No upgrade log present (probably fresh install)

Ken Sharp (kennybobs) wrote :
Serge Hallyn (serge-hallyn) wrote :

Thanks for reporting this bug - could you please re-test with the 1.7
version now in trusty and let us know if that fixes it?

Could you please give the precise full command you used?

Changed in qemu (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Ken Sharp (kennybobs) wrote :

Version: 1.7.0+dfsg-2ubuntu3

No change.

Changed in qemu (Ubuntu):
status: Incomplete → New

reproduced with:

sudo qemu-debootstrap --verbose --components=main,universe --arch=s390x stable x

Changed in qemu (Ubuntu):
status: New → Triaged
Serge Hallyn (serge-hallyn) wrote :

Also reproduced with today's git HEAD, after doing

git clone git://git.qemu.org/qemu.git
cd qemu
./configure --target-list=s390x-linux-user --static --disable-system
make clean && make -j4
sudo cp s390x-linux-user/qemu-s390x /usr/bin/qemu-s390x-static
sudo qemu-debootstrap --verbose --components=main,universe --arch=s390x stable y

Ken Sharp (kennybobs) on 2014-01-15
Changed in qemu:
status: New → Confirmed
Ken Sharp (kennybobs) wrote :

Version: 1.5.0+dfsg-3ubuntu5.2

This doesn't occur in version 1.5.0 in Saucy. Regression?

The second stage fails anyway because it claims it cannot find /debootstrap/debootstrap which is similar to other open bugs, but there is no segfault.

tags: added: regression-release
Peter Maydell (pmaydell) wrote :

Does this patch fix this issue? http://patchwork.ozlabs.org/patch/309529/

Ken Sharp (kennybobs) wrote :

It certainly does!

Changed in qemu (Debian):
status: Unknown → New
Changed in qemu (Debian):
status: New → Fix Committed
Changed in qemu (Debian):
status: Fix Committed → Fix Released
Serge Hallyn (serge-hallyn) wrote :

This fix is upstream, so it will be pulled in when we switch to qemu 2.0 in 14.04.

Changed in qemu (Ubuntu):
status: Triaged → Fix Committed
Changed in qemu:
status: Confirmed → Fix Released
Changed in qemu (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.