i386 qemu-user-static package should not have x86_64 binfmt support

Bug #1319296 reported by Rex Tsai on 2014-05-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qemu-linaro (Ubuntu)
Undecided
Unassigned

Bug Description

The current qemu-user-static:i386 installed an amd64 binfmt support config, which caused all amd64 binary on a qemu-user-static guest or host are all executed by /usr/bin/qemu-x86_64-static.

Since you can install qemu-user-static:i386 on a x86_64 host, this caused the host crashed.

Solutions are -
1. filter out x86_64 for i386 platform. (as patch)
2. Do not install any binfmt-support target which matching `uname-m' and current userspace.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: qemu-user-static:i386 1.0.50-2012.03-0ubuntu2.1
ProcVersionSignature: Ubuntu 3.2.0-61.93-generic 3.2.55
Uname: Linux 3.2.0-61-generic x86_64
NonfreeKernelModules: btrfs zlib_deflate libcrc32c ufs qnx4 hfsplus hfs minix ntfs vfat msdos fat jfs xfs reiserfs binfmt_misc ip6table_filter ip6_tables ebtable_nat ebtables xt_state xt_CHECKSUM veth kvm_intel kvm ipt_LOG ipt_MASQUERADE iptable_raw iptable_nat ipt_REJECT xt_comment xt_addrtype bridge stp xt_mark xt_multiport xt_conntrack nf_nat_tftp nf_nat_snmp_basic nf_conntrack_snmp nf_nat_sip nf_nat_pptp nf_nat_proto_gre nf_nat_irc nf_nat_h323 nf_nat_ftp nf_nat_amanda nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 ts_kmp nf_conntrack_amanda nf_conntrack_sane nf_conntrack_tftp nf_conntrack_sip nf_conntrack_proto_sctp nf_conntrack_pptp nf_conntrack_proto_gre nf_conntrack_netlink nfnetlink nf_conntrack_netbios_ns nf_conntrack_broadcast nf_conntrack_irc nf_conntrack_h323 nf_conntrack_ftp nf_conntrack iptable_filter xt_TCPMSS xt_tcpmss xt_tcpudp iptable_mangle ip_tables x_tables pppoe pppox ext2 option usb_wwan psmouse usbserial hpwdt serio_raw hpilo joydev mac_hid lp parport usb_storage usbhid hid e1000e
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: amd64
Date: Wed May 14 16:09:02 2014
Dependencies:

MarkForUpload: True
PackageArchitecture: i386
ProcEnviron:
 LC_CTYPE=zh_TW.UTF-8
 TERM=xterm
 PATH=(custom, no user)
 LANG=zh_TW.UTF-8
 SHELL=/bin/zsh
SourcePackage: qemu-linaro
UpgradeStatus: No upgrade log present (probably fresh install)

Rex Tsai (chihchun) wrote :
Steve Langasek (vorlon) wrote :

This is already fixed in later releases of Ubuntu in the 'qemu' (rather than 'qemu-linaro') source package. While this is a genuine issue, one does not normally install qemu-user-static:i386 on an amd64 host system, so we are probably not going to fix this for 12.04 now that 14.04 LTS is out.

Rex Tsai (chihchun) wrote :

Yes, this issue has been fixed in 14.04LTS.

The qemu-user-static:i386 works better on other embedded system (armhf and sh4 in my case). It does cause the system to hang, the user have to remove the qemu package from console to recover the system.

Should it be consinder as high-impact bug for SRU?

Ken Sharp (kennybobs) on 2018-08-17
Changed in qemu-linaro (Ubuntu):
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers