spice: lack of initial boot display and mouse scroll events

Bug #1032277 reported by Jamin W. Collins on 2012-08-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qemu-linaro (Ubuntu)
Undecided
Unassigned

Bug Description

I apologize if this is not the proper package for these two issues. Feel free to reassign if necessary.

I've recently moved one of my virts over to using spice. For the most part things are working well. There are however a few areas of concern:

- no display output prior to X starting within the guest
- no mouse scroll events

The virt is an up to date 12.04 64-bit desktop installation. There is absolutely no display output from it prior to X starting. This is more than a little bit of a problem as the guest is using full disk encryption and needs a passphrase entered to unlock the volume. For now, I've simply been waiting and blindly entering the phrase, which has worked so far. However, I can see this failing badly as soon as there is any issue with the guest startup and any interaction is necessary to fix it.

As for the scroll events, I've tried an upstream patch: http://<email address hidden>/msg08429.html. It doesn't appear to have had any impact on the issue. No scroll events are received by the guest, I've checked using xev within the guest.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: qemu-kvm-spice 1.0.50-2012.03-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-7.7-generic 3.5.0
Uname: Linux 3.5.0-7-generic x86_64
ApportVersion: 2.0.1-0ubuntu11
Architecture: amd64
Date: Thu Aug 2 09:08:42 2012
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: qemu-linaro
UpgradeStatus: Upgraded to precise on 2012-04-27 (96 days ago)

Jamin W. Collins (jcollins) wrote :
Jamin W. Collins (jcollins) wrote :

Any acknowledgement/update?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers