Activity log for bug #1030594

Date Who What changed Old value New value Message
2012-07-29 19:07:36 dann frazier bug added bug
2012-07-29 19:23:18 Launchpad Janitor branch linked lp:~dannf/qemu-linaro/highbank
2012-07-30 15:13:20 dann frazier branch unlinked lp:~dannf/qemu-linaro/highbank
2012-07-30 15:27:19 Launchpad Janitor branch linked lp:~dannf/qemu-linaro/highbank
2012-07-31 19:16:07 Dave Walker nominated for series Ubuntu Precise
2012-07-31 19:16:07 Dave Walker bug task added qemu-linaro (Ubuntu Precise)
2012-07-31 19:16:07 Dave Walker nominated for series Ubuntu Quantal
2012-07-31 19:16:07 Dave Walker bug task added qemu-linaro (Ubuntu Quantal)
2012-07-31 19:19:25 Dave Walker bug added subscriber Ubuntu Sponsors Team
2012-08-16 18:34:41 Bryce Harrington description Please add a build-dep on libfdt-dev, which will add flat device tree support to qemu. This will let users pass the '-dtb' command line option, allowing us to specify a device tree file. Though it is supposedly possible to pass a dtb file to the instance by appending it to the zImage, I've been unable to get this to work (even with CONFIG_ARM_APPENDED_DTB=y). The -dtb method is more straightforward and I've been able to boot a highbank target with it (and the patch referenced in #1030588): ubuntu@server-1343577662-az-3-region-a-geo-1:~$ sudo qemu-system-arm -nographic -M highbank -m 4089 -kernel ~/vmlinuz-3.2.0-2000-highbank -append console=ttyAMA0 -dtb ~/highbank.dtb l2x0_priv_write: Bad offset 900 l2x0_priv_write: Bad offset 904 Booting Linux on physical CPU 0 Linux version 3.2.0-2000-highbank (buildd@nikusui) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu3) ) #1-Ubuntu SMP PREEMPT Tue Mar 27 01:49:53 UTC 2012 (Ubuntu 3.2.0-2000.1-highbank 3.2.12) CPU: ARMv7 Processor [410fc090] revision 0 (ARMv7), cr=10c5387d [...] [Impact] [Fix] [Test Case] [Regression Potential] [Original Report] Please add a build-dep on libfdt-dev, which will add flat device tree support to qemu. This will let users pass the '-dtb' command line option, allowing us to specify a device tree file. Though it is supposedly possible to pass a dtb file to the instance by appending it to the zImage, I've been unable to get this to work (even with CONFIG_ARM_APPENDED_DTB=y). The -dtb method is more straightforward and I've been able to boot a highbank target with it (and the patch referenced in #1030588): ubuntu@server-1343577662-az-3-region-a-geo-1:~$ sudo qemu-system-arm -nographic -M highbank -m 4089 -kernel ~/vmlinuz-3.2.0-2000-highbank -append console=ttyAMA0 -dtb ~/highbank.dtb l2x0_priv_write: Bad offset 900 l2x0_priv_write: Bad offset 904 Booting Linux on physical CPU 0 Linux version 3.2.0-2000-highbank (buildd@nikusui) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu3) ) #1-Ubuntu SMP PREEMPT Tue Mar 27 01:49:53 UTC 2012 (Ubuntu 3.2.0-2000.1-highbank 3.2.12) CPU: ARMv7 Processor [410fc090] revision 0 (ARMv7), cr=10c5387d [...]
2012-08-16 21:19:10 dann frazier description [Impact] [Fix] [Test Case] [Regression Potential] [Original Report] Please add a build-dep on libfdt-dev, which will add flat device tree support to qemu. This will let users pass the '-dtb' command line option, allowing us to specify a device tree file. Though it is supposedly possible to pass a dtb file to the instance by appending it to the zImage, I've been unable to get this to work (even with CONFIG_ARM_APPENDED_DTB=y). The -dtb method is more straightforward and I've been able to boot a highbank target with it (and the patch referenced in #1030588): ubuntu@server-1343577662-az-3-region-a-geo-1:~$ sudo qemu-system-arm -nographic -M highbank -m 4089 -kernel ~/vmlinuz-3.2.0-2000-highbank -append console=ttyAMA0 -dtb ~/highbank.dtb l2x0_priv_write: Bad offset 900 l2x0_priv_write: Bad offset 904 Booting Linux on physical CPU 0 Linux version 3.2.0-2000-highbank (buildd@nikusui) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu3) ) #1-Ubuntu SMP PREEMPT Tue Mar 27 01:49:53 UTC 2012 (Ubuntu 3.2.0-2000.1-highbank 3.2.12) CPU: ARMv7 Processor [410fc090] revision 0 (ARMv7), cr=10c5387d [...] [Impact] No known way to use the highbank model at the moment. [Fix] Add a build-dep on libfdt-dev. [Test Case] On an amd64 system w/ > 4G of RAM: $ sudo qemu-system-arm -nographic -M highbank -m 4089 -kernel ~/vmlinuz-3.2.0-2000-highbank -append console=ttyAMA0 -dtb ~/highbank.dtb You can use the vmlinuz and highbank.dtb files from the latest linux-image-XXX-highbank package. [Regression Potential] CONFIG_FDT, in most cases, is compiling in code to execute when -dtb is specified, instead of the current behavior of printing an error. In these cases, the risk of regression is low because if you weren't specifying -dtb before, nothing will be different. There are models, however, that have different behavior if CONFIG_FDT is undefined. These are petalogix_s3adsp1800_mmu, petalogix_ml605_mmu, and virtex_ml507. In these cases, it simply passes the device tree blob directly to the kernel. So, it is a risk on these models that the kernel was able to successfully handle the dtb processing, but the QEMU code we are now enabling does not. Finally, there's simply the risk that comes along with adding a new library dependency - it could introduce a FTBFS on some architectures, for example. [Original Report] Please add a build-dep on libfdt-dev, which will add flat device tree support to qemu. This will let users pass the '-dtb' command line option, allowing us to specify a device tree file. Though it is supposedly possible to pass a dtb file to the instance by appending it to the zImage, I've been unable to get this to work (even with CONFIG_ARM_APPENDED_DTB=y). The -dtb method is more straightforward and I've been able to boot a highbank target with it (and the patch referenced in #1030588): ubuntu@server-1343577662-az-3-region-a-geo-1:~$ sudo qemu-system-arm -nographic -M highbank -m 4089 -kernel ~/vmlinuz-3.2.0-2000-highbank -append console=ttyAMA0 -dtb ~/highbank.dtb l2x0_priv_write: Bad offset 900 l2x0_priv_write: Bad offset 904 Booting Linux on physical CPU 0 Linux version 3.2.0-2000-highbank (buildd@nikusui) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu3) ) #1-Ubuntu SMP PREEMPT Tue Mar 27 01:49:53 UTC 2012 (Ubuntu 3.2.0-2000.1-highbank 3.2.12) CPU: ARMv7 Processor [410fc090] revision 0 (ARMv7), cr=10c5387d [...]
2012-08-20 14:11:43 Fathi Boudra bug added subscriber Fathi Boudra
2012-08-20 14:37:58 Fathi Boudra qemu-linaro (Ubuntu Quantal): assignee Fathi Boudra (fboudra)
2012-08-20 14:39:50 Fathi Boudra qemu-linaro (Ubuntu Quantal): status New Confirmed
2012-08-21 14:58:28 Fathi Boudra qemu-linaro (Ubuntu Quantal): status Confirmed In Progress
2012-08-21 14:58:11 Launchpad Janitor branch linked lp:~fboudra/qemu-linaro/new-upsrtream-release-1.1.50-2012.08-0ubuntu1
2012-09-07 07:01:10 Fathi Boudra branch unlinked lp:~dannf/qemu-linaro/highbank
2012-09-07 07:02:26 Fathi Boudra summary enable flat device tree support [FFE] enable flat device tree support
2012-09-07 07:02:36 Fathi Boudra bug added subscriber Ubuntu Release Team
2012-09-11 16:16:42 Micah Gersten bug added subscriber Micah Gersten
2012-09-11 16:16:44 Micah Gersten removed subscriber Ubuntu Sponsors Team
2012-09-11 16:16:46 Micah Gersten qemu-linaro (Ubuntu Quantal): status In Progress New
2012-09-11 16:16:49 Micah Gersten qemu-linaro (Ubuntu Quantal): assignee Fathi Boudra (fboudra)
2012-09-15 07:29:15 Fathi Boudra branch linked lp:~fboudra/qemu-linaro/new-upstream-release-1.2.0-2012.09-0ubuntu1
2012-09-16 10:34:27 Iain Lane removed subscriber Ubuntu Release Team
2012-09-16 10:34:36 Iain Lane bug added subscriber Ubuntu Sponsors Team
2012-09-17 21:34:02 Kate Stewart qemu-linaro (Ubuntu Quantal): status New Triaged
2012-09-28 15:28:19 St├ęphane Graber qemu-linaro (Ubuntu Quantal): status Triaged Fix Released
2012-09-28 15:39:00 Michael Vogt qemu-linaro (Ubuntu Precise): status New In Progress
2012-09-28 15:39:01 Michael Vogt qemu-linaro (Ubuntu Precise): importance Undecided Medium
2012-09-28 18:47:39 St├ęphane Graber removed subscriber Ubuntu Sponsors Team
2012-10-03 17:26:00 Adam Conrad qemu-linaro (Ubuntu Precise): status In Progress Fix Committed
2012-10-03 17:26:03 Adam Conrad bug added subscriber Ubuntu Stable Release Updates Team
2012-10-03 17:26:05 Adam Conrad bug added subscriber SRU Verification
2012-10-03 17:26:13 Adam Conrad tags verification-needed
2012-10-03 19:45:19 dann frazier tags verification-needed verification-done
2012-10-10 18:43:36 Adam Conrad removed subscriber Ubuntu Stable Release Updates Team
2012-10-10 18:44:10 Launchpad Janitor qemu-linaro (Ubuntu Precise): status Fix Committed Fix Released