cannot build xorg-xserver inside an armhf pbuilder chroot

Bug #1019438 reported by Matt Fischer on 2012-06-29
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Linaro QEMU
Fix Released
Undecided
Unassigned
qemu-linaro (Ubuntu)
Undecided
Unassigned
Precise
Medium
Unassigned

Bug Description

I'm attempting to build the precise xorg-xserver on an amd64 host using an armhf chroot. I'm pretty sure this worked last week, but I can no longer prove that since it definitely does not work now.

I am attempting to build xorg-7.6+12ubuntu1 and it fails fairly quickly.

The chroot hangs here:
perl: warning: Falling back to the standard locale ("C").
qemu-arm-static: /build/buildd/qemu-linaro-1.0.50-2012.03/user-exec.c:100: handle_cpu_signal: Assertion `({ unsigned long __guest = (unsigned long)(address) - guest_base; (__guest < (1ul << 32)) && (!reserved_va || (__guest < reserved_va)); })' failed.

I cannot seem to run strace, but I'm happy to gather whatever other info you need:
root@caprica:~/Projects/precise-armhf/xserver-xorg/xorg-7.6+12ubuntu1# strace dpkg-buildpackage
qemu: Unsupported syscall: 26
strace: ptrace(PTRACE_TRACEME, ...): Function not implemented

I'm using the ubuntu version which has superseded the linaro version.

qemu-user-static:
  Installed: 1.0.50-2012.03-0ubuntu2
  Candidate: 1.0.50-2012.03-0ubuntu2
  Version table:

Peter Maydell (pmaydell) wrote :

This bug was fixed in qemu-linaro 2012.05.

Changed in qemu-linaro:
status: New → Fix Released
Chris J Arges (arges) wrote :

I hit this bug on my precise amd64 machine trying to compile an armhf package using sbuild.

qemu-arm-static: /build/buildd/qemu-linaro-1.0.50-2012.03/user-exec.c:100: handle_cpu_signal: Assertion `({ unsigned long __guest = (unsigned long)(address) - guest_base; (__guest < (1ul << 32)) && (!reserved_va || (__guest < reserved_va)); })' failed.

Can we get this fix backported to precise?

Changed in qemu-linaro (Ubuntu Precise):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qemu-linaro (Ubuntu Precise):
status: New → Confirmed
Changed in qemu-linaro (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers