crash at start guest on Ubuntu12.04 64bit host

Bug #978320 reported by Christoph on 2012-04-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
qemu-kvm (Ubuntu)
Undecided
Unassigned

Bug Description

kernel reportet cash at starting vm.

 [ 682.151774] ------------[ cut here ]------------
 [ 682.151847] kernel BUG at /build/buildd/linux-3.2.0/arch/x86/kvm/../../../virt/kvm/kvm_main.c:2367!
 [ 682.151971] invalid opcode: 0000 [#1] SMP
 [ 682.152005] CPU 0
 [ 682.152005] Modules linked in: kvm_amd kvm ip6table_filter ip6_tables ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack ipt_REJECT xt_CHECKSUM iptable_mangle xt_tcpudp iptab
le_filter ip_tables x_tables bridge 8021q garp stp mxm_wmi edac_core edac_mce_amd s3fb psmouse serio_raw svgalib fb_ddc i2c_algo_bit k10temp vgastate video wmi mac_hid i2c_nforce2 lp parport raid10 raid456 async_pq async_xor xor async_me
mcpy async_raid6_recov usb_storage e1000e pata_amd raid6_pq async_tx raid1 raid0 multipath linear [last unloaded: kvm]
 [ 682.152005]
 [ 682.152005] Pid: 2877, comm: kvm Not tainted 3.2.0-22-generic #35-Ubuntu To Be Filled By O.E.M. To Be Filled By O.E.M./K10N78hSLI-GLAN
 [ 682.152005] RIP: 0010:[<ffffffffa015e7b9>] [<ffffffffa015e7b9>] kvm_spurious_fault+0x9/0x10 [kvm]
 [ 682.152005] RSP: 0018:ffff88020ecb9d00 EFLAGS: 00010046
 [ 682.152005] RAX: ffff8802101da000 RBX: ffff880211ee0000 RCX: ffff880211ee0000
 [ 682.152005] RDX: 0000000000000000 RSI: 0000000000000000 RDI: ffff880211ee0000
 [ 682.152005] RBP: ffff88020ecb9d00 R08: 0000000000000000 R09: ffff88020ecd8910
 [ 682.152005] R10: 0000000000000001 R11: 0000000000000000 R12: ffff88020fc15bc0
 [ 682.152005] R13: 0000000000000000 R14: 0000000000000000 R15: ffff88020fc15bc0
 [ 682.152005] FS: 00007fce49d12700(0000) GS:ffff88021fc00000(0000) knlGS:0000000000000000
 [ 682.152005] CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b
 [ 682.152005] CR2: 00007f32d5917b50 CR3: 0000000210127000 CR4: 00000000000006f0
 [ 682.152005] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
 [ 682.152005] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
 [ 682.152005] Process kvm (pid: 2877, threadinfo ffff88020ecb8000, task ffff88020fc15bc0)
 [ 682.152005] Stack:
 [ 682.152005] ffff88020ecb9d58 ffffffffa027c0eb ffffffffa0277dec ffff88020ecb9d38
 [ 682.152005] ffff880211ee0000 ffff880211ee0000 ffff880211ee0000 ffff88020fc15bc0
 [ 682.152005] 0000000000000000 0000000000000000 ffff88020fc15bc0 ffff88020ecb9d98
 [ 682.152005] Call Trace:
 [ 682.152005] [<ffffffffa027c0eb>] cr8_write_interception+0x10b/0x16b [kvm_amd]
 [ 682.152005] [<ffffffffa0277dec>] ? svm_vcpu_run+0x11c/0x4a0 [kvm_amd]
 [ 682.152005] [<ffffffffa0178745>] vcpu_enter_guest+0x165/0x590 [kvm]
 [ 682.152005] [<ffffffffa01790f8>] __vcpu_run+0x158/0x2d0 [kvm]
 [ 682.152005] [<ffffffffa01792ee>] kvm_arch_vcpu_ioctl_run+0x7e/0x150 [kvm]
 [ 682.152005] [<ffffffffa0162182>] kvm_vcpu_ioctl+0x4e2/0x780 [kvm]
 [ 682.152005] [<ffffffffa0162eed>] ? kvm_vm_ioctl+0x23d/0x300 [kvm]
 [ 682.152005] [<ffffffff81189cfa>] do_vfs_ioctl+0x8a/0x340
 [ 682.152005] [<ffffffff810a0b4a>] ? sys_futex+0x10a/0x1a0
 [ 682.152005] [<ffffffff8118a041>] sys_ioctl+0x91/0xa0
 [ 682.152005] [<ffffffff81664a82>] system_call_fastpath+0x16/0x1b
 [ 682.152005] Code: c8 c4 00 00 48 8b 80 38 e0 ff ff a8 08 75 02 5d c3 e8 ec ba 4f e1 5d c3 66 2e 0f 1f 84 00 00 00 00 00 55 48 89 e5 66 66 66 66 90 <0f> 0b 0f 1f 44 00 00 55 48 89 e5 53 48 83 ec 08 66 66 66 66 90
 [ 682.152005] RIP [<ffffffffa015e7b9>] kvm_spurious_fault+0x9/0x10 [kvm]
 [ 682.152005] RSP <ffff88020ecb9d00>
 [ 682.152005] ---[ end trace eab60f55ece26a10 ]---

 vendor_id : AuthenticAMD
 cpu family : 16
 model : 2
 model name : AMD Phenom(tm) 9550 Quad-Core Processor

ProblemType: Bug
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
Uname: Linux 3.2.0-22-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/25/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.00
dmi.board.name: K10N78hSLI-GLAN
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.00:bd04/25/2008:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvn:rnK10N78hSLI-GLAN:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
---
AplayDevices: Error: [Errno 2] No such file or directory
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CRDA: Error: [Errno 2] No such file or directory
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=d3b4cd4a-99bf-46eb-912a-2e14537a0d15
InstallationMedia: Ubuntu-Server 12.04 LTS "Precise Pangolin" - Beta amd64 (20120327)
KvmCmdLine: Error: command ['ps', '-C', 'kvm', '-F'] failed with exit code 1: UID PID PPID C SZ RSS PSR STIME TTY TIME CMD
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
Package: qemu-kvm 1.0+noroms-0ubuntu10
PackageArchitecture: amd64
PciMultimedia:

ProcEnviron:
 TERM=screen
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcFB: 0 S3 Trio64V2/DX
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-22-generic root=UUID=63bb1f33-7c41-4316-81e3-025fb08e8e48 ro
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
RfKill: Error: [Errno 2] No such file or directory
Tags: precise precise
Uname: Linux 3.2.0-22-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

WifiSyslog:

dmi.bios.date: 04/25/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.00
dmi.board.name: K10N78hSLI-GLAN
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.00:bd04/25/2008:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvn:rnK10N78hSLI-GLAN:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
---
AlsaDevices:
 total 0
 crw-rw---T 1 root audio 116, 1 Apr 11 11:48 seq
 crw-rw---T 1 root audio 116, 33 Apr 11 11:48 timer
AplayDevices: Error: [Errno 2] No such file or directory
ApportVersion: 2.0.1-0ubuntu1
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CRDA: Error: [Errno 2] No such file or directory
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=d3b4cd4a-99bf-46eb-912a-2e14537a0d15
InstallationMedia: Ubuntu-Server 12.04 LTS "Precise Pangolin" - Beta amd64 (20120327)
KvmCmdLine: Error: command ['ps', '-C', 'kvm', '-F'] failed with exit code 1: UID PID PPID C SZ RSS PSR STIME TTY TIME CMD
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 002: ID 13fe:3800 Kingston Technology Company Inc. Rage XT Flash Drive
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
Package: qemu-kvm 1.0+noroms-0ubuntu12
PackageArchitecture: amd64
PciMultimedia:

ProcEnviron:
 TERM=screen
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcFB: 0 S3 Trio64V2/DX
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-22-generic root=UUID=63bb1f33-7c41-4316-81e3-025fb08e8e48 ro
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
RfKill: Error: [Errno 2] No such file or directory
Tags: precise precise
Uname: Linux 3.2.0-22-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 04/25/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.00
dmi.board.name: K10N78hSLI-GLAN
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.00:bd04/25/2008:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvn:rnK10N78hSLI-GLAN:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.

Christoph (chr-istoph) wrote :
Serge Hallyn (serge-hallyn) wrote :

 [ 682.152005] Pid: 2877, comm: kvm Not tainted 3.2.0-22-generic #35-Ubuntu To Be Filled By O.E.M. To Be Filled By O.E.M./K10N78hSLI-GLAN

?

Serge Hallyn (serge-hallyn) wrote :

@Christoph,

thanks for submitting this bug. Did you just install precise? If not, is it up to date? Can you tell us exactly how you started kvm?

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 978320

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: precise
Christoph (chr-istoph) wrote :

@Serge I have install precise at a new hard disk. Everything is up to date. I start it with virt-manager or virsh. If I start the machin, after 2 Secons it crash.

Hier is my one of my vms:
<domain type='kvm'>
  <name>ubuntu</name>
  <uuid>ea3ac3c6-93d0-b174-97dc-e3e2827e051f</uuid>
  <memory>1048576</memory>
  <currentMemory>1048576</currentMemory>
  <vcpu>1</vcpu>
  <os>
    <type arch='x86_64' machine='pc-1.0'>hvm</type>
    <boot dev='cdrom'/>
    <boot dev='hd'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <devices>
    <emulator>/usr/bin/kvm</emulator>
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw'/>
      <source file='/mnt/md0/kvm/ubuntu.img'/>
      <target dev='vda' bus='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
    </disk>
    <disk type='block' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <target dev='hdc' bus='ide'/>
      <readonly/>
      <address type='drive' controller='0' bus='1' unit='0'/>
    </disk>
    <controller type='ide' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
    </controller>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='-1' autoport='yes'/>
    <video>
      <model type='cirrus' vram='9216' heads='1'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>
    <memballoon model='virtio'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x0'/>
    </memballoon>
  </devices>
</domain>

Serge Hallyn (serge-hallyn) wrote :

Thanks, Christoph.

 [ 682.152005] [<ffffffffa027c0eb>] cr8_write_interception+0x10b/0x16b [kvm_amd]
 [ 682.152005] [<ffffffffa0277dec>] ? svm_vcpu_run+0x11c/0x4a0 [kvm_amd]

I unfortunately do not have a amd box to test on, but this looks bad.

Are you able to run apport-collect 978320 as Brad('s bot) asked? I fear we need system details to analyze this further.

Also, if you do:

wget -O precise-mini.iso http://archive.ubuntu.com/ubuntu/dists/precise/main/installer-amd64/current/images/netboot/mini.iso
qemu-img create x.img 1G
kvm -hda x.img -cdrom precise-mini.iso -boot d -m 512

does that also cause a crash?

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in qemu-kvm (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: amd crash

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-23.36

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Christoph (chr-istoph) wrote :

@Serge i have tested your kvm commandline. But it crashed, too.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Christoph (chr-istoph) wrote :
Download full text (4.7 KiB)

Now i retested with current kernel using command line
kvm -hda launchpad.img -cdrom precise-mini.iso -boot d -m 512 -curses

The vm hangs showing bios iPXE ... Press Ctrl-B ... message

and it still triggers the kernel BUG:

Apr 11 23:12:21 ba kernel: [ 143.771843] ------------[ cut here ]------------
Apr 11 23:12:21 ba kernel: [ 143.771918] kernel BUG at /build/buildd/linux-3.2.0/arch/x86/kvm/../../../virt/kvm/kvm_main.c:2367!
Apr 11 23:12:21 ba kernel: [ 143.772049] invalid opcode: 0000 [#1] SMP
Apr 11 23:12:21 ba kernel: [ 143.772130] CPU 0
Apr 11 23:12:21 ba kernel: [ 143.772157] Modules linked in: ip6table_filter ip6_tables ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack ipt_REJECT xt_CHECKSUM iptable_mangle xt_tcpudp iptable_filter ip_tables x_tables bridge kvm_amd kvm s3fb svgalib 8021q fb_ddc i2c_algo_bit garp vgastate stp edac_core lp i2c_nforce2 edac_mce_amd psmouse k10temp serio_raw mac_hid parport video mxm_wmi wmi raid10 raid456 async_pq async_xor xor async_memcpy async_raid6_recov e1000e pata_amd usb_storage raid6_pq async_tx raid1 raid0 multipath linear
Apr 11 23:12:21 ba kernel: [ 143.773332]
Apr 11 23:12:21 ba kernel: [ 143.773353] Pid: 2954, comm: kvm Not tainted 3.2.0-23-generic #36-Ubuntu To Be Filled By O.E.M. To Be Filled By O.E.M./K10N78hSLI-GLAN
Apr 11 23:12:21 ba kernel: [ 143.773557] RIP: 0010:[<ffffffffa015c7b9>] [<ffffffffa015c7b9>] kvm_spurious_fault+0x9/0x10 [kvm]
Apr 11 23:12:21 ba kernel: [ 143.773714] RSP: 0018:ffff8802117d1d00 EFLAGS: 00010046
Apr 11 23:12:21 ba kernel: [ 143.773793] RAX: ffff88020db20000 RBX: ffff88020fe18000 RCX: ffff88020fe18000
Apr 11 23:12:21 ba kernel: [ 143.773896] RDX: 0000000000000000 RSI: 0000000000000001 RDI: ffff88020fe18000
Apr 11 23:12:21 ba kernel: [ 143.774000] RBP: ffff8802117d1d00 R08: 0000000000000000 R09: 0000000000000000
Apr 11 23:12:21 ba kernel: [ 143.774105] R10: 0000000000000000 R11: 0000000000000000 R12: ffff88020f85ade0
Apr 11 23:12:21 ba kernel: [ 143.774209] R13: 0000000000000000 R14: 0000000000000000 R15: ffff88020f85ade0
Apr 11 23:12:21 ba kernel: [ 143.774314] FS: 00007fae074e6700(0000) GS:ffff88021fc00000(0000) knlGS:0000000000000000
Apr 11 23:12:21 ba kernel: [ 143.774433] CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b
Apr 11 23:12:21 ba kernel: [ 143.774641] CR2: 00007ffc9d5f4160 CR3: 000000020da68000 CR4: 00000000000006f0
Apr 11 23:12:21 ba kernel: [ 143.774872] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Apr 11 23:12:21 ba kernel: [ 143.775099] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Apr 11 23:12:21 ba kernel: [ 143.775326] Process kvm (pid: 2954, threadinfo ffff8802117d0000, task ffff88020f85ade0)
Apr 11 23:12:21 ba kernel: [ 143.775673] Stack:
Apr 11 23:12:21 ba kernel: [ 143.775787] ffff8802117d1d58 ffffffffa01e60eb ffffffffa01e1dec ffff8802117d1d38
Apr 11 23:12:21 ba kernel: [ 143.775787] ffff88020fe18000 ffff8802117d1d38 ffff88020fe18000 ffff88020f85ade0
Apr 11 23:12:21 ba kernel: [ 143.775787] 0000000000000000 0000000000000000 ffff88020f85ade0 ffff8802117d1d98
Apr 11 23:12:21 ba kernel: [ 143.775787] Call ...

Read more...

Stefan Bader (smb) wrote :

So basically the guest seems to have an unexpected fault while still executing option rom code. The host kernel has code to cause a stack trace in that situation. This is specific to the AMD kvm module. Just that I don't seem to be able to trigger the same on the systems I have access to...

Serge Hallyn (serge-hallyn) wrote :

@Christoph - thanks (for confirming with simple kvm command).

I will try to reproduce as soon as hardware to do so with arrives.

Stefan Bader (smb) wrote :

I am not sure I understand this completely, but for the spurious fault there is a comment in the code saying that virtualization instructions may fail if turned off after reboot but processes using them. Not sure this means reboot of guest or host and if host how processes may use them still...
But anyway, it cannot harm to check. Christoph, when you go into your BIOS, is there some option about virtualization feature of the cpu, and is it turned on?

Christoph (chr-istoph) wrote :

Hello Stefan, Hello Serge

today I finally had the opportunity to update the BIOS. Now it run.

Sorry for your time. I close this bug.

Changed in qemu-kvm (Ubuntu):
status: Confirmed → Invalid
Changed in linux (Ubuntu):
status: Confirmed → Invalid
Changed in linux (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.