qemu refused to run without acceleration

Bug #892050 reported by Serge Hallyn on 2011-11-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qemu-kvm (Ubuntu)
Medium
Serge Hallyn

Bug Description

As of commit 303d4e865b74402b49f52e975c396c952f063e58 (which is included in qemu 0.15 which is in precise) qemu refuses to run with no accelerator.

I believe the solution is to add the new --enable-tcg-interpreter option to configure

Changed in qemu-kvm (Ubuntu):
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Serge Hallyn (serge-hallyn)
status: Confirmed → In Progress
Serge Hallyn (serge-hallyn) wrote :

No, that option does not yet exist in 0.15.0 (but is introduced later in upstream git).

A workaround for now is to specify 'accel=tcg' by hand, i.e. do

    qemu -machine pc,accel=tcg ...

Changed in qemu-kvm (Ubuntu):
importance: High → Medium
Scott Moser (smoser) wrote :

serge said in irc that adding:
 -machine pc,accel=kvm:tcg

will allow the old behavior of accelerated if possible, unaccelerated if not.

Can we possibly add a message about that if the user runs kvm without hardware support? Ie:
  You have invoked kvm but acceleration is not available on this CPU.
  If you want to run with software acceleration (which is much slower)
 add the following arguments to you kvm line.

Generally i don't like the upstream decision, but probably not worth carrying delta for it. The case that will catch people is where they're testing some software that goes through libvirt or another abstraction layer. They were getting the software path through 'kvm' and were fine with it being slow. Devstack is an example of this. Often times I would just tell openstack to use libvirt-kvm because that would work fast if available and slowly if it was not. Now, people will have to build the logic of "if i have hardware acceleration, then invoke qemu-system-x86, otherwise, invoke kvm" further up in the stack.

Serge Hallyn (serge-hallyn) wrote :

@smoser,

as suggested by jdstrand, we will carry a patch until 12.04 to not change the behavior yet.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qemu-kvm - 0.15.0+noroms-0ubuntu2

---------------
qemu-kvm (0.15.0+noroms-0ubuntu2) precise; urgency=low

  * debian/patches/default-to-tcg.patch: fall back to unaccelerated qemu if
    kvm acceleration is not available. (LP: #892050)
 -- Serge Hallyn <email address hidden> Fri, 18 Nov 2011 09:26:33 -0600

Changed in qemu-kvm (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers