please enable spice support

Bug #828789 reported by Serge Hallyn on 2011-08-18
72
This bug affects 14 people
Affects Status Importance Assigned to Milestone
qemu-kvm (Ubuntu)
Medium
Serge Hallyn
Oneiric
Medium
Unassigned
Precise
Medium
Serge Hallyn
qemu-kvm-spice (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

Once the spice packages are synced from debian, enable spice support in qemu-kvm.

Changed in qemu-kvm (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Serge Hallyn (serge-hallyn) wrote :

Since spice is in universe, we can't have qemu-kvm depend on it. This debdiff creates a new qemu-kvm-spice package which just installs the spice-enabled binaries, called 'kvm-spice' etc.

Dave Walker (davewalker) on 2011-09-13
tags: added: server-o-rs
Changed in qemu-kvm (Ubuntu Oneiric):
milestone: none → ubuntu-11.10-beta-2

The attachment "qemu-spice-sep12.2011.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

This needs an ACK from ubuntu-release at this time. Unsubscribing ubuntu-sponsors. Once you have the ACK, please resubscribe.

Dave Walker (davewalker) on 2011-09-23
Changed in qemu-kvm (Ubuntu):
milestone: ubuntu-11.10-beta-2 → ubuntu-11.10
Dave Walker (davewalker) wrote :

libcelt051-dev doesn't seem to be in Oneiric? the qemu-kvm debdiff still seems to build-depend on spice packages, which means it will dep wait if uploaded, as only main is available in the build env.

At this point, it seems saner to make this a P target - unless we consider it a release blocker.

Changed in qemu-kvm (Ubuntu Oneiric):
status: Confirmed → Incomplete
tags: removed: server-o-rs

The attachment "qemu-spice-sep12.2011.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

@Dave,

hmm, good point. I wonder why it built for me then. Yes, that dependency should be removed.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qemu-kvm (Ubuntu Precise):
status: New → Confirmed

I can't wait for Spice to be in Ubuntu !

There is this PPA: https://launchpad.net/~serge-hallyn/+archive/spice2

If it could help.

Sorry, this repository should be better for Oneiric users:

https://launchpad.net/~bderzhavets/+archive/spice-test

Quoting Fabien Lusseau (<email address hidden>):
> Sorry, this repository should be better for Oneiric users:
>
> https://launchpad.net/~bderzhavets/+archive/spice-test

We can't take that approach for qemu-kvm, since the spice
libraries are in universe. This week I will sync the latest
qemu-kvm into precise, and then add the qemu-kvm-spice package
as per the debdiff already attached to this bug.

Changed in qemu-kvm (Ubuntu Oneiric):
status: Incomplete → Won't Fix
Changed in qemu-kvm (Ubuntu Precise):
status: Confirmed → In Progress
importance: Undecided → Medium
assignee: nobody → Serge Hallyn (serge-hallyn)
Changed in qemu-kvm (Ubuntu Precise):
status: In Progress → Fix Released
Dave Walker (davewalker) on 2011-10-17
summary: - [FFE] please enable spice support
+ please enable spice support
Dave Gilbert (ubuntu-treblig) wrote :

Is there a how-to to use this in Precise? virt-manager doesn't seem to be able to make use of it.

Serge Hallyn (serge-hallyn) wrote :

libvirt and virt-manager integration has not yet been addressed. Start spice-enabled kvm by hand using for example:

kvm-spice -vga qxl -spice 5930,disable-ticketing

and then connect with

spicec -h localhost -p 5930

Dave Gilbert (ubuntu-treblig) wrote :

Thanks Serge,
    That actually needed:

kvm-spice -vga qxl -spice port=5930,disable-ticketing

and for those who've just done that, it's shift-f12 to escape from the spicec window.

It works, but isn't stable; I guess it needs some separate bugs; I got a qxl X server crash in the (upto date precise 32bit) client (very repeatable), and I'm getting lots of drawing artifacts (see http://www.treblig.org/debug/badspice.png )

I guess the server crash should go with the X server - what about the drawing artifacts - do you want those against the X server or kvm-spice or spicec ?

Serge Hallyn (serge-hallyn) wrote :

Thanks, Dave - you're right of course about the proper command line, sorry about that.

I have no idea where the blame for the drawing artifacts will lie, so I would recommend filing against X first and then hitting 'also affects distribution' and choosing spice, and again for kvm-spice.

Note there is a newer version of spice as of this weekend, 0.10.0 - which should have a few bug fixes. Did you reproduce even with that?

Dave Gilbert (ubuntu-treblig) wrote :

Hi Serge,
  See bug 913311 and bug 913314 for the crasher and the corrupt display respectively.
(And yes it's 0.10.0 spicec).

Dave

Eugene San (eugenesan) wrote :

As of 06/03/2012 qemu-kvm (1.0+noroms-0ubuntu6) in Precise is built without spice support.

I've prepared patch that should fix above and add spice support.

Serge Hallyn (serge-hallyn) wrote :

@Eugene

Install the qemu-kvm-spice package, and run kvm-spice.

Spice is rejected for main, and therefore qemu-kvm in main cannot link against it.

Changed in qemu-kvm (Ubuntu Precise):
status: Fix Released → In Progress
Changed in qemu-kvm (Ubuntu Precise):
status: In Progress → Won't Fix
Changed in qemu-kvm-spice (Ubuntu Oneiric):
status: New → Won't Fix
Changed in qemu-kvm-spice (Ubuntu Precise):
status: New → Fix Released
Changed in qemu-kvm (Ubuntu):
milestone: ubuntu-11.10 → none
Changed in qemu-kvm (Ubuntu Oneiric):
milestone: ubuntu-11.10 → none
James Page (james-page) on 2012-04-12
Changed in qemu-kvm (Ubuntu):
status: In Progress → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers